"Open & fill out" doesn't work on NAS-login page (Safari)

So when I want to use 1PW to login to my NAS under 192.168.x.x (or "mynas".local) in Safari, 1PW opens the page, but doesn't fill out the login information. It does if I click the entry one more time in the Safari extension, but not automatically. It works fine with 1PW X, so it seems to be an issue with opening and filling out login information in Safari on these local pages (local because all other websites work fine).

I have deleted the complete entry and created a new login, with no success.

Any ideas what else I could be trying? By the way, it makes no difference whether I click "open and fill out" in the main application, or the extension.

Thanks!


1Password Version: 7.2.6
Extension Version: 7.2.6
OS Version: macOS 10.14.5
Sync Type: 1PW account

Comments

  • LarsLars Junior Member

    Team Member

    @MrSnrub - I'm sorry for the trouble. When you say you created a new login, what method did you use? The usual method for creating a Login item in 1Password is to visit the site's login page and enter your details manually, then allow the 1Password extension to capture the details for you, as outlined here. If that doesn't work for you, I'd recommend trying the manual method of saving a Login. See how that works for you. :)

  • Hi Lars - sorry, I didn't mention that: I actually tried both methods! I also applied the manual method in the main application, creating a new login there - same result.

  • LarsLars Junior Member

    Team Member

    @MrSnrub - thanks for the clarification. This is going to be difficult for us to verify, since we can't test your internal setup. However, 1Password 7 for Mac is filling my own internal server Login pages just fine here in my household setup. Is your local NAS login possibly a pop-up that drops down from the top of your browser window?

  • MrSnrubMrSnrub
    edited May 23

    @Lars: no, it's a login page that opens like any website, not a dropdown window.

    The weird thing is: I know this has worked before in Safari for my NAS login (can't remember when though). I just had the tendency to manually enter the login, because I could remember the passphrase. Now I've gotten lazy and wanted to use 1 PW for this login too. So I think my issue has been introduced in the meantime.

    Well I was expecting you to come to my house and test my setup, but oh well (just kidding). Tell me what to test and I'll do it.

  • LarsLars Junior Member

    Team Member

    @MrSnrub - would you mind sharing what model NAS this is? One of our team might have something similar, though we don't have access to every model under the sun.

  • It's a Synology DS 218play, with the latest DSM version 6.2.2-24922.

  • Hi @MrSnrub,

    I've got a Synology NAS myself although I haven't updated to 6.2.2 yet, I haven't been in a hurry given I think they pulled the update once or twice and I figure wait to make sure there isn't a flood of outcry.

    Something odd is happening but I'm finding it quite intermittent and if it doesn't happen immediately after a clean start of Safari I find it fills consistently as part of open-and-fill. If it doesn't work the first time I find I can reproduce the result but even then there are caveats. I wonder if you can try the following and let me know what you observe.

    1. Launch or restart Safari so you have a clean starting point.
    2. From a fresh tab, use the keyboard shortcut ⌥⌘\ to access 1Password mini.
    3. Search for your Synology Login item and initiate open-and-fill.
    4. Observe the result.

    If you find in 4. that open-and-fill doesn't perform the fill can you repeat steps 2-4 a couple of times to see if you find things are consistent.

    1. Repeat steps 2-4 from above but this time pick any other site that you have stored in 1Password and you know works with open-and-fill. You should find this works if I've understood how narrow the scope of the issue is.
    2. After 1Password successfully fills, repeat steps 2-4 but this time select the Synology Login item again.

    What I was finding was if 1Password didn't fill that repeated attempts also didn't fill. What makes it weird though is if I used open-and-fill with another Login item when I returned to testing the Synology page it started working and worked reliably. It may also be because I didn't repeat tests sufficient times but I seemed to find clicking the 1Password button in the Safari toolbar seemed to consistently fill when used over the keyboard shortcut, which is my default method of using 1Password.

    Mostly I'm just curious to know if you see similar behaviour. If you do then I can file an issue and I will be intrigued to see if we can understand why this behaviour exists and why only Safari.

  • Thanks @littlebobbytables for your thoughts and hints! Sorry it took my a while to get back to you.

    So I tried what you suggested (closing and re-opening Safari, using the shortcut to open 1Password, searching for my NAS, and selecting the entry) and I repeated the steps about 15 times, if not more, but I never got 1PW to correctly autofill the login data upon opening the website. Only if I use the same keyboard shortcut again, but I think that's by design.

    I also tried clicking the 1Password mini icon and locking 1Password before doing what you suggested, to see if that makes any difference.

    I also had no luck after using open-and-fill succesfully on another website and then returning to my NAS page.

  • Hi @MrSnrub,

    Now there will always be bugs and I don't even mind if they are complex, I just wish we had some consistency between our results. If I could only have one item on a wish list for filing bugs it's consistency. The only saving grace with this odd behaviour is at least once the page has loaded you can use the keyboard shortcut to fill. Now it doesn't have convenience of open-and-fill but at least it isn't copy and paste or worse, manually entering credentials. Hopefully we can figure out why it isn't working smoothly with the Synology page.

  • I'm sorry I haven't replied here since a couple of weeks. Where you expecting more information from me?

  • Hi @MrSnrub,

    I wasn't expecting any additional information, I'm not even sure what you provide to be honest but that also sadly means I'm stumped as to why we've not been able to establish any common behaviour.

    I do have one odd question for you though, now I think the defaults for a Synology NAS are for it to use port 5001 for DSM. Can I ask what you have stored in the first website field, the one 1Password will be using for open-and-fill. I'm curious as to the full URL, assuming there's nothing personal or sensitive revealed by it. Where am I going with this? Very recently I was doing some tinkering with reverse proxies and noticed a redirect based on the port. It could be absolutely nothing but given the lack of decent leads I figure its worth asking.

  • Thanks, @littlebobbytables!

    I was checking out ports as one of my first steps. They all have the same result.

    My URL is: https://localipadress(:5001).

    I typed (:5001), because it doesn't matter if I add the port or not.

    Also I tried with just http and port 5000, same thing.

    Don't worry too much about this. I'm pretty sure it will be resolved somehow sometime.

  • Greetings @MrSnrub,

    Yup, I'm stumped as to why we're not seeing similar behaviour then. Lets hope future work has a positive knock-on effect here.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file