Chrome extension broken after update to 7.3

DougCDougC
in Mac

Since an automatic update to yesterday the Chrome extension is completely non-functional. Opening 1Password mini while Chrome is the front application prompts to install the Chrome extension, which is already installed. Removing and reinstalling the Chrome extension has no effect. This appears to have been mentioned several times on the Chrome extension page (below), but I didn't see anything about it on the forum yet. Hopefully this will be resolved very soon!!

https://chrome.google.com/webstore/detail/1password-extension-deskt/aomjjhallfgjeglblehebfpbcfeobpgk

Thanks!
Doug


1Password Version: 1Password 7 Version 7.3 (70300019) Mac App Store
Extension Version: Chrome 4.7.4.90
OS Version: macOS 10.14.5 (18F132)
Sync Type: 1Password Account

«1

Comments

  • MrRooniMrRooni

    Team Member

    Hi there @DougC, thanks for writing in. I'm sorry about the trouble this update has caused with Chrome. We are working on a fix, but in the meantime a reboot of your computer should flush out the gremlins and get things up and running again.

  • bcohen44bcohen44
    edited May 30

    @MrRooni , a Mac reboot did not fix it for me. 1Password Chrome extension continues to be completely broke.

    • 1Password 7.3
    • Chrome for Mac - Version 74.0.3729.169 (Official Build) (64-bit)
    • MacOS 10.14.4
  • MrRooniMrRooni

    Team Member

    Sorry about that @bcohen44 . Could you send a diagnostic report to [email protected]? You can find instructions on how to do that here:

    https://support.1password.com/diagnostics/

  • Done

  • BenBen AWS Team

    Team Member

    Hi @bcohen44

    We've been having some trouble tracking down your report that you emailed in. You should have received a support ID in an auto-reply back from BitBot when you emailed in. Did you receive that? If not we may not have received your report. If you don't have a support ID please try emailing the report again.

    Thanks!

    Ben

  • I actually cannot email the zip file. Both my Outlook and Gmail are blocking zip file attachments :-(

  • BenBen AWS Team

    Team Member

    @bcohen44

    That can happen if you try to email the troubleshooting utility, instead of the report that it generates. Please make sure you're following the instructions closely and that you're attaching the report rather than the tool. :)

    Ben

  • Sent!

  • I have the exact problem. 1Password Mini in Mac Menu only shows the "Install 1Password ..." dialog whenever Chrome browser is frontmost. May have a bead on the problem:

    It seems happens only when I have Chrome's 1PasswordX extension active.
    When I disable 1Px and re-enable the original 1P chrome extension, 1Pmini works normally.

    Is there any new suggestions, or should I also send a diagnostic report?

    Thx

    Lyle

  • brentybrenty

    Team Member
    edited May 30

    @leturner: We recommend using 1Password X or the 1Password desktop app extension, not both.

    The issue you're describing is that when 1Password for Mac is not able to connect to its companion extension, it thinks it's not installed, and therefore offers to install it -- which will definitely happen if you have it disabled.

    So the solution in your case would be to use the 1Password desktop app with its extension:

    https://support.1password.com/1password-extension/

    Or neither of those, and use 1Password X instead:

    https://support.1password.com/getting-started-1password-x/

    I hope this helps. Be sure to let me know if you have any other questions! :)

  • Right, I can just ignore 1Pmini while using chrome, it's just annoying/odd that it suddenly stops working depending on which browser app you have active. I was using 1PX exclusively in Chrome, (just hadn't deleted the disabled 1P extension) And happened to test results if I switched the 'enabled' toggles.

    So is it that 1Pmini can't recognize the chrome 1PX extension anymore? Or that it WASN'T checking for browser extensions until now? Bc they seemed to get along fine until recent update: I was using 1P extension in Safari, 1PX in Chrome and Firefox, and 1Pmini for any/all of them at various times

    I use all three because while I like 1PX, there's no option for it in Safari, and I don't always want to fire up the app or browser just to look up a stored item.

  • brentybrenty

    Team Member

    @leturner: While you can certainly use both, we don't recommend it. As you indicated, it can be confusing. I'd say give the desktop app/extension a test drive by itself for a few days and see how that goes. If you find you still prefer 1Password X, you can always switch back to that.

    The only real limitation is that 1Password X works independently, and "only" in Firefox and Chrome(-based browsers), whereas the desktop extension is also available for Safari and "classic" Edge, and also shares all of its settings and behaviour between them since it's all handled by the desktop app.

    1Password X is designed first and foremost to be entirely self-sufficient, running solely in the browser, so that it works in places where a desktop app cannot: ChromeOS, Linux, restricted company computers, etc.

    Using the 1Password desktop app/extension sounds like it would be a better fit for you though, since you "don't always want to fire up the app or browser just to look up a stored item". 1Password mini -- the browser interface for the desktop app -- allows you to do that. :)

  • I have tried several times to change a password on a site that has a duplicate password. Chrome saves the password but 1Password has no idea what is going on and leaves the password as is. It's like it's not installed. This is the version I'm using.1Password 7
    Version 7.3 (70300020). This happened right after I added the extension.

  • Thx, Brently

    True, but really like how 1PX works within the actual webpage fields. Desktop/extension combo doesn't do that.

    It's all good. I've been with 1P a long time - long as the behavior is consistent I can adapt and hope you can someday get to bring Safari into the 1PX family.

  • brentybrenty

    Team Member

    @merrie101: I'm not sure I understand your description. Can you give me the specifics?

    • OS version
    • Browser version
    • Extension version
    • URL
    • Exact steps you're taking and what is (or is not) happening as you expect

    I will say though that it's recommended to disable the browser's built-in password management, both for security and privacy reasons and to avoid conflicts:

    Turn off the built-in password manager in your browser

    Anyway, let me know, and I'll be happy to investigate. :)

  • brentybrenty

    Team Member

    @leturner: Thanks for the kind words, and your support! We hope that 1Password X can come to Safari someday too, though that's quite a challenge success is uncertain since it works completely differently to Chrome and Firefox (which share many extension APIs now). So I wouldn't hold my breath on that. :blush:

    However, one thing that may help which does look more promising is integration between 1Password for Mac and 1Password X, currently in beta. You might want to check that out. We'd love to have you participate and provide feedback. :chuffed:

  • Hey guys,

    same problem here:

    The Google Chrome Extension ist not working anymore.
    Im Using Mac OS, 1Password 7 (without abo) and the Chrome Extension.
    What can I do?

  • BenBen AWS Team

    Team Member

    @Timotime

    I'm not sure what you mean by "without abo?" But in any event, restarting your Mac should resolve the problem. Please let us know.

    Ben

  • TimotimeTimotime
    edited May 31

    @Ben

    I mean, that I have bought 1password7 with a onetime payment and I am not using the abo model for 1password / have no account at 1password. A restart did not resolve my problem :-(

    Edit: After also restarting Google Chrome again its now working :-)
    Thank you very much!

  • Ok, so I'm having the same issue so I'm going to try to cover all the needed details.
    Macbook pro 2012 13inch, MacOs 10.14.4, Chrome Version 74.0.3729.169 (Official Build) (64-bit), 1password chrome extension version 4.7.4.90. I have uninstalled and reinstalled the chrome extension and it is still prompting me to install 1password. My 1password is currently unlocked and should be working but its not. I use 1password updated through the mac app store so version 7.3.

  • BenBen AWS Team

    Team Member

    @Timotime

    Okay, thanks for the update. I'm glad to hear you were able to get things working.

    I am not using the abo model

    I'm not familiar with that term... "abo." We would typically refer to what you're talking about as a 1Password membership or a subscription. :+1: In any event — glad things are working after restarting.

    Ben

  • BenBen AWS Team

    Team Member

    @thisguyneil,

    I'm sorry for the trouble. It may be necessary to restart the Mac in order to re-establish the communication between 1Password for Mac and the extension.

    Ben

  • I have restarted my Mac. I have stopped the "offer to save passwords" in crome. Now when I press the I button in chrome or the I button at the top of my screen - nothing happens.
    It's very frustrating. Should I discontinue the Chrome extension?
    I just tried to sign in here and 1 password didn't save my password so I will have to reset it.

  • I'm having the exact same issue as described "Since an automatic update to yesterday the Chrome extension is completely non-functional. Opening 1Password mini while Chrome is the front application prompts to install the Chrome extension, which is already installed. Removing and reinstalling the Chrome extension has no effect. " I tried restarting my Mac as recommended but the issue persists.

    • OS version (MacOS Mojave 10.14.5)
    • Browser version (Chrome 74.0.3729.169 (Official Build) (64-bit))
    • Extension version (4.7.4.90)

    I've been a loyal customer for a long time even before the subscription model. This latest change in functionality is quite annoying TBH.

  • Same issue here, on three different Macs. 2 iMacs (one of which is the new 2019 model, one is a 4-year-old i5), and a 2017 13" MacBook Pro. The two iMacs are running Mojave 10.14.5, the laptop is 10.14.4. All three are running the latest Chrome (74.0.3729.169).

    Machines have been restarted, the extension has been removed and reinstalled (numerous times). Whenever I try to click on the extension, I get what looks like the menu you see when you right-click the browser extension icon (1Password extension, "This can Read and Change Site Data", "Remove From Chrome", etc)

    Clicking on the 1password mini icon in the system toolbar shows the "Install the extension to fill in Chrome" message. The mini tool will allow me to search for my logins

  • This is the extension when clicking on it

  • Diagnostic sent

  • mark_l_sandersmark_l_sanders Junior Member

    Update to 7.3 seems to break the Chrome extension (almost) randomly.
    I use Chrome on 2 laptops, and I've had to remove/reinstall the extension on both.

    I've just tried to use the extension on my home laptop (running Mojave) with Chrome 74.0.3729.169 - removed/reinstalled/restarted but nothing helped. I tried for 10 minutes - tried to use teh full 1Password7 app to create a new Password but found it hard.

    Gave up and went to Safari: extension worked fine.....after about 20 minutes I restarted Chrome and - the extension now works without a problem. This includes 1Password7 Mini in mac - also wasn't working, now is working.

    This is not the first time that I've had to remove and reinstall the extension. Clearly the problem is not simply linked to the upgrade, but to a wider issue with the implementation of the extension.

    Given that Chrome use (ok, global, not Mac) is at 60%+ a new implementation may well be a good idea, as the whole experience is often spoiled by this issue. Let's face it, if the interface doesn't work properly, the rest of the app is tainted.

  • I have problems since the update with the extension as well. It works, but the new UI (which I don't see as an improvement) doesn't work properly. If I have a website with multiple saved logins, I need to click two or 3 times before it fills the details. Double-clicking on the saved login works, but only after 2 or 3 tries.

    So yeah, very buggy and not user-friendly at all. Really hope we can get a solution soon.

  • LarsLars Junior Member

    Team Member

    @merrie101 - make sure you've got the proper extension installed, please. The current version for Chrome is 4.7.4 -- what version do you see installed when you open chrome://extensions ?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file