Not able to get extension working consistently in Firefox 67.0

My extension icon is currently grayed out in Firefox. Sometimes (very rarely) it works as expected. I have 1Password 7.3.684. It worked fine with 1Password4, I only started having issues once I upgraded. I tried reinstalling Firefox and 1Password, but that didn't help. Any ideas?

Just checked, it's not working in Chrome either.


1Password Version: 7.3.684
Extension Version: 4.7.4.90
OS Version: Windows 10
Sync Type: 1Password Account

Comments

  • I have the SAME issue! Same vers 1P & FF (on macOS 10.12.6)

  • I had the same problem (Win7) but after a system reboot everything started working again properly.

  • Same here. Numbers:

    • macOS ‘Mojave’ 10.14.5
    • Firefox 67.0, plain-release
    • 1Password 7.3 (70300019), Mac App Store
    • 1Password FireFox extension, 4.7.4.90

    The ‘Debug Addons’ page says:

    Reading manifest: Error processing key: An unexpected property was found in the WebExtension manifest.

    Opening the debugger for the 1Password extension, I get:

    Finished loading auth configuration. Processing callbacks. global.min.js:88:471
    [CHROME:NM] Port <[object Object]> disconnected: No disconnect message global.min.js:249:130
    [AGENT] Connection [object NativeMessagingConnection] disconnected. global.min.js:105:278
    1Password detected a high number of disconnections from the browser extension to the main application between Sat Jun 01 2019 03:23:52 GMT-0500 (Central Daylight Time) and Sat Jun 01 2019 03:25:54 GMT-0500 (Central Daylight Time) global.min.js:249:479
    [Exception... "Component not initialized"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: resource://gre/modules/ExtensionChild.jsm :: api/register/publicAPI.onDisconnect< :: line 188"  data: no]
    api/register/publicAPI.onDisconnect<@resource://gre/modules/ExtensionChild.jsm:188:42
    [email protected]://gre/modules/ExtensionChild.jsm:240:9
    [email protected]://gre/modules/ExtensionChild.jsm:306:7
    recei[email protected]://gre/modules/ExtensionChild.jsm:160:40
    _handleMessage/</<@resource://gre/modules/MessageChannel.jsm:922:27
    _handleMessage/<@resource://gre/modules/MessageChannel.jsm:921:9
    [email protected]://gre/modules/MessageChannel.jsm:919:16
    receiveMessage/<@resource://gre/modules/MessageChannel.jsm:218:14
    [email protected]://gre/modules/MessageChannel.jsm:211:10
    
  • brentybrenty

    Team Member

    @ELLIOTTCABLE: Your post indicates that something is interfering with the connection. Try rebooting, but if you're still having trouble you'd need to find the source of the interference on your machine. Do you have other extensions or "security" software running there?

  • brentybrenty

    Team Member

    @1234567890: Which 1Password, browser, and extension versions are you using? Does rebooting help?

  • brentybrenty

    Team Member
    edited June 4

    @ELLIOTTCABLE: The extension button being greyed out means that there is no connection, and that can be caused by a number of things. First, did you uninstall 1Password 4, and do you have any "security" software that you need to whitelist the new app in?

    Edit: I @-mentioned the wrong person here. Sorry!

  • edited June 3

    I'm still having an issue, for me rebooting does not help.

    I get this when I debug the addon:

    1Password version 4.7.4 loaded @ Mon Jun 03 2019 15:45:01 GMT-0500 (Central Daylight Time) global.min.js:127:404
    Error: Invalid tab ID: 0 ExtensionUtils.jsm
    Finished loading auth configuration. Processing callbacks. global.min.js:88:471
    [CHROME:NM] Port <[object Object]> disconnected: No disconnect message global.min.js:249:130
    [AGENT] Connection [object NativeMessagingConnection] disconnected. global.min.js:105:278
    [Exception... "Component not initialized"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: resource://gre/modules/ExtensionChild.jsm :: api/register/publicAPI.onDisconnect< :: line 188"  data: no]
    api/register/publicAPI.onDisconnect<@resource://gre/modules/ExtensionChild.jsm:188:42
    [email protected]://gre/modules/ExtensionChild.jsm:240:9
    [email protected]://gre/modules/ExtensionChild.jsm:306:7
    [email protected]://gre/modules/ExtensionChild.jsm:160:40
    _handleMessage/</<@resource://gre/modules/MessageChannel.jsm:922:27
    _handleMessage/<@resource://gre/modules/MessageChannel.jsm:921:9
    [email protected]://gre/modules/MessageChannel.jsm:919:16
    receiveMessage/<@resource://gre/modules/MessageChannel.jsm:218:14
    [email protected]://gre/modules/MessageChannel.jsm:211:10
    MessageChannel.jsm:924
    Error: Invalid tab ID: 0 ExtensionUtils.jsm
    Error processing windowTypes: This property is deprecated global.min.js:250
    

    I'm running Norton Security and Malwarebytes. Disabling both of them doesn't make a difference.

  • brentybrenty

    Team Member

    @richardsonlesh: Stupidly, I @-mentioned someone else above when I was meaning to reply to you earlier. Sorry about that! Have you uninstalled 1Password 4?

  • Yes, I have.

  • brentybrenty

    Team Member

    @richardsonlesh: Thanks for letting me know. If you're still having trouble, the best thing to do will be to restart your device, reproduce the same issue, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#HWH-78283-596]

    If you’re reading this and you are not richardsonlesh, this Support ID is for richardsonlesh only. Please ask us for your own if you also need help.

    This will link it to our current conversation. Once we see it we should be able to better assist you. Thanks in advance!

    ref: HWH-78283-596

  • Reboot DID fix it thx

  • brentybrenty

    Team Member

    Great! Thanks for letting me know. We're here if you need anything else. :)

  • Hm. Yeah, this is really hard to reliably reproduce.

    The following process produced no result the first time (the inability-to-connect continued to occur); but a second run-through resulted in a successful connection to the app:

    • Uninstall addon
    • Reboot computer
    • Re-install addon

      This isn’t the first time this has happened, but I also cannot get it to start happening again. Sounds like a really frustrating issue to reproduce and debug. )=

    Is it a known issue, or should I attempt to generate and submit diagnostics next time I see it?

  • Hi @ELLIOTTCABLE,

    Until we can pin down what and why is happening in your case it's hard to say if it's a known issue or not. What might help is a diagnostic report. Can you:

    1. Restart your Mac.
    2. Launch 1Password and unlock.
    3. Launch Firefox and confirm the extension is working.
    4. Use the Mac as you normally would until the issue appears.
    5. Create a diagnostic report and send it in.

    The restart is just so we have a nice clean starting point although it does assume the issue isn't taking days and days before it appears. Even learning if it seems to only occur after long periods between restarts or if you happen to discover occurrences seem to be more random may be one of the clues that along with others help to reveal what is happening. For the diagnostic report itself, this link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • I ended up just having to reinstall Windows. Worked fine after that.

  • brentybrenty

    Team Member

    Dang. I'm sorry to hear that it was necessary to go through all of that, but glad that it at least helped in the end.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file