3 fields for login on both Hyatt website & American Airlines website

At Hyatt's website, it requires 3 fields to login. How do we setup 1Password to work with these 3 fields?

American Airlines has the same problem.

We don't know how to get 1Password to work on either of these websites.

Any ideas on how to make this work?

Thanks! :)


1Password Version: 6.8.8 Mac App Store
Extension Version: 4.7.3
OS Version: macOS 10.14.5
Sync Type: Dropbox

Comments

  • MrRooniMrRooni

    Team Member
    edited May 30

    Hi there @scotty321. Great question! You can actually manually save a login for these pages and 1Password will fill all the fields correctly going forward. We've got a nice support document here: How to save a Login manually in your browser

    I just tested it for both of these sites and it worked like a dream.

  • Nope, I tried these steps 4 different times to manually save a brand new login for the Hyatt website, and it still doesn't work on the Hyatt website. Haven't even tried it on the AA website yet.

    I went to the Hyatt website, filled in all 3 of the login fields, then MANUALLY saved a new login for that page BEFORE logging into that page.

    It "sort of" looks like 1Password remembered the information, because when I go into 1Password and choose to "Show Web Form Details", it shows me my last name in a field called "last_name".

    However, when trying to autofill on the Hyatt website, 1Password gets it all wrong. 1Password leaves the username completely blank, and 1Password puts my username into the Last Name field.

    I tried this on Chrome on a Mac, so it definitely doesn't work with that combination.

  • Greetings @scotty321,

    I thought I knew why @MrRooni's suggestion didn't help. He most likely tested with 1Password 7 whilst the version of 1Password you supplied was 1Password 6 and we've had a lot of filling code changes go into 1Password 7. I went back and tested 1Password 6 though and after manually saving a Login item I found it filled all three fields. In fact no test I've tried so far has failed so I'm at a bit of a loss to explain why it isn't working for you.

    Here is what I've been trying.

    1. Load https://world.hyatt.com/ in my browser.
    2. Access the sign-in form.
    3. Filled the three fields and saved a Login item as per the page @MrRooni linked to.
    4. Reloaded the page and accessed the sign-in form.
    5. Instructed 1Password to fill using the Login item saved in step 3.

    Your previous post did strongly suggest you saved an entirely new Login item rather than attempted to update an existing one but can I confirm that please. The update existing option that exists in 1Password for Mac only updates the stored password and @MrRooni and myself were testing with a completely new Login item during our own tests.

    I know American Airlines has been a thorn in our side in the past and that may require some tinkering to get 1Password 6 to work properly there but with the Hyatt site it looks like things should work with no tweaking. I can't think why we're not seeing similar results for that one.

  • scotty321scotty321
    edited June 10

    Yes, I already took all of those steps, and yes, this was creating a BRAND NEW LOGIN FROM SCRATCH.

    Still doesn’t work at all.

    That’s fine, I don’t really care, I’ll just copy and paste in everything manually.

    Would just be nice for 1Password to somehow be able to work with these trickier, non-standard websites.

  • ag_anaag_ana

    Team Member

    @scotty321:

    Would just be nice for 1Password to somehow be able to work with these trickier, non-standard websites.

    1Password does work with sites like this one, as both MrRooni and littlebobbytables tested and confirmed.

    One thing that might be worth trying on your end is to use 1Password version 6.8.9. I noticed that you are using version 6.8.8 instead, which is one update behind, so while I am not sure if it actually will make a difference when it comes to this specific issue, perhaps it's worth trying to update it and see if this helps.

  • Updated to 6.8.9 and it still doesn’t work, so obviously it doesn’t always work.. That’s really great that the internal employees of 1Password can get it to work, but it’s not working for your customer out in the real world. Do you guys need me to create a video of my screen to show the entire process (that I followed verbatim), and how it fails?

  • I have also just tried this multiple times on American Airlines' website, and it does not work for me either. If I save it manually from the main page, it does save a "lastName" field; however, it does NOT fill it in automatically. Oddly, if I go to the login page linked up top and try to save it manually, it does NOT save the "lastName" field like it does when saving from the main page. Regardless, 1Password never autofills the 3 login fields on any page even when the lastName field is stored in the login record.

  • LarsLars Junior Member

    Team Member

    @nukesean - sorry for the trouble. Can you tell us:

    1. What specific version of 1Password for Mac you're using
    2. What specific version of macOS you're running
    3. What specific version of 1Password extension, in which specific version of which browser?

    Thanks. :)

    (for what it's worth, although as littlebobbytables metioned, we've had troubles intermittently with AA over time as they've changed the function of their Login page, I can currently get this to work flawlessly in 1Password for Mac 7.3 and Safari 12.1.1 on macOS 10.14 (“Mojave”) 10.14.5).

  • LarsLars Junior Member

    Team Member

    @scotty321 - confirming both mrrooni and littlebobbytables' experience here; on both 7.3/Mojave and 6.8.9/El Capitan, I can use the Save Manual Login instructions to save a Login item for both American Airlines and Hyatt's sites that will reliably fill in all three fields.

    That doesn't mean I don't believe you're experiencing what you say you are, but it does mean that it's likely to be something specific to your system. Do you have any content blockers turned on in your browser currently? If so, can you try disabling them (actually, disable ALL extensions besides 1Password for a moment) and try it again? Re-save a Login item using the manual save method, then restart your browser and try filling. Let us know how you get on.

  • j0oj0o
    edited September 10

    Just a data point.
    I tried the fix (creating new login) suggested by the esteemed 1Password staff. When I glanced at the fields of this new entry only the username and password components were visible. I assumed, therefore, the fix didn’t work. However, on trying the newly made entry, all three fields were correctly filled in! The secret, maybe, is in the Saved form details where all the relevant items appear.
    Thanks.

  • LarsLars Junior Member

    Team Member

    @j0o - yep! There are the default fields, and then there are other fields which 1Password will capture, which are not always immediately visible -- but if you look in Saved Form Details, you should see everything. By the way, it's also a good idea not to mess with what's saved there, as it can impair 1Password's ability to fill. Thanks for confirming! :)

  • No answer yet?

  • ag_michaelcag_michaelc

    Team Member

    @ansgar, did you perhaps mean to post in a different thread? I don't see a question from you here, and a solution is in the original reply. :smile:

  • @lars How do I unsubscribe from this forum thread, but still keep my subscriptions active for other threads?

  • LarsLars Junior Member

    Team Member

    @scotty321 - you can find your notifications preferences here...but I there are no mechanisms to unsubscribe from particular threads. We're somewhat constrained by what we can do, since we're only able to offer what our forum software, Vanilla, allows us to do in terms of user management of notifications. You can unsubscribe from mentions in threads you've created or participated in, but that would be across-the-board. Typically, threads will tend to "die out" after they've fallen off the front page of their respective category, just because no one's seeing threads on page 2 or later any longer, so someone has to do a local or Google search to find them. It does happen, but for example if you look at the history of this thread, there have been only two replies after your initial thread -- one three months later, and another a month after that.

  • There have been 5 replies in the last few weeks. This thread was dead to me a while ago, but now it has been revived over the last few weeks. Would be great if your forum software was upgraded to a platform that lets us subscribe or unsubscribe to individual threads. This would help with situations like this, but would ALSO enable us to easily subscribe to interesting threads as well.

  • YaronYaron

    Team Member

    Thank you for your feedback, @scotty321 .
    We wish it were that simple, but we would hate to lose years of questions and answers here just to get to a new platform. For the time being, this place serves its purpose well, even if the individual settings are rather limited.

    Thank you anyways, we appreciate your input :)

  • Sorry for somewhat 'reactivating' this thread. I asked whether a solution was provided to the initial post because I surfed the forum via my iPhone and I wasn't able to see the answers. Hence I can clearly follow scotty's wish for a better forum/platform. I also understand that a migration to a new platform is tricky. Can't the Vanilla developers provide those more advanced features with new versions? Nevertheless, thanks for your really quick responses.

  • ag_anaag_ana

    Team Member

    @ansgar:

    I surfed the forum via my iPhone and I wasn't able to see the answers

    Can you please elaborate on this a little bit? What happened exactly when you visited this discussion on your phone?

  • Concrete example: I received a mail telling me about your comment above. I clicked the link included to respond and I only got to see a blank webpage and no other indicator. From your question I understand that such behavior is not exactly the expected behavior.
    So I started thinking 💭 what could hinder on my end the correct display. It was not my private browsing window but my add blocker. Switching it off everything became visible and I could write this answer to you.
    Now I shall be more specific: It would be nice if your forum software could tell me about my ad blocker as other pages do. Especially since iOS offers an easy way for switching it off for individual web pages. 😊
    Thanks for listening.

  • One small addition. Now being able to read the initial posts and the comments I kept browsing for a while. I realized that I repeatedly had to deactivate my ad blocker. Bit strange and not a smooth experience but I’m still happy to use my iPhone to search your forum. Have a good day.

  • ag_anaag_ana

    Team Member

    Thank you for the update! We will see if there is anything we can do, and I am happy that you managed to find the culprit already :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file