7.3 Breaks Autofill

Upgraded to 1pwd 7.3 on my Mac this morning. And Autofill has broken in Safari.

-- MacOS Mojave 10.14.5
-- 1password 7.3 (from Mac App Store)

When I try to use Autofill from the main Mac app, a Safari window opens .. and then nothing happens. Web site does not appear, I just get a blank Safari page. Was working literally up to 5 mins before the App Store updated it to 7.3.

Anything I can try to restore this functionality?

--TIm


1Password Version: 7.3
Extension Version: 7.3
OS Version: 10.14.5
Sync Type: Not Provided

Comments

  • NycSmart1NycSmart1 Junior Member

    Seems to be a common problem. I have it too. Two different computers, across browsers.

  • Hi @drtimhill & @NycSmart1,

    If you haven't already can you try restarting the Mac, launching and unlock 1Password and then start Safari. Does the issue persist after this?

  • NycSmart1NycSmart1 Junior Member

    Yes. Tried that. No luck. And it's not just safari. It's all browsers. I see that this is a common problem across the forum. Is there a ticket to follow this bug?

  • Hi @NycSmart1,

    If a restart didn't resolve it can you try the following for me please.

    1. If 1Password is currently running hold down the alt/option ⌥ key and click on the 1Password icon in the macOS menu bar at the top of the screen. Select the menu option Quit 1Password Completely.
    2. Drag the 1Password application bundle from the /Applications/ folder to the Trash.
    3. Restart your Mac.
    4. Download a fresh copy of 1Password via the App Store application.
    5. Launch and unlock 1Password.
    6. For Safari confirm the extension is enabled.

    Do you find 1Password now works at all? While we have seen some teething issues with the update we aren't looking at a wide-spread, global issue of the extension not working. By this I mean that while we are seeing some reports and you're not alone it also isn't everybody suffering at the same time.

    If still no joy I think the next best step is for us to review a diagnostic report and see if we can determine what is going on. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • A restart of my Mac DID seem to fix the problem for me (I thought I had already tried that, sorry). Thanks for the help.

  • Greetings @drtimhill,

    I'm just happy things are working again for you. The update must have gone smoothly for the majority of people otherwise we would be flooded with justifiable complaints but we are also definitely seeing more trouble with this update than we can comfortable with. I can only hope the developers manage to pin down why it was so troublesome and make sure it doesn't happen again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file