1Password requires "update" every time I open a new browsing session on Firefox. Is that normal?

CobbersCobbers
edited June 6 in 1Password X

Hey, I have recently upgraded to Firefox v67 (and now 67.0.1) and have been using 1Password for some time on both Chrome and previous versions of Firefox, but now, every time I open a new instance of Firefox, I am required to "update" 1Password.

I have a feeling this may be more of a Firefox issue, but is anyone else having this problem? And, does anyone know how to fix it? :(


1Password Version: 7.3.684
Extension Version: 1.15.2
OS Version: Windows 10 Pro 1809
Sync Type: Not Provided

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @Cobbers! Thanks for pointing this out. It seems like you're either using Firefox in private browsing mode or your cache is being cleared after each session. You should only be required to click that "Update" button once to move to the new popup unless something's being reset on the backend. Do you happen to have a utility tool that clears your cache every so often?

  • Hi @kaitlyn, thanks for the swift response on this! :) It's actually been happening just in standard browsing mode, not in private browsing mode, but I've investigated some of the Firefox settings further. I have always had my browsers clear down all my data from a privacy perspective after each use, but turns out that unless you customise the settings in v67, then simply checking the box within "Privacy & Security" to "Clear history when Firefox closes" doesn't just clear the history, but clears out Browsing, Downloads, Forms, Logins, Cookies and Cache. I've removed the cache from those defaults and tried opening a new instance of the browser, and the settings seem to have stuck. I'll try rebooting and confirm if that's done the trick, though :)

  • @kaitlyn unfortunately after a reboot, this didn't work. I'm not quite sure what to consider next. Any suggestions?

  • kaitlynkaitlyn

    Team Member

    @Cobbers – I played around with this a little more today, and the original setting that you thought was the culprit didn't end in me needing to select "update" in 1Password X upon restarting Firefox. However, I found another setting that did end with needing to click that "update" button upon every restart of Firefox. That setting reads "Delete cookies and site data when Firefox is closed" under the Cookies and Site Data section on the Privacy & Security page. Do you happen to have that one checked?

  • @kaitlyn - Thanks again for trying to this out and taking the time to look! I'm really, very grateful! :) But yes, I do actually have that checked. I'll give it a try with unchecking it and rebooting.

  • kaitlynkaitlyn

    Team Member

    @Cobbers – Absolutely! I wanted to get to the bottom of it as well. :) Many restarts later, I still believe that "Delete cookies and site data when Firefox is closed" setting is the culprit. Please do let me know what you find!

  • @kaitlyn - Well I think your hard work has paid off, as I just tried it, and it now works fine!! :) Although, Mozilla need to sort that, as that setting never used to impact extensions in that way...very frustrating. But thanks ever so much for your help and efforts on this - I am incredibly grateful! :)

    For the record, I did try going into "Manage Permissions..." next to that checkbox and adding both 1Password and Feeder (my RSS reader extension that also resets after each restart) to the "Allow" list with the "Delete cookies..." option still ticked, but it didn't make any difference, unfortunately.

  • kaitlynkaitlyn

    Team Member
    edited June 11

    No problem at all, @Cobbers! I'm glad you were able to get things back to normal. I don't believe that 1Password X has had an option to update to a new version in the past, so it's easy for me to believe that this could have been the first time it came up. It's also not an option that'll stick around forever, given you'll only be able to use the older design of the popup for a limited number of time. Eventually, you should be able to have that Firefox setting checked and 1Password X will remain unchanged. :)

  • Thanks @kaitlyn I really appreciate that! And it's good to know that this will potentially be resolved properly in future releases as well! :) (I shall keep my fingers crossed!) Thanks again for your help, and have a great week! :)

  • kaitlynkaitlyn

    Team Member

    @Cobbers – You're very welcome. ❤️I hope you enjoy the rest of your week as well!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file