Autofill „compatibility mode” and Chrome

In the latest beta you say that 1Pass should now work with Chrome without using accessibility service, but how is this supposed to work exactly?

I updated the app, launched it, so it can update its data and then tried logging to different services in Chrome, but I can’t get 1Pass to offer autofill here.


1Password Version: 7.2beta1
Extension Version: Not Provided
OS Version: Android 9.0
Sync Type: Not Provided

Comments

  • periperi

    Team Member

    Hey @revanmj. It should look the same on your end when filling is working. If you're not seeing the Autofill prompt, try fully exiting and relaunching Chrome. If you're still having trouble, can you let me know what version of Chrome you're using?

  • Thanks, force closing Chrome and waiting a moment seems to have worked and 1Pass autofill shows up now.

  • brentybrenty

    Team Member

    Great! Thanks for the update. We're looking into some issues with Chrome as well. :)

  • Same problem with no autofill appearing. Tested on Chrome, Chrome Dev, Brave, and also tried clearing cache and reopening the browsers but can't get it to work.

    1Password Version: 7.2beta1
    Extension Version: Not Provided
    OS Version: Android Q Beta 4
    Sync Type: Not Provided

  • I cannot get any autofill to work with Chrome. I've tried several pages, restarted the phone, etc.

    1Password Version: 7.2beta1
    OS Version: QPP3.190404.015

  • saadsaad

    Team Member

    Sorry to hear Autofill in Chrome is not working for you. In 1Password 7.2.BETA-1, we moved over to using Autofill compatibility mode for filling in Chrome. I’ve passed on these details to our development team, and we’ll take another look at the behaviour on Android Q.

  • I'm running Chrome 74 on Android 9 and have to force close Chrome often to get the prompt to return, it only seems to work for a short while. The old auto fill was far more reliable.

  • mverdemverde

    Team Member

    Thanks for sharing those details @Lunim. I'm aware of some issues affecting Chrome 75 and Android Q, but I'd like to get more details about the issue you're encountering. Are you able to identify any particular steps that seem to trigger the issue? For example, loading a URL from another app? Opening another tab?

  • LunimLunim
    edited June 11

    .

  • Forgot to include detailed OS and browser version on my reply, here they are:

    Android 10 QPP4.190502.018

    Chrome 74.0.3729.149
    Chrome Dev 76.0.3809.12
    Brave 1.0.95, Chromium 74.0.3729.157

  • I've found that it seems to happen most often if I have closed all tabs. When I open a single new tab, it doesn't work, but if I open a new tab and switch back it may start working. I took a video:

  • periperi

    Team Member

    Thank you for the update! I'll pass this along to our development team.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file