After every update: Lock screen wants Master Password although disabled

DenalBDenalB

I disabled the lock screen for Password AutoFill in "Settings - Advanced - Security". My Master Password must be entered every 30 days. In the meantime I only have to use my PIN-Code. This works well for opening the app and for Password AutoFill.

But after updating to the latest version every time I have to enter the Master Password for opening the app and for Password AutoFill.

I remember the last updates of the iOS version of 1Password. Every time I have to go to "Settings - Advanced - Security" enable the Password AutoFill setting and disable it again. Then it works and my PIN-Code is needed for opening the app and Password AutoFill. Otherwise I have to use my Master Password which isn't short to login to the app or Password AutoFill.

May be you can reproduce this behavior and can build a fix for that?


1Password Version: 7.3.2
Extension Version: Not Provided
OS Version: iOS 12.3.1
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member
    edited June 11

    @DenalB: You always will need to enter your Master Password in the main 1Password app the first time to enable "quick unlock" -- wether you're using a PIN for that or biometric features like Face ID or Touch ID. That's expected, and unavoidable, as the data cannot be decrypted without the Master Password. If you unlock only the 1Password extension or Autofill, you'll need to enter the Master Password every time until you unlock the main 1Password app with it. I hope that helps clear up any confusion around the feature. :)

  • @brenty

    You always will need to enter your Master Password in the main 1Password app the first time to enable "quick unlock"

    No. I don't need the Master Password when creating a PIN-Code and disabled the lock screen for Password AutoFill in the iOS app. Sorry.

    Every time I open the app or using the autofill function to fill in a password I only need to enter my PIN-Code. The Master Password is only required after a device restart, after 30 days or when I entered the PIN-Code incorrectly. And that's a feature I love.

    Here are the steps opening the 1Password app.

    1. Only my email app is opened in the background. 1Password app is completely closed:

    1. Opening the 1Password app asks for my PIN-Code:

    1. After entering the app these are my settings in "Settings - Advanced - Security":

    Now let me show you autofilling the password for an app.

    1. Try to open the app which wants to have a password:

    1. The 1Password app asks for my PIN-Code when want to autofill:

    1. Searching for the app:

    1. Autofilling the password:

    You can see that I never have to enter my Master Password.

    But when updating the app to the newest version I have to enter the Master Password in every step when normally the PIN-Code is needed until I enable and disable the lock screen for Password AutoFill in "Settings - Advanced - Security" again.

  • ag_anaag_ana

    Team Member

    Hi @DenalB,

    But when updating the app to the newest version I have to enter the Master Password in every step when normally the PIN-Code is needed until I enable and disable the lock screen for Password AutoFill in "Settings - Advanced - Security" again.

    After you update the app to the newest version, do you first open the 1Password app itself, and enter the Master Password there? Or do you directly use AutoFill before launching the iOS app?

  • DenalBDenalB
    edited June 11

    Hi @ag_ana ,

    After you update the app to the newest version, do you first open the 1Password app itself, and enter the Master Password there? Or do you directly use AutoFill before launching the iOS app?

    It doesn't matter. Until I enable and disable the setting again I have to enter the Master Password everywhere.

    It also happens on iPhone 6s of my wife. It is not only my behavior (iPhone 8 Plus). So I thought it is a general "problem". ;)

  • BenBen AWS Team

    Team Member
    edited June 11

    It is possible that it is a generalized problem with Quick Unlock via PIN. I'm surprised that setting has anything to do with it, but with the popularity of Touch ID / Face ID the number of people using PINs has dropped significantly and I'd be surprised if anyone on our team is using one. I'll mention this to our QA team to see if with the next update they can test this.

    Thanks for the report! We'll be in touch if we need additional info.

    Ben

    ref: apple-3833

  • Thank you very much @Ben.

    And just to say it again it has nothing to do only with the latest update. All last updates since I'm using 1Password from January 2019 on have the same behavior. 😉

  • BenBen AWS Team

    Team Member

    Understood. :) You're very welcome.

    Ben

  • Just tried again a little bit and found out that after restarting my iPhone I have to enter my Master Password every time I use the 1Password app. Normally I don't restart my iPhone. Just do it when I think it's time for a real "shutdown". ;)

    I have to enter the Master Password until I enable and disable the lock screen for Password AutoFill in "Settings - Advanced - Security" again. After doing this every time I use 1Password I only have to enter my PIN.

    I would understand when restarting the iPhone I have to enter my Master Password once and then enter my PIN again. But that isn't like it is. And I hope that this is only a bug that could be fixed. :)

  • BenBen AWS Team

    Team Member

    Just tried again a little bit and found out that after restarting my iPhone I have to enter my Master Password every time I use the 1Password app. Normally I don't restart my iPhone. Just do it when I think it's time for a real "shutdown". ;)

    I have to enter the Master Password until I enable and disable the lock screen for Password AutoFill in "Settings - Advanced - Security" again. After doing this every time I use 1Password I only have to enter my PIN.

    So this is happening with the 1Password app too, not just with autofill?

    1. Reboot
    2. Launch 1Password app
    3. Prompted for MP (enter MP to unlock)
    4. Close 1Password
    5. Launch 1Password app
    6. Prompted for MP (enter MP to unlock)?
    7. Toggle setting in Settings > Advanced > Security for showing the lock screen for autofill
    8. Close 1Password
    9. Launch 1Password app
    10. Prompted for PIN?

    Is that a fair description of what is happening?

    I would understand when restarting the iPhone I have to enter my Master Password once and then enter my PIN again. But that isn't like it is. And I hope that this is only a bug that could be fixed. :)

    Unfortunately I can't promise that, but I have filed a report with our team to investigate further, and once we clarify about the above point I'll add that information to the report.

    Ben

  • @Ben

    So this is happening with the 1Password app too, not just with autofill?

    Yes. This happens not just with autofill. It happens with the complete 1Password app.

    Is that a fair description of what is happening?

    Yes! That's exactly how it works actually. I didn't recognize it earlier because I don't shut down my iPhone normally. But my wife does and she complains that she has to use the Master Password every time she uses 1Password app or autofill. ;)

    Unfortunately I can't promise that, but I have filed a report with our team to investigate further

    Thank you very much Ben!
    I just wonder why I seem to be the only one with the problem. :'(

  • ag_anaag_ana

    Team Member

    @DenalB, Thank you for additional information on this, and sorry for the trouble.

    Like Ben mentioned above we will investigate this further.

    Meanwhile, thank you very much for your patience!

  • @ag_ana

    Meanwhile, thank you very much for your patience!

    Thank you ALL very much for your support and 1Password! 8-)

  • ag_anaag_ana

    Team Member

    @DenalB, on behalf of everyone, you are very welcome!

    Have a wonderful day! :)

  • @Ben & @ag_ana
    Today I installed the latest update to version 7.3.3 and it looks like the problem is fixed now.

    It is not written in the changelog but after updating I had to use the Master Password once to open the app and now only the PIN is needed. After restarting the iPhone I also had to use the Master Password only once to open the app.

    I will take a closer look at this point on all my devices. If there are still problems with this I will come back to you. Thanks for fixing this problem. :)

  • BenBen AWS Team

    Team Member
    edited July 3

    I wish we could take credit but it doesn't appear we've changed anything. In any event, I'm glad to hear it is working as expected.

    Ben

  • @Ben
    Let me have a look in the next days. ;)

  • BenBen AWS Team

    Team Member

    :+1:

    Ben

  • @Ben

    I wish we could take credit but it doesn't appear we've changed anything. In any event, I'm glad to hear it is working as expected.

    Don't know what I tested but it isn't fixed yet. After updateing the app to a newer version I have to enter the Master Password every time although the PIN should be entered. :(

    So I'm waiting for a fix for ref: apple-3833.

  • BenBen AWS Team

    Team Member

    @DenalB

    Just to be sure we're on the same page: it is expected that you have to enter the Master Password once in the main 1Password app (not Password AutoFill / the extension) before you'll be able to unlock Password AutoFill with any sort of Quick Unlock (PIN, Touch ID, Face ID).

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file