1password is trying to autofill a field called Email Template - but it isn't an email field at all

Hi there,

I use 1password extensively, and spend a lot of my day in Salesforce. Salesforce has some fields called things like "Email template" (the one that is driving my crazy today) that 1password is trying to suggest email addresses for - but I need to enter the name of the email template. I can get around this, but I'm wondering if there's a way for me to tell 1password to never try to autofill this field. (I'll see it about 40 times today.)


1Password Version: 7.3
Extension Version: 1.15.2
OS Version: 10.14.5
Sync Type: iCloud
Referrer: forum-search:it isn't an email field

Comments

  • kaitlynkaitlyn

    Team Member

    Hi there @annahc! I'm sorry for the trouble. Based on your description, it sounds like you're using an internal Salesforce tool that I wouldn't be able to get access to. If that's the case, would you mind right clicking on the "Email template" field and selecting Inspect? That should bring up the HTML for the field that's giving you trouble. Please take a screenshot of it and attach it to your response as long as you're sure it doesn't reveal any personal info since this is a public forum. While there isn't a way to tell 1Password to never fill that particular field, I'd like to raise the issue with my team so we can work on improving 1Password's filling algorithm. Please let me know!

  • Thanks Kaitlyn! Here's that screen shot.

  • kaitlynkaitlyn

    Team Member

    @annahc – The code that's hidden underneath <label for="Name">...</label> is what I'll need to see, unfortunately. I see that the correct row is highlighted, but would you mind clicking the > arrow in the highlighted row so I can see what's inside it? I'm sorry for the confusion. I thought it would open up to the correct code right off the bat, but it seems to be hidden within a table. Please let me know if I'm not making sense, and I'd be happy to clarify. :)

  • No problem at all - I think this screenshot has the right info? Thank you so much for your help.

  • ceceliacecelia

    Team Member

    Hey @annahc! Thanks for sending over that screenshot. <3

    I've gone ahead and filed an issue with my team to see if we can fix 1Password's behavior here. In the meantime, if you're seeing this issue a lot, turning off Show autofill menu on field focus might help:

    • Right click the 1Password X icon in your browser and choose Settings.
    • Scroll down until you see Show autofill menu on field focus and bump the slider next to it to the left (off).

    This will make it so the inline menu doesn't appear when you focus the field. To access the inline menu when cursor focus is on the field all you'll need to do is hit the down key on your keyboard. Or if you're a mouse user, click the 1Password icon in the field.

    ref:582

  • Thank you! For an administrator in Salesforce, this is very common so I'll probably change the autofill menu options. There are a few similar places in Salesforce, although I have no idea if they have the same underlying html. Would you like me to collect all of them?

  • kaitlynkaitlyn

    Team Member

    @annahc – Each field could differ slightly, so you're welcome to post the others here so we can take a look. :)

  • Cool! Here's the other one I've run into a lot this week.

  • kaitlynkaitlyn

    Team Member

    @annahc – Thanks so much! It sounds like Cecelia's suggestion will come in handy for you, but I've got this one added to the issue she mentioned. :)

    ref: xplatform/filling-issues#82

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file