annoying issue: autofill repeatedly asks for passphrase (instead of pin or fingerprint unlock)

snappysnappy

So, I think this only happens when 1P hasn't previously had a passphrase entered and enters a "dormant" mode (in my case: unlock with a PIN).

  1. Open an app or website, use autofill, enter passphrase, select item (maybe automatically selected as a suggestion), then return to app.

  2. Sometimes credentials don't actually fill, so you do autofill again, and enter passphrase, select item, then return to app. Hopefully on second time the creds get filled. Good.

  3. Now, open up 1P or use autofill on another app, and you still have to use passphrase to unlock. Very annoying.


1Password Version: 7.3.2
Extension Version: Not Provided
OS Version: iOS 12.3.1
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member

    Hi @snappy

    Is your device capable of Touch ID? If so I'd recommend trying the following settings and see if that works better for you:

    • 1Password > Settings > Security > Touch ID > On
    • 1Password > Settings > Security > Lock on Exit > Off
    • 1Password > Settings > Advanced > Security > Always show lock screen for Password AutoFill > On

    Please let me know. :+1:

    Ben

  • Hi @ben,

    Appreciate the suggestion, but I'm uninterested in TouchID for accessing the "crown jewels." I prefer an authentication system that won't allow someone to login if I'm incapacitated (haha - as if this scenario is ever going to play out though).

    But I'm happy to try it and see if I can replicate the issue.

    I'm pretty sure the problem would still persist though; the problem is that 1P on what is seemingly cold start is not going to "dormant" mode when triggered by an autofill prompt, even after repeated successful unlock attempts. What works is going to 1P and explicitly opening it up, and then autofill prompts will start using PIN unlock.

  • BenBen AWS Team

    Team Member

    But I'm happy to try it and see if I can replicate the issue.

    Please do let me know if with those settings it works more in line with what you're expecting. Both Touch ID / Face ID and a PIN are considered "Quick Unlock" by 1Password, but I'm thinking there may be differences in how they are handled.

    I'm pretty sure the problem would still persist though; the problem is that 1P on what is seemingly cold start is not going to "dormant" mode when triggered by an autofill prompt, even after repeated successful unlock attempts. What works is going to 1P and explicitly opening it up, and then autofill prompts will start using PIN unlock.

    I'm not entirely sure I follow, but if I do... that is currently working as designed. It is necessary after a restart to enter the Master Password in the main 1Password app (not autofill / the share sheet extension) before Quick Unlock will work in autofill / the extension.

    Ben

  • I'm not entirely sure I follow, but if I do... that is currently working as designed. It is necessary after a restart to enter the Master Password in the main 1Password app (not autofill / the share sheet extension) before Quick Unlock will work in autofill / the extension.

    Sorry let me clarify.

    Start with a cold start of iPhone.

    1P is not in Quick Unlock state.

    Enter an app or browser which will prompt an autofill suggestion (I don't remember if at this point there is a recommended suggestion or just say "open 1P", but whatever). Select to open up 1P.

    Enter passphrase, select item, and return to app. May need to do this multiple times (using the autofill prompt) because sometimes the credentials don't fill. Every time requires a passphrase unlock. So note: even though you've filled in passphrase first time, 1P hasn't gone into Quick Unlock mode on subsequent autofills.

    Now, open 1P explicitly from home screen, enter passphrase, exit. 1P is now in Quick Unlock mode.

    Use 1P app explicitly or via autofill prompt and you can now unlock using Quick Unlock mode.

    Let me know if that helps.

  • BenBen AWS Team

    Team Member

    Right; that's correct. After a reboot of your iPhone you have to enter your Master Password in the main 1Password app once first before Quick Unlock will be available in autofill. That's working as designed. In a future version we'd love to be able to have entering your Master Password in autofill enable Quick Unlock after a reboot, but at this point I'm not sure that is something we'll be able to do.

    Ben

  • That's working as designed.

    But don't you think that's an annoying UX thing?

  • BenBen AWS Team

    Team Member

    I do, yes. As I mentioned we'd very much like to make improvements here in the future, but we're playing in someone else's sandbox, so this may not be something we can do on our end with the currently available tech. :)

    In a future version we'd love to be able to have entering your Master Password in autofill enable Quick Unlock after a reboot, but at this point I'm not sure that is something we'll be able to do.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file