System.DllNotFoundException

robfarrrobfarr
edited June 12 in Windows

1Password (Windows) Version 7.2.617, clean installation using a fresh copy of the setup executable from the 1 Password website.

Launching the application causes an immediate crash, no user interface is displayed.

From Event Viewer:

`Application: 1Password.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.DllNotFoundException
at AgileBits.OnePassword.Native.SetCurrentLanguage(System.String)
at AgileBits.OnePassword.StringsManager.set_Locale(System.String)
at AgileBits.OnePassword.StringsManager..ctor()
at AgileBits.OnePassword.The..cctor()

Exception Info: System.TypeInitializationException
at AgileBits.OnePassword.The.get_Console()
at AgileBits.OnePassword.App.CurrentDomain_UnhandledException(System.Object, System.UnhandledExceptionEventArgs)
`


1Password Version: 7.2.617
Extension Version: Not Provided
OS Version: Windows 10.0.17134 Build 17134
Sync Type: Not Provided
Referrer: forum-search:System.DllNotFoundException

Comments

  • Attempted (re)installing the application, as well as deleting the %appdatalocal%/1Password directory before re-installing with no affect.

  • GregGreg

    Team Member

    Hi @robfarr,

    Thank you for reporting this! Please try to do the following:

    1) Find 1Password folder in %LOCALAPPDATA% folder and move it to desktop.

    2) Download and run the installer of 1Password 7.3 from here.

    Does the issue remain with it? Let me know. :+1:

    ++
    Greg

  • I actually can't download that version of the installer (or any 7.3.x version from the release notes page for that matter).

    I receive an error "Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item." when attempting to open the installer.

    And "You require permission from Everyone to make changes to this file" when attempting to move the installer.

    Thanks for the quick response.

  • robfarrrobfarr
    edited June 12

    Following on from this, it appears that the access permissions for "1password.dll" are corrupt. Immediately upon loading any version of the file anywhere on the computer renders it un-readable.

    I have even tried copying the DLL from a known good working PC onto the desktop of the non-working Windows PC. As soon as the DLL touches the non-working PC it cannot be read ... I'm unsure what is incorrect with the permissions as of yet. This sounds like an AV issue, but the problem persists when in safe mode with AV software disabled.

  • bundtkatebundtkate

    Team Member

    Have you tried this on a fresh user profile, by chance, @robfarr? Just create a local user as a test on the same PC and see if that local user is able to install any version? AV is a good theory, but I think this could be profile corruption as well so this seems a worthy test.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file