Extension doesn't fill on Wordpress login page

I manage a Wordpress site (hosted on my own domain) and the 1Password extension does not fill my login. The extension window comes up and I select my login, but nothing happens. My URL is: https://stairwells.org/wp-login.php


1Password Version: 7.3
Extension Version: 4.7.4.90
OS Version: 10.14.4
Sync Type: 1Password.com

Comments

  • ag_anaag_ana

    Team Member

    Hi @ggilder,

    I have just tried filling on that page and it worked here right away. What browser is this happening with please?

  • @ag_ana this is on Chrome 74.0.3729.169. Interestingly the problem is happening for me on Safari too.

    I noticed something and did a little test — it appears I've found a different bug. I noticed that the login was saved with a URL of "STAIRWELLS.ORG/wp-admin" - the domain was in all caps. I edited the login and changed it to lowercase, "stairwells.org/wp-admin", and now it fills properly!

    I'm glad it's working now, but this is a bug since domains should be case-insensitive.

  • ag_anaag_ana

    Team Member

    @ggilder:

    I am happy to hear that things are working again for you :)

    After using my 1Password browser extension to create this test item, I can see the URL field is lowercase for me, like every other 1Password item with a URL field. Therefore I take it that you manually typed the URL in your 1Password item with caps lock enabled, correct?

  • @ag_ana I'm not sure, I think this login might have actually been imported from another password manager a while ago.

    The funny thing is that clearly the extension is detecting it as a match for the page — the login shows up in the extension when I'm on that page whether the domain in the login URL is capitalized or not — but it just fails to fill the login when the capitalization of the domain doesn't match.

  • ag_anaag_ana

    Team Member
    edited June 2019

    @ggilder:

    I'm not sure, I think this login might have actually been imported from another password manager a while ago.

    Ah yes, that could be an explanation.

    The funny thing is that clearly the extension is detecting it as a match for the page — the login shows up in the extension when I'm on that page whether the domain in the login URL is capitalized or not — but it just fails to fill the login when the capitalization of the domain doesn't match.

    I agree. I will open an internal issue to see if there is anything we can do to work around this ;)

    ref: xplatform/filling-issues#581

  • ag_anaag_ana

    Team Member

    @ggilder:

    A quick update about this: we have tested the website again on the latest 1Password X beta and an internal version of 1Password for Mac. So one of the next updates for 1Password for Mac and for 1Password X should include the fix as well :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file