1Password in Firefox - Having Trouble

nhDOBsfcnhDOBsfc
edited June 23 in Windows

I have been using 1Password with Chrome for a long time. Today, I tried changing my default browser to Firefox, and I'm having difficulty getting the 1Password extension to show up in Firefox. I don't see the extension at all. I tried searching for Firefox in this forum to see if there is a pre-existing thread before starting a new thread. That lead me to a Firefox extension called 1Password X, that I also installed. Still no luck.

For clarity, I see the 1Password and 1Password X extension in Firefox "about:addons," and both are enabled, but I don't see any 1Password Icons on my main Firefox screen.

Also, FireFox version is 67.0.2, 64 bit.


1Password Version: 7.3684 Windows
Extension Version: Extension 4.7.4.90, and 1Password X 1.15.3
OS Version: Win 10 Pro 1903
Sync Type: 1Password Cloud

ref: XYL-82474-671

Comments

  • brentybrenty

    Team Member

    @nhDOBsfc: If you have a 1Password membership, you can use either 1Password X or the 1Password desktop app/extension. I recommend choosing one of those, as it can get pretty confusing to have more than one 1Password extension installed. It sounds like maybe you just need to enable the icon in Firefox. Do you see it when you right click and choose "Customize"?

  • @brenty , I uninstalled both extensions (1Password X or the 1Password desktop app/extension) and restarted Firefox. Then I reinstalled the 1Password desktop app/extension into Firefox. Then I right clicked and chose "Customize." No, I do not see the 1Password Icon there, but I do see several other Icons.

  • bundtkatebundtkate

    Team Member

    What about if you press Ctrl + \ on Firefox's start page, @nhDOBsfc? Do you see 1Password mini pop up?

  • No, neither Ctrl + \ nor Ctrl \ does anything. Well, its really no big deal. I switched my default back to Chrome. I'll keep an eye out here for any new instructions, but it's like like I'm dealing with a total outage.

  • bundtkatebundtkate

    Team Member

    Any anti-virus on this PC by chance? It definitely sounds like 1Password isn't connecting to Firefox by the laundry list of typical causes there is pretty short. Another thing I can think of is that Firefox has made some recent changes that I've noticed will prevent new extensions from enabling right away in some cases. I've not seen that with 1Password, but it may depend on settings and, as I understand, behaviors might be different for new installs vs. existing installs of Firefox. When this happens to me, there's an orange icon in my toolbar. Clicking that icon will allow me to enable whatever extension I installed by accepting its permissions. If you see one of those icons, it's worth giving it a click to see if maybe you need to accept some permissions to enable 1Password.

  • @bundtkate , I'm using "McAffee Total Protection," and it does have a Web addon that it periodically installs on all my internet browsers, but I manually disable it when I notice it. The McAffee Web addon is instantly noticed, because it changes the search engine on the internet browsers to McAffee Safe Search, which is their fork of Yahoo.com. So, I disable the McAffee Web addon right away every time it reactivates itself, which is approximately monthly.

  • bundtkatebundtkate

    Team Member

    In that case, @nhDOBsfc, you might try rebooting in Safe Mode with Networking and seeing if you can fill then:

    https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode

    While interference from anti-virus apps is less common these days with some changes we've made to filling in the past year or so, they still do pop up sometimes. If thinks work in Safe Mode, that's a good sign that at least something is interfering with that process on your PC and that we need to take a closer look from that angle. :chuffed:

  • @bundtkate , I rebooted in safe mode and still didn't see 1Password icon in Firefox. Next, while still in safe mode, I disabled and re-enabled the 1Password addon within Firefox, and and still didn't see 1Password icon in Firefox. I tried to re-download the 1Password addon for Firefox, but then learned I had no network access in safe mode, lol.

  • brentybrenty

    Team Member

    @nhDOBsfc: Select "Safe Mode with Networking". Very handy. :)

  • nhDOBsfcnhDOBsfc
    edited June 24

    @brenty or @bundtkate , would you please check and make sure my 1Password is not hammering your server with requests, as was the case in https://discussions.agilebits.com/discussion/99052/force-1password-windows-10-to-sync#latest , which ended up being attributable to Razer Synapse 2? I am now using Razer Synapse 3, and I'm experiencing some 1Password synchronization weirdness.

    Razer Synapse 2: https://www.razer.com/synapse-2
    Razer Synapse 3: https://www.razer.com/synapse-3

    Emailed diagnostics report. Sent: Sunday, June 23, 2019 10:59 AM

    ref: XYL-82474-671

  • GregGreg

    Team Member

    Hi @nhDOBsfc,

    This question is quite different from the one you asked in your initial post, so I am a little confused. Have you managed to solve the issue with 1Password icon in Firefox on your side? Please let us know. Thank you!

    ++
    Greg

  • @Greg , no I've not managed to solve the Firefox problem, and so I'm just using Chrome which works fine. I had a situation where I had to reboot my computer to get a new 1Password entry, made on my computer, to sync up and become available on my phone.

  • GregGreg

    Team Member

    Hi @nhDOBsfc,

    I found your new report on our side, so let's continue our conversation via email. Thanks! :+1:

    ++
    Greg

    ref: XYL-82474-671

  • nhDOBsfcnhDOBsfc
    edited July 13

    1Password is now working in Firefox! Several software packages have updated since the original report. Current status is:

    FireFox version is 68.0, 64 bit.
    1Password Version: 7.3.702 Windows
    Extension Version: Extension 4.7.5.90
    OS Version: Win 10 Pro Version 10.0.18362 Build 18362
    Sync Type: 1Password Cloud

    Case closed!

  • ag_anaag_ana

    Team Member

    Thank you for the update @nhDOBsfc! I am happy to hear this :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file