Support for the new Firefox Preview (AKA Firefox Fenix)

👋 I came across Firefox Preview today and I noticed that 1Password autofill doesn't appear on it.

I visited their GitHub issues tracker and came across https://github.com/mozilla-mobile/fenix/issues/87 which leads to https://github.com/mozilla-mobile/fenix/issues/87#issuecomment-497493449

It appears this is pending on a change at your end. Could you flag this up to your Android product team, please? I am a huge fan of 1Password and I am hoping to see this available on Firefox Preview (Firefox Fenix).

Thank you!


1Password Version: 7.1-BETA-5
Extension Version: Not Provided
OS Version: Android 9
Sync Type: 1Password.com

Comments

  • Actually, giving it another try, I see 1Password's autofiller now. I am not sure why it did not appear earlier. Feel free to close/resolve this forum post.

  • I probably spoke too soon here. While the 1Password autofiller appears, the 1Password results do not match the website I am on. Is this something your Android team should look at? 🤔

  • periperi

    Team Member

    Hi @arunsathiya. Thanks for reaching out! I'm not seeing this behavior with Firefox Preview on my end. Can you clarify what version you're using? The original message shows 7.1-BETA-5, though 7.1.5 is our stable build.

  • Just to clarify, are you saying that your app on your Android is showing proper logins (by matching the active domain) when using on Firefox Preview? My version is correct. I probably haven't updated to latest because I don't use Google Play Store anymore, and there aren't any other distribution channels that 1Password is using.

  • periperi

    Team Member

    @arunsathiya Indeed, I'm seeing matching Logins when filling in Firefox Preview. I believe the issue due to the fact that you're using an outdated version of 1Password, which was released in December. In recent updates, we've made improvements to Autofill in Android Preview. I strongly recommend installing the latest build from the Play Store so you can get this issue resolved.

  • Thanks for confirming. I cannot update the app unfortunately, as I don't use Google Play Store anymore. I hope you consider other app distribution channels in the future, for such users. Thanks.

  • brentybrenty

    Team Member

    Thanks for clarifying. We use the Google Play store because it allows us to get 1Password to users through a trusted channel where it can be verified that nothing has been tampered with using the codesigning all the way through the chain. That also makes purchasing secure and convenient, which is good for everyone involved. We don't have plans to distribute it anywhere else.

  • edited July 9

    The latest 1Password beta from the Play Store doesn't work either (no autofill popup) and forcing autofill via the keyboard detects the app as Firefox Preview rather than the website (see screenshot). https://imgur.com/a/LGLKOib

    1Password 7.2.BETA-5
    Firefox Preview nightly 190709 18:02

  • periperi

    Team Member
    edited July 10

    Hi @Canuckistan. Autofill is working for me in the latest beta with both Firefox Preview and Firefox Nightly. Can you please launch 1Password and disable Autofill, then re-enable it? Does that help?

  • I tried that, no luck. Then I restarted my device and it worked once. Subsequent attempts don't work either. I'm on Android 8, for what that's worth.

  • periperi

    Team Member

    You mentioned previously that you're using the beta version of 1Password, @Canuckistan. Can you update to the latest beta build and let us know if that resolves the issue for you?

  • Sort of - I can now consistently get it to work once after disabling/enabling autofill on BETA-6, after which it stops working again until I enable/disable again. Firefox Preview Nightly 190712 06:02

  • periperi

    Team Member

    Can you please wait until it stops working, then immediately create a diagnostics report from your Android device:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/105040/support-for-the-new-firefox-preview-aka-firefox-fenix#latest
    • Your forum username: Canuckistan

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!

  • edited July 15

    So I actually upgraded to Q Beta 5 over the weekend (from Oreo previously) and the issue is completely gone - autofill works perfectly now. This means I can't capture the bug report for you anymore unfortunately, but I'm guessing the issue has to do with a bug in Oreo's Autofill APIs

  • saadsaad

    Team Member

    We’ve been testing on Android Oreo as well, and Firefox Preview is working fine on our end. This makes it harder to reproduce and identify the cause. We’ll certainly keep an eye out to see if there is something OS specific that prevents filling in Firefox Preview. I’m glad you can use Autofill on the latest Android Q beta. Thanks for sharing your findings.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file