1password extension is no longer working in Safari

1password has suddenly stopped automatically filling in login details in Safari. 1password is asking me to enable the 1password extension in safari. The 1password extension is no longer in the the Safari extension list. I have tried reloading the extension from the App store where it is shown as being in the iCloud but nothing seems to happen. this has not solved the problem and does not make it appear in the available extensions list. Have tried turning off 1password, and rebooting my Mac but this has not solved the problem either. Do I need to remove 1password altogether and reload it again?


1Password Version: 7.3.2 beta
Extension Version: ?
OS Version: OSX 10.14.5
Sync Type: iCloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @JStatton!

    The 1password extension is no longer in the the Safari extension list.

    By Safari extension list, do you mean the one next to the Safari URL bar, or directly inside Safari Preferences > Extensions tab?

  • Yes 1password does not appear in this Extensions screen as you have shown. I have then gone to the "More Extensions" tab to download again from App store but this still does not bring it into this Extensions window.

  • ag_michaelcag_michaelc

    Team Member

    @JStatton, please open 1Password 7, then press Control-Option-Command-Q on your keyboard to quit 1Password completely. Also quit Safari. Then, without using any app cleaners, drag 1Password 7 to the Trash, and reinstall a fresh copy from 1Password.com/downloads. Once that's done, go into Safari's preferences under the Extensions tab. Do you see the extension there now? If it's disabled, enable it, and if it's already enabled, toggle it off and on, please.

    Are things working after these steps?

  • Thanks
    Reloading 1password7 has worked and fixed the problem
    Cheers from Australia

  • ag_anaag_ana

    Team Member

    You are welcome @JStatton! I am glad to hear everything is working again :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • I have the same problem with 6.8.9. Upgraded my old iMac to an SSD drive, and now iPassword extension in Safari is nowhere to be found. I quite Safari, deleted and reinstalled 6.8.9, rebooted the iMac. Nothing. Can you help me?

  • ag_michaelcag_michaelc

    Team Member

    Hey @bnlgrabo :smile:

    Which version of Safari are you running? You can grab the Safari extension for 1Password 6 here but please note this won't be compatible with Safari beyond Safari 12. You'll need to upgrade to 1Password 7 due to changes coming in Safari 13. You can find out more about this here:

    https://blog.1password.com/safari-13-is-awesome-upgrade-from-1password-6/

  • 1Password - 7.3.1
    Safari - 12.1.1
    Mojave - 10.14.5

    I'm having this problem now - it suddenly vanished from Safari. I've tried all the steps above (close apps > delete > empty trash > reboot > reinstall) but no luck.

    Any other ideas please?

  • ag_anaag_ana

    Team Member

    Hi @Riadsala,

    After doing all those things, do you still not see the 1Password extension under Safari Preferences > Extensions tab?

  • No. The list of extensions (Safari>Preferences>Extensions) is totally clear. I don't use many (other than 1P!)....

  • ag_anaag_ana

    Team Member

    @Riadsala:

    Can you please send us a diagnostic report from your Mac, so we can take a closer look at why this is happening to you? You can send it to [email protected]

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and get back to you as soon as possible.

    Looking forward to your message!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file