On iOS have to enter master password for every login even though biometrics is enabled

jasimon9jasimon9 Member

This sounds similar to the question at https://discussions.agilebits.com/discussion/105084/why-do-i-have-to-enter-my-master-password-for-every-login-on-ios-and-how-do-i-fix-it#latest.

Ever since the beginning, I have been able to use the fingerprint authentication on my iPhone to unlock 1P. However, that is stopped. I have to enter the master pw into the app every time. Even if there is some problem with the login and i have to start over, I have to again enter my master pw.


1Password Version: 6.8.9
Extension Version: 4.7.5.90
OS Version: 10.14.5, iOS 12.3.1
Sync Type: dropbox

Comments

  • BenBen AWS Team

    Team Member

    Hi @jasimon9

    Could you please confirm which version of 1Password for iOS you're running? If you unlock the 1Password app (not autofill above the keyboard or the extension) and then try again do you continue to have to enter your Master Password?

    Ben

  • jasimon9jasimon9 Member

    Is this not what you want?

    1Password Version: 6.8.9
    Extension Version: 4.7.5.90
    OS Version: 10.14.5, iOS 12.3.1
    Sync Type: dropbox

    Do you mean the following;
    1. on the phone unlock the 1P app? Would that mean open it and enter credentials?
    2. This is new behavior. I never had to do that before. Has something changed?

  • BenBen AWS Team

    Team Member

    v6.8.9 isn't a version of 1Password for iOS. The version 6.8 release cycle only went to v6.8.2.

    1. on the phone unlock the 1P app? Would that mean open it and enter credentials?

    Yes.

    1. This is new behavior. I never had to do that before. Has something changed?

    No recent changes have been made in this regard.

    Ben

  • jasimon9jasimon9 Member

    When I look into 1P on my phone, it shows 7.3.3 in the text near the bottom of the Settings page. Is that what you want?

  • BenBen AWS Team

    Team Member

    When I look into 1P on my phone, it shows 7.3.3 in the text near the bottom of the Settings page. Is that what you want?

    That makes more sense, yes, thanks. That said, I'm still not sure what we can do to help here. It sounds to me as though things are working as designed? It is a known & expected situation that you have to launch and unlock the 1Password app once with the Master Password (particularly after a reboot of the device) in order to then subsequently unlock the autofill function using biometrics. In the future we would like to find a way to remove that requirement, but that is the current state.

    Ben

  • jasimon9jasimon9 Member

    Thanks Ben. I will see if that helps. Just don't recall having to do that before, but it might have been serendipitous that I had unlocked 1P "once" with the Master Password before using it later.

  • BenBen AWS Team

    Team Member

    You're welcome. If you do find that you're having to do it more than once after a reboot in order to enable biometrics please let us know. :+1:

    Ben

  • I agree. I NEVER had to enter my master password after rebooting my iPhone device. Only had to use the fingerprint. But when I updated to the latest release a couple of days ago, that all changed. Now I have to enter the master one time after every time I reboot the device. I am running 7.4.1

    James

  • I found the fix that allows you to get into 1Password after IOS reboot. Once in the app, go to settings, then advanced, and then security. Set “Require Master Password” to Never. Then when you reboot your IOS, launch 1Password and it will present you with a fingerprint icon under the textbox to enter your Master Password. Press the icon on the screen. It will then prompt you to use the Touch ID.

  • BenBen AWS Team

    Team Member

    @jrmocfl

    Yep; that should do it, though I'm not sure how you were able to reboot before without bring prompted for your Master Password if that wasn't set that way. 🤔 It is also worth mentioning that 'never' doesn't truly mean never and that you can forget your Master Password. The Master Password will still be required for some operations and if for any reason Touch ID becomes unavailable (including if you change the fingerprints registered with Touch ID).

    Ben

  • Hi Ben, I kind of alluded to that when I said "Once in the app....." I should have said, "Once you enter your master password, go to settings.....

    Thanks,
    James

  • BenBen AWS Team

    Team Member

    @jrmocfl

    Sorry; I don't think we're on the same page. I was commenting on this statement:

    I NEVER had to enter my master password after rebooting my iPhone device.

    I don't know how that would've been possible if Settings > Advanced > Security > Require Master Password weren't already set to 'never'.

    Ben

  • Oh, okay. Let me explain. I must have had this setting set to 'NEVER' a long time ago, but forgot about the setting. I didn't just update to the latest 1Password, but removed 1Password from the phone, along with its settings, and reinstalled it because I was having some issue. After reinstalling 1Password, I had to keep entering my password every time I rebooted, but prior to this, ..... "I NEVER had to enter my master password after rebooting my iPhone device". So maybe the person who opened this ticket did the same thing as me.

  • BenBen AWS Team

    Team Member

    Ah, gotcha. Thanks for the additional details. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file