I am getting a second factor prompt a lot

I have enabled 2FA on my 1Password account, and a lot of the time when I use the integrated password filling in iOS I get a notification that tells me to tap on it to enter the 2FA code. I ignore it and the password fills correctly. Also the 1Password app seems to work ok and gets updates, but rarely asks for the 2FA code.

Why is it asking me for the 2FA code so often, and even when it doesn't seem to need it and doesn't stop the form filling if I don't enter it?


1Password Version: 7.3.3
Extension Version: Not Provided
OS Version: ios 12.2
Sync Type: Not Provided
Referrer: forum-search:two factor prompt on ios

Comments

  • BenBen AWS Team

    Team Member

    Hi @matty666

    I'm sorry to hear about the difficulty.

    Why is it asking me for the 2FA code so often

    It shouldn't be. I'd recommend disabling 2FA and re-enabling it as a troubleshooting step.

    and even when it doesn't seem to need it and doesn't stop the form filling if I don't enter it?

    2FA is used for authenticating with the 1Password server, not for accessing data that is already cached on your device.

    Ben

  • Thanks @Ben I've just tried turning off 2fa and then re-enabling it.

    Its still the same. If I open, say, chrome on my iphone, and go to a login form to fill, then tap the 1password prompt to auto-fill it, it lists the passwords to choose from, but also the tap to enter 2 factor notification appears every time.

    I can tap it and it opens the 1password app, but it never asks for the 2nd factor code.

    It does this pretty much every time

  • BenBen AWS Team

    Team Member

    @matty666

    After getting such a prompt please generate a diagnostic report for us.

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/105119/i-am-getting-a-second-factor-prompt-a-lot#latest
    • Your forum username: matty666

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!

    Ben

  • matty666matty666
    edited July 9

    Thanks Ben, I sent a couple of diagnostics reports, the first one I missed off the link and username but the 2nd one I didn't.

    I'll post the support id numbers when they arrive.

  • BenBen AWS Team

    Team Member

    Thank you. I was able to locate both reports, so no need to post the support IDs. I've asked for a second set of eyes from our QA team so hopefully we can take a look together in the morning and see what we can figure out.

    Ben

    ref: MTH-67684-462

  • Awesome thanks, the support ids haven't come through yet anyway so glad you found the reports! :)

  • LarsLars Junior Member

    Team Member

    @matty666 - yep, one of us will be with you as soon as possible. Let's keep the conversation going via email instead of in multiple places at once. Thanks! :)

  • I am also seeing this same issue on my MacBook with macOS Mojave. I've submitted a support ticket with the diagnostics info.

  • BenBen AWS Team

    Team Member

    @georgewitteman

    I've replied to your email. To avoid duplicating efforts let's continue the conversation there please. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file