Lost sync between iOS 1P7 and MacOs 1P7 after recent upgrade

So …
I've been using 1P since … v3 maybe. As early as everything was out on iOS too.
I've had 1P 7 on iOS for quite some time now, along MacOS 1P 6. And it worked quite well.
Just upgraded the MacOS to 7.
My vault got … upgraded ? … there. And I cannot seem to have my two 1P 7 to sync now.
I deleted both apps, reinstalled. I followed the sync troubleshooting (turning sync off, reseting iCloud data, restarted sync), did not work.
I completely remove the app on iOS, reinstalled, and now, at startup, iCloud shows "no vault were found in iCloud", while MacOS shows confirmation of the sync with the time.
I'm a developper, and went to check what's in my MobileDocs (iCloud), and I see two entries:

  • HASH~com~agilebits~onepassword
  • (SAME)HASH~com~agilebits~onepassword-ios

Could that maybe be the source?

Thank you!


1Password Version: MacOS 1P 7.3.1, iOS 1P 7.3.3
Extension Version: Not Provided
OS Version: MacOS 10.14.5, iOS 12.3.1
Sync Type: iCloud

Comments

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @berengerzyla! I'm sorry for the trouble. If you've been using iCloud as your sync method, then your vault wouldn't have been upgraded. We DID retire the older Agile Keychain format of sync keychain that was used in Dropbox, in favor of the newer OPVault format, but iCloud has always used this newer format (at least, since 2014), so that wouldn't have been the issue you're experiencing.

    Do you use the same Apple ID on both your Mac and your iOS device(s)? Or do you maybe have multiple Apple IDs for various reasons/testing/etc? Make sure you're using the same Apple ID on all devices you want to use 1Password on. If you are - or if you only have one Apple ID - then that won't be an issue. Let me know what you discover.

  • I have the same iCloud accounts on both, and it worked well until the upgrade on Mac.
    It's fine now, even though it took several tries. What worked:

    • Deactivated iCloud sync on Mac.
    • Reseting iCloud data on Mac.
    • Deactivated iCloud sync on iOS.
    • Reseting iCloud data on iOS.
    • Deleting the app on iOS and all its data (otherwise, a try with just the steps before did not work, even scraping all data from within the app).
    • Restarting app on Mac, restarting iCloud sync on Mac.
    • Reinstalling the app on iOS, configuring using vault from iCloud.

    Without deleting the app on iOS, somehow, it would say "no vault were found in iCloud".

    Anyway, it works now :)

  • ag_anaag_ana

    Team Member

    Thank you for the update @berengerzyla, and for sharing the steps that worked for you! I am happy to see that things are working again :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file