Two versions on one computer

I have 1Password Version 6.8.8 (688001) bought on the Mac App Store years ago. I also downloaded 1PW7 a couple of days ago and signed up for a 30 day trial. Do I have two accounts now? My master password for both versions is the same. I've been trying to move my logins, etc. from v. 6 and have tried to follow directions on the website but I can't figure it out.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:I've been working with someone from support in an email thread and hope we can resolve my problem.

Comments

  • LarsLars Junior Member

    Team Member

    @Bart523 - I'm sorry for the confusion.

    Do I have two accounts now?

    No. If you actually purchased 1Password for Mac from the Mac App Store years ago, that's a standalone version of 1Password, meaning: you pay up front for the software, then you install it and create your data (vaults) locally, and sync it (if you wish) via one of our 3rd party sync services (Dropbox, iCloud, or even WLAN). What you just signed up for a 30-day trial of is a 1password.com membership/account. In a 1password.com account, you have local copy of your data, but it's synced through the 1password.com servers, not any 3rd party services like Dropbox or iCloud.

    What's puzzling me is that when you installed 1Password 7 for Mac, it should have recognized that you had 1Password 6 for Mac installed, and imported your data, then zipped up version 6. I take it that did not happen? It may be because you're on a significantly older version of 1Password 6 for Mac (6.8.9 was the final version of 1Password 6). When you open 1Password 7 for Mac, what do you see? Is your previous data present? If so, is it what you would consider a complete and up-to-date copy of your data?

  • Bart523Bart523
    edited July 11

    This is the version I have:
    1Password
    Version 6.8.8 (688001)
    Mac App Store
    When I installed 1PW7 no data was imported from the above version.
    When I open 1PW7 I see:
    on the left Personal, my name, a +New Vault
    in the middle my name next to a "contact" card, under that Welcome to 1Password!, under that 1Password Account with my name and email.
    on the right details of each of the above items in the middle section

    With 1Password7 open I just looked into file/import/where is your data coming from?(which would be 1PW6/then another box popped up B5.sqlite and OnePassword.sqlite highlighted and it says the contents will be merged into Personal.
    Will this work? Do I choose both B5.sqlite and OnePassword.sqlite?

  • LarsLars Junior Member

    Team Member

    @Bart523 - you'll want the OnePassword.sqlite file, but before you do that, click the drop-down menu at the top of the import window, and make sure the file you're looking at is in this location ...(your Mac username)/Library/Containers/2BUA8C4S2C.com.agilebits.onepassword-osx-helper/Data/Library/Data, like this:

    (and yes, my test Mac's username is "crash" ;) ). If that's the file, then yes, the OnePassword.sqlite file you're looking at is the one you want. Select it, click "Open," and you'll be required to enter your Master Password for 1Password 6 for Mac (if you used a different one there). You should see the import window with "Success!" at the top.

    Click "View Imported Items" to be taken to your vault. Let me know how that works for you. :)

  • Bart523Bart523
    edited July 11

    Thanks, It worked!
    Now how do I get 1PW7 on my iPhone and iPad? I already have 1Password installed on both but do I need the new 1PW7 app?

  • BenBen AWS Team

    Team Member

    @Bart523

    Are you sure you don't already have v7 installed on the iPhone and iPad?

    How to keep 1Password (for iOS) up to date

    Ben

  • I have them but they're the old version 6. Do I need to delete the old app from iPhone and iPad and download the new?
    I guess that's a duhhhh question.

  • BenBen AWS Team

    Team Member

    I would be really surprised if they're actually version 6 unless you are running an old version of iOS that isn't capable of running v7. Would you mind double checking exactly which version is installed using the instructions I linked to in my last message?

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file