1Password doesn't fill in the Bank of America login information if online ID is stored.

There have been two recent Bank of America threads already, but in my mind they don't get to the heart of the problem. 1Password works with the Bank of America website (https://www.bankofamerica.com/) if I do not save my online ID. (The website has a checkmark I can select to save my ID between sessions.) However, the moment I do save my ID, 1Password autofill doesn't work anymore. (The password field doesn't seem to get recognized. The 1Password button in the field doesn't show.) Now you might say that I don't have to save my ID with Bank of America, which is true in principle, only that then Bank of America wants me to verify my identity (via a challenge question) every time I log in. In aggregate, the result is that 1Password as it currently stands is not useful for the Bank of America website.


1Password Version: 7.3.1
Extension Version: 1.15.3
OS Version: OS X 10.14.5
Sync Type: Not Provided
Referrer: forum-search:bank of america

Comments

  • brentybrenty

    Team Member

    @clauswilke: It sounds like you're talking about some different things here. If you use 1Password for Mac and its desktop extension, it fills just fine at the URL you provided whether the "Online ID" is saved or not.

    But you don't seem to be using that, but rather 1Password X, which is separate. It sounds like, if not saving the "Online ID" allows it to work the way you want, that's the way to go then. But I would like to know the specific steps you're taking and what is (or is not) happening as you expect.

    To clarify, "Save Online ID" has nothing to do with having to enter a "challenge question"; that's a completely separate choice on the following page: "Yes, remember this computer." or
    "No, don't remember this computer." It sounds like the former is what you want.

    What you're describing, with the password field not filling, seems to be in reference to a completely different page than the one you linked. In that case, the password field is disabled on the site until the username is filled. There's nothing we can do about that.

    Anyway, let me know the details and we'll go from there.

  • My browser is Google Chrome and I'm using the Chrome extension. Is that 1Password X?

    This is the login field:

    If I do not select "Save Online ID" then autofilling will continue to work in the future, but I get asked a challenge question every time. There is no button I can click to avoid the challenge questions in the future.

    The only way to avoid getting asked challenge questions every time is to save the online ID in the first box, in which case the next time it'll look like so:

    Note that the passcode field is selected, but the 1Password button does not appear. The passcode field is not recognized for some reason.

    Without online ID stored, it looks like this (as expected):

    Therefore, in summary, I can either have 1Password (X?) autofill the form or I can avoid the challenge question, but I cannot have both at the same time.

  • brentybrenty

    Team Member
    edited July 12

    @clauswilke: Thanks for getting back to me with the additional details! That helps a lot. :)

    My browser is Google Chrome and I'm using the Chrome extension. Is that 1Password X?

    I'm using Chrome too. The extension you're using there is 1Password X. Nothing wrong with that. Just wanted to make sure you weren't trying to use the desktop app/extension and getting confused because of that. I think there's a solution regardless.

    If I do not select "Save Online ID" then autofilling will continue to work in the future, but I get asked a challenge question every time. There is no button I can click to avoid the challenge questions in the future.

    I really appreciate the screenshot, because I probably wouldn't have believed you otherwise. Inexplicably, you don't seem to be getting this option:

    You may want to reach out to the bank for help with that. The only thing I can think of is you have cookies or something disabled completely. Otherwise something is broken.

    Note that the passcode field is selected, but the 1Password button does not appear. The passcode field is not recognized for some reason.

    Correct. 1Password X doesn't know this is a login form when there is no username field. That's why it's not showing the inline icon. But you should be able to fill from the 1Password X icon in the browser's toolbar:

    Therefore, in summary, I can either have 1Password (X?) autofill the form or I can avoid the challenge question, but I cannot have both at the same time.

    I think there's probably room for improvement with both 1Password and the website, but this workaround should help. Let me know how it goes. :)

    ref: xplatform/filling-issues#364

  • Aha, problem solved. On my screenshot, instead of the security preference settings, you see the following:

    You're seeing this screen because you told us to ask you a challenge question at every sign-in. You can change your security preference in Profile & Settings.

    I hadn't notice this before. After going into Profile & Settings and telling the site to remember my computer, things work. I don't store my online ID through the site, 1Password X fills in the ID and the password, and I don't have to answer any security questions. Thanks!

  • brentybrenty

    Team Member

    Oh, dang. Good catch! Mystery solved, and that sounds like a workable solution. Glad to be able to help, at least indirectly. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file