Firefox logins autofill but login not working

I just upgraded to a Samsung S10e, and installed 1Password and also 1PasswordX Add on in Firefox. It was working OK for a week and then about a week ago it has stopped working. In Firefox I open up a site I want to log into, then I click on "Autofill in 1Password" that comes up, it fills my login details in the form, then I click to login, but then it just returns me to the login screen without logging in. I have tried this with a few different logins. Some give me an error saying there is a problem serving the requested page. Another one displays messages that the login is successful, but then it shows the login screen and does not log in. I have updated to the latest version of Firefox and rebooted my phone.

When I try to log in through the 1Password app and not my browser it works fine. But this is not suitable as I want to go through my browser, and I don't like using the 1Password app.

thanks


1Password Version: Not Provided
Extension Version: 1.15.3
OS Version: Android 9
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @AngeP!

    What happens if you manually copy and paste the password from the app to the browser? Are you able to login to every account without issues?

  • If I manually copy and paste the password from the app to the browser it still doesn't work. (But if I open the webpage from the app it still does work). What do you mean am I able to login to every account without issues?

    I haven't tried uninstalling and reinstalling the Firefox Add on, should I try this?

    thanks

  • I just uninstalled and reinstalled the Addon and it still doesn't work.

  • I've just realised that I think this problem is coming from 1Password app not the Addon in Firefox. As I just uninstalled the Addon again so it's not in Firefox. Then I went to open the web page I want to go to and it prompts to autofill by 1Password. So this must be coming from the app. It still doesn't work though.

  • I've just uninstalled the 1Password app and reinstalled it. And have turned autofill on. The problem is still happening though. The version of 1Password is 7.1.5

  • Greetings @AngeP,

    So just before we delve into 1Password for Android and the options for filling I want to just say a brief word on 1Password X. 1Password X is a standalone extension, initially designed to bring support for 1Password to Linux and ChromeOS. I don't believe we've tested use of 1Password X on a mobile device so I couldn't comment as to what may work or if it will work at all. For mobile devices we do recommend use of the native client as we have both Android and iOS covered with both supporting features specific to that OS (Operating System).

    Now 1Password for Android supports two filling approaches which we refer to as Autofill and Accessibility in our app. Can I ask which (or both) are enabled please.

    I'm also attaching a screenshot of what you would see if you have 1Password and Autofill enabled and the screenshot is of Firefox for Android, just so we can tell if we're testing the same thing or if there is something else at play that we need to account for.

    Does this look like what you're seeing when things don't work as intended?

    I also wonder if you could share one or two sites that you've tested where you're experiencing this, ideally sites where we can easily create an account if needed to test. In my limited testing just now I found Autofill allowed me to successfully sign in so there's clearly an important piece of the puzzle we've yet to identify.

  • Hi, thanks for clarifying that. I use 1Password X for Firefox on my Linux machine and also my windows machine, so I think I've just had it installed on my phones because of that. I have uninstalled 1Password X Add On now on my phone.

    In Settings/Accessibility/Installed services: 1Password is "On"
    In Settings/General Management/Language and Input/Input assistance/Autofill service: "1Password" (so yes this is activated)

    Examples:

    From Firefox I go to chemistwarehouse.com.au, click on Menu/Login, tap in username field and it then displays "Autofill with 1Password", I then enter my master password and another 1Password message displays saying "Select the account that you want to use with chemistwarehouse.com.au and then it shows my Chemist Warehouse 1password record (similar to the icon and account you have shown in your image), I select it, then click "Sign In" and I get an error message (the error message is coming from chemistwarehouse as they think the problem is at their end) and it doesn't log me in.

    If I do exactly the same process for booking.com, when I click to sign in it just returns me to the booking.com home page without logging me in. (no error message this time.).

    The same happens for other logins I have tried, it looks like it is logging in but then just returns to the login page. My Siteground email account even gives a message saying "Login successful, redirecting" initially, but then it changes and just returns to the login page and I am not logged in.

    I have attached 2 photos in case it helps, of booking.com: the initial autofill prompt, and the home page it returns to without logging in.

    Note that this was all working when I installed it on my new s10 originally, then after about a week it stopped working. (And it's working fine still on my old s5).

  • Hi, thanks for clarifying that. I use 1Password X for Firefox on my Linux machine and also my windows machine, so I think I've just had it installed on my phones because of that. I have uninstalled 1Password X Add On now on my phone.

    In Settings/Accessibility/Installed services: 1Password is "On"
    In Settings/General Management/Language and Input/Input assistance/Autofill service: "1Password" (so yes this is activated)

    Examples:

    From Firefox I go to chemistwarehouse.com.au, click on Menu/Login, tap in username field and it then displays "Autofill with 1Password" as a popup which I click on, I then enter my master password and another 1Password message displays saying "Select the account that you want to use with chemistwarehouse.com.au and underneath is my Chemist Warehouse 1password record (similar to the icon and account you have shown in your image), I select it, then click "Sign In" and I get an error message (the error message is coming from chemistwarehouse as they think the problem is at their end) and it doesn't log me in.

    If I do exactly the same process for booking.com, when I click to sign in it just returns me to the booking.com home page without logging me in. (no error message this time.).

    The same happens for other logins I have tried, it looks like it is logging in but then just returns to the login page. My Siteground email account even gives a message saying "Login successful, redirecting" initially, but then it changes and just returns to the login page and I am not logged in.

    Note that this was all working when I installed it on my new s10 originally, then after about a week it stopped working. (And it's working fine still on my old s5).

    I tried to attach a screenprint but it says I can't upload files in this category. Not sure if that would help anyway.

    thanks

  • Hi @AngeP,

    Given your preferred browser is Firefox can you try the following for me please.

    1. In 1Password for Android disable the accessibility filling, leaving only Autofill enabled.
    2. Quit Firefox if running.
    3. Launch Firefox and attempt to sign into booking.com and let me know what happens.

    I've picked booking.com as a working example as it turns out I already had a test account. I've been able to sign in so at least in the simulator running Android things look okay. If we don't see consistency it may be somebody with a Samsung device may need to take over in case there is something very weird and device specific going on.

  • AngePAngeP
    edited July 17

    OK, so inside 1Password App I went to: Settings/Filling/Accessibility/Installed Services/1Password/ then select Off. Then quit/restarted Firefox, then retried booking.com and the same thing happened (looks like its processing and logging in but doesn't).

    And yes well spotted, Firefox is my preferred browser, it's the only one I use :)

    thanks.

  • Greetings @AngeP,

    One last question before I go hunting for somebody with a Samsung device, after trying to use Autofill on the booking.com site did:

    1. The fill menu look like the one in my screenshot where it displays the icon, title and username?
    2. After filling the email address field and moving to the next stage, was the password field already filled?

    Also, if you create an entirely new Login item for booking.com and copy over the username, password and set the website field to https://secure.booking.com/ so it's a match, does the new Login item also exhibit the same issue?

    It's odd, try as I might when I'm using Autofill I can't get it not to sign me in so I'm puzzled as to why it's misbehaving for you so badly at the moment.

    1. Yes but it also says "Select the account that you want to use with booking.com and then under that shows the icon, title and username. And also note that prior to this it first displays "Autofill with 1Password" (see above), which I click on.

    2. Yes it was already filled (and it looks like it logs in, it even says "Loading", but then it doesn't. Same with my Siteground account it even says login successful, but then returns back to the login screen without logging in.

    3. I created a new login and copied across the details with the secure link (which I created in 1Password X on my Linux machine and tested to ensure it works, then I synced 1password app on my phone). I then went into the 1Password app on my phone, opened this new login, clicked on the website field/link, and it opens a booking.com page but still keeps the secure address in the address bar, but gives a message saying "We couldn't find this page" which looks like it is a booking.com message. If I then click on the booking.com menu to login, it opens the email address field but doesn't fill or suggest to autofill. (But note this is still within the 1Password app and not in Firefox.) Now if I open Firefox and manually enter the secure webaddress, I get the same "We couldn't find this page" message, I go to the menu to login and it autofills properly, but does the same thing, booking.com says "Loading" and looks like it is logging in, but then it doesn't and I'm back at the booking.com page.

    I know, I don't know why either as it was working originally.

    thanks

  • I also found another problem while I've been using 1Password app and not Firefox to open my logins.

    When I log into my Siteground email account from within 1Password app, some buttons are not working. eg:

    1. I opened your email notifying me that you had responded, I then clicked on "Click here to reply" in the email, and it doesn't do anything ie it doesn't open the link.
    2. I create a new email message and click on the option to add an attachment. It then opens a pop up menu in the middle of the screen with the options/buttons "Add Attachment" and "Close". "Add Attachment" doesn't work (I press it and nothing happens), but "Close" does.

    I did have "Appear on top" allowed in the 1Password app, and I tried it with this on and off, but still doesn't work. (not sure if this is the option that is needed to get this working)

  • Hello @AngeP,

    Sorry for the delay in getting back to you.

    I don't know for certain but in the URL that loads the sign-in page I see a parameter being passed in the URL is a token. It is possible that the token has a shelf life and once expired it simply behaves as if the page doesn't exist when trying to load instead of something a bit friendlier such as saying expired session before redirecting you. When I suggested setting it to https://secure.booking.com/ it wouldn't be any use for open-and-fill but it would match the loaded page for filling.

    As for all the other woes, there is only one other thing I can think of to try right now. Staying with booking.com for the moment, I wonder if you could try changing your password using 1Password X and Firefox on your Linux machine and if your password previously contained symbols, limit the new password to alphanumerics. I'm just wondering if for some reason a combination of your current password and Firefox for Android doesn't work. Should that be the case? it really shouldn't but I'm kind of grasping at straws at the moment. That or do you have any form of content blocking on the Samsung device, something that might be interfering with Firefox?

    There is a service I use and what I found was a password that worked on their website wouldn't work on their Apple TV app. A password that worked on the website and Apple TV app wouldn't work on another of their iOS apps. It took a few attempts at dumbing down the password to find one that worked everywhere. I also recently discovered certain domains being blocked would cause the site to claim my credentials were incorrect but it turns out they were using a third party service for authentication so I needed to tweak by content blocker. That service drives me nuts but thankfully I haven't found another that comes close to that level of inconsistency.

    I will have to ask about the limitations you've found accessing your webmail in 1Password. It might be a permissions thing, I genuinely don't know.

  • Hi,

    I only just saw your response today, must have somehow missed a notification.

    Based on what you have said about content blocking etc, I set a very simple password, turned off 1Password autofill so I was just using Firefox and manually entering my password, and the problems still occurred. So I then went thru my content blocking options in Firefox which I have quite strict, and testing them to see which was affecting the logins, and sure enough it was having cookies disabled. So I now have 1Password working properly within Firefox with my logins - yay, and thank you so much for your help on this!

    Now.... the only problem I seem to have is what I mentioned above that when I login to my Siteground email account from inside the 1Password app (still on Android), some of the buttons (eg Add Attachment) do not work. Now that I can log in to Siteground from Firefox I tested these buttons and they do work from within Firefox.

    thanks!

  • periperi

    Team Member

    Hey @AngeP. Thanks for the update. I'm glad you were able to resolve your issue with filling in Firefox. As to the other issue you mentioned, are you referring to the built in 1Browser?

  • brentybrenty

    Team Member

    @AngeP: Also, sorry for notification trouble! Our forum provider was having some issues with email notifications recently. It should be resolved now, so hopefully you receive notifications for these comments here from myself and Peri. :)

  • Thanks, yes I did just get these notifications.

    1Browser is the browser that is inside the Android 1Password app isn't it, and if so, then yes the issue I am having is here (as it works fine from within Firefox). Thanks.

  • periperi

    Team Member

    @AngeP Thanks for clarifying. For now, I'd recommend using your default browser. While we do have the 1Browser available, we're not a browser developer, so the 1Browser won't be as feature rich as other browsers. For instance, pop ups can't be opened from 1Browser. Do these buttons, such as Add Attachment' open pop ups in Firefox? If so, that would explain why they don't react in the 1Browser.

  • ok thanks. Yes they will either open up an option to search a file to add as an attachment from my phone, or another one is clicking on the notification button in your emails "Click here to reply", which should open up this thread but doesn't do anything.

    I will continue to use Firefox, thanks for your help. Love 1Password btw :)

  • brentybrenty

    Team Member

    Ah, that's interesting. I haven't heard of that before. Thanks for letting us know! Glad that Peri's explanation helped. Thanks for the kind words. We're here if you need us. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file