1Password X Beta in Edge (Mac) can’t establish connection…

To piggyback off the previous post about the X Beta not being able to connect in chrome (https://discussions.agilebits.com/discussion/105694/1password-x-beta-fails-to-establish-connection-on-chrome)

Using the Edge Dev Beta and it can’t connect to the desktop version. I’ve updated the browser, have the latest version of 1PX Beta, and also running the Beta of the Desktop Application.

Browser is Edge for Mac Version 77.0.223.0


1Password Version: 1Password 7 Version 7.3.2.BETA-1 (70302001)
Extension Version: 1.16.6
OS Version: OSX 10.15
Sync Type: 1Password Teams

Comments

  • brentybrenty

    Team Member

    @ejschenck: Sorry for the confusion there. 1Password for Mac does not support Edge at all. It's likely it will in the future, once Microsoft completes it, but for now 1Password X can work there by itself, since it can run entirely in the browser. I hope this helps. Be sure to let me know if you have any other questions! :)

  • @brenty, sorry for resurrecting this again. Just wanted to make sure we are talking about the same story here. I guess it's clear, just to make it crystal-clear as MS simply sucks at naming things and always creates a looooot of confusion.

    Edge Beta Channel is the new Chromium based Edge version. Not related to the previous Edge versions based on Chakra.

    https://www.microsoftedgeinsider.com/en-us/

    So, it's based on Chromium and I can go to the Chrome store and install the 1P extension as I can do with Chrome.

    Could you elaborate a bit more on why "1Password for Mac does not support Edge at all" as other Chromium based browsers (e.g. Brave, Opera) are supported?

    Does it mean you have to create the extension for every Chromium browser from scratch, and Edge vNext is not supported yet because of it's beta status?

    Thanks for some more insight

  • kaitlynkaitlyn

    Team Member

    Hey @dawe! These are some really good questions.

    Could you elaborate a bit more on why "1Password for Mac does not support Edge at all" as other Chromium based browsers (e.g. Brave, Opera) are supported?

    Each Chromium browser has a different code signature that needs to be added to the 1Password desktop apps in order for the browser to be considered supported. What the OP was asking about is Desktop App Integration between 1Password X and 1Password for Mac. Since it requires communication with the desktop app, it won't work with Edge until the new code signature is added to 1Password for Mac. If you're wanting to use 1Password X in Edge by itself, then that's absolutely fine and that should work well for you. It isn't until the desktop app comes into play where we'd need to validate the code signature.

    Does it mean you have to create the extension for every Chromium browser from scratch, and Edge vNext is not supported yet because of it's beta status?

    The answer is the first question is no, we don't create a brand new extension for each Chromium browser. And yes, you're right about 1Password for Mac not supporting Chromium Edge quite yet since it's not complete. I'd expect us to add the code signature in the future once the stable version is released, but I don't have any specific dates to share.

    I hope this helps, but let us know if you have any other questions!

  • I'm also using Edge Beta/Dev/Canary for Mac and would love support with the desktop connection extension. Any time line on adding signatures for those browsers?

  • brentybrenty

    Team Member

    @Bryan Steger: It was added in 1Password for Mac version 7.3.3 beta:

    Added BETA-ONLY support for Microsoft Edge. {#4067}

    You just need to opt-in to betas. Cheers! :)

  • I am running 1passwordX 1.17.1.beta on Edge Version 78.0.276.14 (Official build) Beta (64-bit)
    and mac 1Password 7 Version 7.3.3.BETA-2 (70303002)
    and I am still getting the unable to establish connection message.

    Is this supposed to be working with the combination I have?

  • kaitlynkaitlyn

    Team Member

    Hey @jeffreyh! The setup itself does sound correct, but I'd have to dig deeper to understand why it's not working properly. To start, could you try following the steps that Brenty laid out in this comment?

  • Thanks. I did the following in the terminal and restarted Edge and things seem to work now.

    cp ~/Library/Application\ Support/Google/Chrome/NativeMessagingHosts/2bua8c4s2c.com.agilebits.1password.json ~/Library/Application\ Support/Microsoft\ Edge\ Beta/NativeMessagingHosts/

  • kaitlynkaitlyn

    Team Member

    @jeffreyh – Perfect! I'm glad to hear that did the trick. If you run into any issues down the road, don't hesitate to let us know. :)

  • i dont know if this its a bug but ... if yes ... thanks god for this bug, tis command works with Edge Canary

    cp ~/Library/Application\ Support/Google/Chrome/NativeMessagingHosts/2bua8c4s2c.com.agilebits.1password.json ~/Library/Application\ Support/Microsoft\ Edge\ Canary/NativeMessagingHosts/

  • kaitlynkaitlyn

    Team Member

    Interesting! Thanks for sharing, @weareartisans.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file