1Password7 for Mac not filling URL in Firefox Private Browsing

The browser extension for Firefox does not fill the URL and open a web site's login page when using private browsing. If I open a login page first, it is able to fill the name and password. This works properly in Firefox standard windows and in Safari using either standard or private browsing. This happens on two computers under both Sierra and Mojave.

How can I get this to work?

Thanks!


1Password Version: 7.3.1
Extension Version: 4.7.5.90
OS Version: 10.14.5
Sync Type: 1Password account

Comments

  • ag_anaag_ana

    Team Member

    Hi @GerryB! Welcome to the forum!

    I don't know if this is really related, but can you also confirm the exact version of Firefox that you are using so we can test it?

    Thank you!

  • Hi Ana,

    I'm currently running Firefox 68.0.1. However, this has been an issue over multiple versions of Firefox and MacOS, on two different computers. I also checked to be sure the browser extension has the necessary permissions in Firefox.

    Gerry

  • littlebobbytableslittlebobbytables

    Team Member
    edited August 2019

    Hi @GerryB,

    There is something odd going on, especially given things work if a page is loaded. The issue seems to be only present with an empty tab. I will file a report and see what we've missed here.

    ref: xplatform/filling-issues#649

  • Thanks!

  • ag_anaag_ana

    Team Member

    On behalf of littlebobbytables, you are welcome!

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • bytesizedbytesized
    edited August 2019

    I wanted to report that I recently updated to 1Password 7 on MacOS, and I am having this exact problem as well. It's extremely annoying.

    The feature does indeed seem to start working again if I load a page first.

  • BenBen AWS Team

    Team Member

    Thanks for the report @bytesized. We have an issue filed with our development team for further investigation.

    Ben

  • Hi! Has the "further investigation" succeeded?

    I am a loyal 1P 6 user and I am testing the 1P membership. But "upgrading" from 1P 6 to 7 in Firefox seems a very bad decision. The extension window used to appear instantaneously, now it tales up to 5 seconds to show up! And I am on a i7 power iMac. And I am having the private window problem too, which is terribly annoying.

    Also, the way the old extension showed the login items was more efficient (favorites are not shown now when the current tab is on a 1P known site, for instance). Plus, I think I only had to click once on each item and now I have to double click (I know... not a big thing... but multiplied hundreds of times daily by years of use... it really adds up!).

    Please help. Thanks!

  • Hey @Osplo! I don't have any updates to share at this time regarding the Firefox issue.

    Regarding the speed of 1Password mini generally speaking, the extension is doing some heavier analysis in this newer version, as it's looking for fields on a page to try to determine whether it should show a specific login, your credit cards, or your identities, so since there's a bit more going on, the slight speed reduction is normal. Five seconds sounds a bit excessive, though — are you noticing that long of delay regularly? On any particular websites? In any particular browsers?

    Finally, regarding the UI of 1Password mini, I'll take it back to the team, as we're always fine-tuning the UI/UX of 1Password. For the double-click issue, you can do a single-click on the AutoFill button, or you can press return/enter on your keyboard to cut the number of actions by half. :smile:

  • OsploOsplo
    edited October 2019

    Thanks for the reply.

  • As for your questions: sorry, I was not very clear. I made some additional checks for you.

    The 5 seconds delay appears only in Private mode. In normal mode, the delay is there but nothing serious. Also, in Private Mode there is no way to open a web site from the mini window by clicking, which is annoying. (BTW, this is the main problem that started this thread). It should be easy to reproduce and fix.

    I was referring to Firefox. I tried Chrome for you. There, there is no delay in Incognito nor normal mode. But the problem is worse regarding opening a site as there the site gets open when the "Go" button is clicked... but in the default browser (Firefox) and in normal mode...!

    Then I tried Safari. No delay, no problem opening sites from Mini in Private mode either.

    And then there's the fact that 1P is not acting as it was in Firefox normal mode, as mentioned earlier. Most of the time 1P shows me credit cards and identities when the current web site and the favorites (they are named favorites for a reason) should be shown. I tried to replicate the old behavior by changing preferences, but I couldn't.

    What's surprising is that Firefox was very well supported in 1P 6. And 1P7 is not new, so it should work like a charm, but it seems like a beta. Please help.

  • brentybrenty

    Team Member
    edited October 2019

    I primarily use Firefox here, and the only thing that I can reproduce is the topic of this discussion: the private browsing issue. We haven't found a way to work around this in Firefox. Otherwise 1Password works the same for me as with other browsers. So I can't agree that it is "easy to reproduce and fix", or with your "beta" comment. But we'll continue to investigate all of this. Thanks for sharing your findings.

  • Any updates? This worked before I updated to 1Password 7. It's quite annoying that not only did updating cause a regression in a feature that used to work, but that it continues to exist 5 months later.

  • ag_anaag_ana

    Team Member

    Not yet @bytesized, but we will continue investigating this.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file