Unable to add Safari Extension

glooftglooft Junior Member
edited August 7 in Mac

I just updated macOS latest update. Upon restart the Safari extension was gone. Going to the Safari>Safari Extensions takes you to the Mac App Store where the 1Password extension is unable to download. It just spins and spins...does not download. This has been going on for about 24 hours. Is there any other place to download this extension?


1Password Version: 7.3.2
Extension Version: Not Provided
OS Version: 10.4.6
Sync Type: Not Provided

ref:

Comments

  • glooftglooft Junior Member
    edited August 7

    Also, the 1Password browser extension page states the extension is "Included with 1Password 7". I have 1Password 7 but I don't have the Safari extension.

  • BenBen AWS Team

    Team Member

    Hi @glooft

    I'm sorry for the trouble with the Safari extension. I see you've also been speaking with @1Password on Twitter about this. To avoid duplicating efforts, for now, let's continue the conversation on Twitter. If that becomes cumbersome or we're not able to get the problem resolved there we can help here or by email. Thanks!

    Ben

  • What is the answer. I do not twit.

  • BenBen AWS Team

    Team Member

    @coronazona

    With 1Password 7 the Safari extension is not a separate download / installation (and attempting to do so may only worsen the situation). The extension is included with the 1Password 7 app. If you don't see it listed in Safari under Preferences > Extensions then please try the following:

    1. Make sure Safari and macOS are up to date
    2. Restart your Mac
    3. Reinstall 1Password 7 for Mac from our website (instructions below)

    If you need to reinstall...

    1. Open and then quit 1Password completely — ⌘⌥⌃Q (Command Option Control Q)
    2. Drag 1Password to the Trash, but DO NOT use a "cleaner" app to remove 1Password if you have one (MacKeeper, CleanMyMac, AppZapper, etc)
    3. Empty the Trash
    4. Restart your Mac
    5. Install 1Password from our website: Download for Mac
    6. Open 1Password
    7. Make sure the extension is shown and enabled in Safari under Preferences > Extensions (do not click "More Extensions")
    8. Verify that you're able to use the extension to fill logins

    Ben

  • I had the same problem, and Ben's solution just worked for me.

  • BenBen AWS Team

    Team Member

    Glad to hear it @JimmyTheSaint. Thanks for the update.

    Ben

  • Thanks for your continued support!
    I followed your directions and resolved the issue. :)

  • BenBen AWS Team

    Team Member

    I'm glad that helped, @coronazona. :)

    Ben

  • Thanks Ben, worked for me!

  • ag_anaag_ana

    Team Member

    On behalf of Ben, you are welcome @bigblackbear :)

    If you have any other questions, please feel free to reach out anytime.

    And Welcome to the forum!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file