Autolock disabled but system still times out and locks

I'm using Windows 7, 1Password ver 1.0.9.296, Internet Explorer 9.0.8112.16421, and Mozilla Firefox 13.0.1, all of which are the latest versions.

I am using 1Password on a home PC with windows 7 32 bit, at work with a PC with windows 7 64 bit, and on an iPhone, with version XXXXX.

What I am seeing, and cannot explain is that on my home PC, where I have disabled the autolock feature, I am still prompted to unlock the file, after I've pressed <CTRL> + "\" to trigger the autofill sequence. I am usually asked to select which record to use for the AutoFill, and then I'm asked for the master password.

If the autolock feature is disabled, then I'm quite surprised that I'm still prompted for the master password.

To be clear, I only set the auto-lock selection to disabled today, in order to try to provide you folks with details on what is happening, so that you can help me. After changing the setting from 60 minutes, to disabled, I was really surprised to see that the file is still locking.

This problem, where I'm asked to unlock the master file, even though the timeout is set to disabled, or to 60 seconds seems to occurr on both my work PC, and home PC, regardless of whether the attribute is disabled, or set as high as 60 minutes. No matter what I do, or how short of a period of time I wait after unlocking the file, I'm often asked to unlock it again.

Can you explain what might be causing this?

Comments

  • khadkhad Social Choreographer

    Team Member
    The browser extensions are unlocked separately from the main application unless "Enable Universal Unlock" is enabled in the extensions' Security settings.

    One thing to keep in mind is that you will always be prompted to enter your master password when you first use the extension after a reboot (presuming you have not already unlocked the main 1Password application and Universal Unlock is enabled).

    Let's focus on one browser at a time to try to narrow down the issue. You mentioned Firefox, so let's focus on that for a moment. Can you verify for me that Universal Unlock is enabled in the 1Password Firefox extension?

    20120713-82us351p4mi5pce612i4ghtfkk.png

    Can you also post a screenshot of your auto-lock settings from the Security tab in 1Password's preferences? Here is mine as an example:

    20120713-f123mm32y4fks4eeege5req243.png

    Thanks!
  • svondutchsvondutch

    Team Member
    cjmusante wrote:

    What I am seeing, and cannot explain is that on my home PC, where I have disabled the autolock feature, I am still prompted to unlock the file, after I've pressed <CTRL> + "\" to trigger the autofill sequence. I am usually asked to select which record to use for the AutoFill, and then I'm asked for the master password.


    I assume you're seeing this in IE, correct? Because our IE add-on is loaded into the IE address space (and unloaded when IE shuts down), it cannot "remember" your master password *unless* you enable this setting: File > Preferences (Ctrl+P) > IE > "keep 1Password extension unlocked when Internet Explorer is closed"
  • Yes, I've gone into Firefox and verified that Universal Lock is turned on/enabled for Firefox.
  • khadkhad Social Choreographer

    Team Member
    Thanks for the screenshots!

    Let's do a little test.

    1. Open Firefox.
    2. Unlock the 1Password extension in Firefox
    3. Quit Firefox.
    4. Open Firefox again.

    Do you need to enter your master password to unlock Firefox again when immediately closing and reopening Firefox like that?
  • OK

    I've gone into Firfox, opened/unlocked the 1Password extension in Firefox, then I quit firefox, and opened and closed it a few more times. I had not intended to open/close a few times, but had a difficult time finding a website that was fully operational. Anyway, the next time that I opened Firefox, it challenged me again, and I was forced to enter my credentials.

    Also, I would have responded to your email sooner, but the Agilebits forums are not notifying me when a new entry is made. I think I've successfully modified my profile so that I'm immediately notified, so my next response should be much faster. Sorry for the delay.
  • khadkhad Social Choreographer

    Team Member
    edited August 2012
    I'm sorry that you are still having trouble. To help us track down the issue more quickly, could you please send us your Diagnostics Report? Select Help > Diagnostics Report > Export to File from the menu bar in 1Password. Then attach the report to a private support ticket:

    http://support.agile.../discussion/new

    Please be sure to include a link to this thread so we can "connect the dots" when we see the report.

    Once we see your report we should be able to help more. Thanks in advance!
  • I"ve created a ticket, but I'm not sure how I can provide you details about that ticket.
  • khadkhad Social Choreographer

    Team Member
    No need to provide any more details here presuming you included a link in the ticket to this thread. We'll work with you via the support ticket to resolve things.

    Thanks!
This discussion has been closed.