iOS 7.3.5 update issues?

Hey guys ... Had a weird issue today. Saw there was a 1Password update available 7.3.5. Read all the notes and installed onto my iPhone. (iPhone 8 running iOS 12.4)
I then launched 1Password and it asked for my Master Password which I dutifully entered. Rejected. Tried again 3 or 4 more times in case I fat fingered it but the issue persisted. Huh ... force quit the app and attempted again and issue persists. Restarted iPhone and issue persists. Tried logging into my account at agilebits.com and password was accepted without issue. OK so the password itself is not the issue. Removed the app and re-downloaded. I was asked to choose from some options and was presented options to import from 1password.com, iCloud etc. I chose iCloud, a file was found and was asked to enter the password and it was rejected. Chose the option to use 1password.com and a vault was found and was asked to enter the password and it was accepted.
So it seems something had happened to the file in iCloud. All is working correctly at the moment but I'm concerned that the app is now writing data to a corrupt or damaged file in iCloud and I will have these same issues on the next update. Has anyone else reported this issue? Are my concerns valid or should I slink away and keep my thoughts to my self?


1Password Version: 7.3.5
Extension Version: Not Provided
OS Version: iOS 12.4
Sync Type: iCloud

Comments

  • ag_anaag_ana

    Team Member

    Hi @invadingrobots! Welcome to the forum!

    From what you wrote, it sounds like you have two separate 1Password vaults, one on 1Password.com and one on iCloud, with different Master Passwords. If you are currently syncing your data using 1Password.com, as per your post, you don't need to use iCloud anymore, as one of the benefits that come with a 1Password account is automatic sync so you don't need any third-party solution :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file