1Password 7 Firefox extension not working

baldibiekbaldibiek
edited August 13 in Mac

OSX 10.12.6
Firefox 68.0.1
1Password 7 installed, Firefox extension version 4.7.5.90

Video of behavior: https://send.firefox.com/download/2a8508f0d2a46983/#HGbsviBy4FSvO49E7uD04Q (expires in 7 days)

When I click the 1Password icon in the browser, the password entry form appears. Then the window disappears as soon as I start typing.

It seems to work properly if I bring up the desktop application and login there.


1Password Version: 7
Extension Version: 4.7.5.90
OS Version: 10.12.6
Sync Type: Not Provided
Referrer: forum-search:firefox 1password 7

Comments

  • Hi @baldibiek,

    I've got a couple of questions if that's okay.

    1. Does the 1Password mini unlock screen appear to stay visible on screen indefinitely if you don't type?
    2. If you unlock 1Password from the main 1Password window are you able to interact with 1Password mini normally i.e. use the search field, select an item to fill and have fields fill?
    3. With 1Password locked and a non-browser application active e.g. Mail, Thunderbird etc. Do you see the same odd behaviour with 1Password mini when trying to unlock here? You can access 1Password mini either via the macOS menu bar icon or the keyboard shortcut ⌥⌘\.
    4. What version of 1Password 7 do you have installed? You can find the exact version in the 1Password 7 > About 1Password menu option.

    I don't think I've seen this behaviour before so just trying to get a better sense of where the issue may lie.

    1. The 1Password mini form disappears after a few seconds, even without typing
    2. If 1Password desktop is unlocked, 1Password mini works normally
    3. I don't see 1Password mini in the macOS menu bar and the keyboard shortcut only works if 1Password desktop is running
    4. Running 1Password 7.3.2 (70302004)

    Thanks!

  • Greetings @baldibiek,

    Thank you. Based on these answers can you check a couple of settings for me please and if you find they aren't enabled can you enable them for me please and we'll see if there's any change in the behaviour.

    In 1Password's preferences navigate to the General tab. If it isn't enabled can you enable the option titled Show 1Password in the menu bar. Next switch to the Browsers tab and do the same for the option titled Always keep 1Password Extension Helper running.

    Any change or where both already enabled?

  • That seems to have fixed it. Thank you!

  • That's great news! Glad we could help solve that puzzle @baldibiek :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file