"Allow Windows Hello to unlock 1Password" option grayed out on Insider builds [under investigation]

critterscritters
edited August 28 in Windows

I have been running 1Password for Windows on Windows Insider (preview) builds for some time. With recent Windows Insider builds, the 1Password application no longer provides the option to allow Windows Hello to unlock the password database. See screenshot.

Windows Hello is otherwise working just fine on the system, including for logging in to the machine and as a FIDO2 authenticator in supported web browsers (such as Edge). This machine is a Surface Book, so I'm using the normal front-facing camera on the machine for Windows Hello. I also have a PIN configured as a backup.

Is this a known issue with 1Password and Windows Insider builds?


1Password Version: 7.3.684
Extension Version: Not Provided
OS Version: Win10 x64 18963
Sync Type: Not Provided

«1

Comments

  • bundtkatebundtkate

    Team Member

    Whether or not this option is available is up to Windows mostly, @critters. If Windows is saying Hello isn't available on your system, then it won't show up as option in 1Password. I asked around and no one on the team has seen issues with Insider, so best place to start is probably same as what we do on stable – disable Hello in Windows Settings, set it up again, reboot, see if you can enable Hello in 1Password after. Usually giving it a good kick in the rear will get everything back in gear. :+1: Let me know if this helps!

  • I have the same issue (1P 7.3.705, Windows Build 18963).

    It's clearly 1Password-specific, as Hello works elsewhere (windows sign in, as a github security key, etc).

  • GregGreg

    Team Member

    Hi @crisbennett,

    Thank you for chipping in! Have you tried disabling Windows Hello and enabling it again? Does the issue remain after that?

    Thanks! :+1:

    ++
    Greg

  • Hey @Greg,

    When you say disable Windows hello do you mean remove and re-add a fingerprint (ie. settings -> sign-in options -> Windows Hello Fingerprint -> Remove, then Add)?

    If that's what you mean, then yes I've tried that. Same deal with the new fingerprint.

    I wouldn't mind testing with further apps, but the only things I have (and know of) locally that use it other than 1Password are OS sign-in, & Chrome (which uses it for WebAuth 2 factor sign in to Github). They're both working as normal right now.

    I'm now on Insiders build 10.0.18965

    Cheers.

  • bundtkatebundtkate

    Team Member

    I was about to suggest something different, @crisbennett, but I just got some Windows updates yesterday and it looks like a total overhaul of that sign-in options screen was among those updates. Based on that new UI, I'd say you've done what you should. Any chance this is a corporate PC that might be subject to Group Policy restrictions? Has Hello ever worked to unlock 1Password on this PC?

  • edited August 22

    Hi @bundtkate - the PC in question is my personal laptop, with no custom group policies in place. I've been using hello (w/fingerprint) to unlock 1Password on it until recently. "Recently" is a bit of a weasel word here as I'm not sure exactly when it stopped working ;) I was busy when it happened so kind of ignored it for few days. Certainly the change has been in the last 2 weeks at worst. My guess is that it was triggered by one of the new Windows builds, but can't be sure of that.

    Given I'm running the Insiders build (on fast ring) I'm not complaining about a glitch with software here & there. But I guess you'll want to know about what may be coming.

    Happy to offer more info or try things if it will help.

    Edit - I did check on the Windows app store to see if I could find another app to test with, but couldn't find anything free or otherwise unintrusive. But hello (fingerprint) is working for my github login on chrome & msedge.

  • bundtkatebundtkate

    Team Member

    The trouble, @crisbennett, is that Edge and Chrome use what I'm fairly sure is the same API we do, but it's a different mechanism through WebAuthn than what we use. Arguably, 1Password's implementation could be simpler, but that doesn't necessarily mean something can't go wrong with it while WebAuthn is fine. I definitely think you're approaching the fast ring intelligently here – things break there more often and it certainly could be something we've not seen despite having folks on Insider. As a general rule, though, 1Password itself plays such a small role in how Hello works (or doesn't) that ye olde "turn it off and back on again" is about all we can suggest.

    Insider is useful for knowing what's coming, but fast ring is tough. It changes so quickly, it's hard to make any decisions based on behaviors seen there. A change might make it all the way to stable or may be totally scrapped in a matter of days. I'm definitely glad you passed this along and it's 💯worth monitoring, but I think you're on the right track here – fast ring tends to bring some glitches and it's tough to pin down the cause with so many changes so quick, nevermind life happening in general. Given you've already tried the best thing I'm aware of to get things fixed up, I think the best thing to do would be just to keep an eye on it and let us know if it doesn't fix itself after a time.

    Thanks again for passing this along (and for suffering the vagaries of early betas so others don't have to) and do let me know if you continue seeing this for an extended period. :+1:

  • Cheers @bundtkate - I'll keep an eye out on what happens as new Insiders builds roll in & report back at some point.

  • brentybrenty

    Team Member

    Sounds good! We will as well. :+1:

  • I'm seeing the same problem. I just got a new 7th gen ThinkPad X1. Out of the box, windows hello + 1Password worked. I am a developer and want to use the WSL2 stuff so I updated to windows insider builds. After that, windows hello works fine for the system but 1Password has the option grayed out. I have removed face and fingerprint to reset it and no change.

    Windows 10 Pro Insider Preview
    Version 1903
    Build 18965.1005

    I opened a feedback issue with Microsoft as well
    https://aka.ms/AA5xtw5

  • bundtkatebundtkate

    Team Member

    Thanks so much for the additional report, @ascarter, and particularly for the specific build info! I think the adventurous types on our team willing to use insider builds have all left the building for the day, but I'll check what builds we have got folks on tomorrow and see if perhaps this issue is rearing its head ahead of what we've got folks running.

    Also, out of curiosity, if you fully disable fingerprint, but continue to use face recognition, then reboot, do you still see this issue? Most reports I've seen have been from folks using fingerprint readers. This could easily be simply that fingerprint is a more common method, but since I don't have a fingerprint reader myself, I figure it's a good one to rule out before I consider spinning up a VM to test. Thanks!

  • @bundtkate I did the Windows Hello Face ID version by itself first and added the fingerprint later. It doesn't seem to matter on my laptop.

    Is there any sort of log or diagnostic that could be a hint? Happy to look for anything here that might be helpful.

  • brentybrenty

    Team Member

    @ascarter: Thank you for the offer, but unfortunately no. We don't have access to Windows Hello, and can only query the OS to find out if it is available. It's something we'll continue to investigate though, especially as Insider progresses. :)

  • I no longer get the finger print or windows hello option not after last Windows update. Win 10-Pro (Fast Ring) 190816-1722) Build#18965. I also am unable to toggle the Windows Hello toggle button in the desktop program. Windows Hello and Finger Print reader currently working as Sign-On for Win-10.

    Any ideas?

  • brentybrenty

    Team Member

    @tregroup: That is a known issue with Insider that we're investigating.

  • SystemSystem

    Team Member
    This discussion was created from comments split from: Fingerprint Option Not Always Showing in 1P.
  • Okay, thank you!

  • brentybrenty

    Team Member

    You're welcome! I'm sorry I don't have more information at this time, but we'll see if there's a workaround, or just something that can be addressed in a future Windows update.

  • Just to confirm that I've got the same problem with a slightly different build from @ascarter .

    1Password version: 7.3.684

    Windows version: Build 18970.rs_prerelease.190824-1711

  • brentybrenty

    Team Member

    Thanks for chiming in! Indeed, we've seen issues with this many recent Insider builds.

  • Microsoft engineer here (though, admittedly not on Windows). I've also been frustrated by this and have also filed a Windows bug (https://aka.ms/AA60bo3). If there's anything I can do to help get this resolved, let me know.

  • brentybrenty

    Team Member

    @corthon: Thanks very much! If you could shoot us an email at [email protected] we can discuss it more in depth and put our heads together to see what the best approach might be. :)

  • Hi

    I'm running Insiders 18975 190830 with 1Password 7.3.712; it's a personal machine so no domain or group policies applied.

    Windows Hello is greyed out as an option. I use PIN regularly to sign in on my desktop, and previously could use PIN to unlock 1Password. The issue also started for me a few weeks ago but unfortunately also not sure which build exactly.

    There's a new Insiders build out for the last few days that I'm planning to install on the weekend and will try that.

  • GregGreg

    Team Member

    @grahammcallister: We do not have any news to share at this point, but please let us know how it works on a new Insider build. Thank you! :+1:

    ++
    Greg

  • Hi @Greg I updated this morning to Windows 18980 190907-1301 and still have the same issue, Allow Windows Hello to unlock 1Password is still greyed out.

  • bundtkatebundtkate

    Team Member

    My understanding is that we've got some handle on which builds were giving folks trouble, @grahammcallister, and that it was probably a bit different per person since Microsoft does deliver different builds to different folks on insider in no small part to identify issues like this with changes made. Given that and what I've heard from other customers seeing this, I suspect you're seeing about what we'd expect at this point. I definitely do appreciate the build info though. I'll pass it along to folks working on tracking this down to help them get to the bottom of things. :+1:

  • Great news! Thank you

  • ascarterascarter
    edited September 14

    I'm still seeing it as well on:
    Build 18980.vb_release.190907-1301

  • bundtkatebundtkate

    Team Member

    Thanks, @ascarter! And apologies to everyone I'm not replying with any more detail to each of these. Because it's insider and changing a bunch, we're at a point where we're working on reproducing and ensuring it's going to stick around so lots of data gathering. I've made sure this thread is being tracked by our development team so that they'll see y'all's reports so don't mistake the short replies for lack of attention. We appreciate y'all and are keeping an eye out here. :+1:

  • Here's another data point: I'm seeing this on 18970.rs_prerelease.190824-1711

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file