I’ve put 1Password 4 on to a new Macbook

but it isn’t letting me just sign in as I do on my other Macs - it wants me to upgrade to version 7 but I can’t do that as my other Macs are on “vintage” OSX and won’t work with the newer version of 1P. I think I purchased it from the App Store years and years ago but I’m not sure.


1Password Version: 4
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:1Password 4

Comments

  • BenBen AWS Team

    Team Member

    Hi @PR1,

    It sounds like you may have run into a bit of a pickle. 1Password 4 for Mac is retired. It is no longer receiving updates. The last update to it was 5 years ago. Quite a lot has changed since then. It is highly unlikely that 1Password v4 is going to work in any meaningful way on any sort of modern Mac. If your other Macs are keeping you stuck in the past it may be time to consider upgrading them. We'd be happy to help in any way we can, but I don't think trying to run software that was last updated 5 years ago on a modern OS is going to be practical. Please let me know how you'd like to proceed.

    Ben

  • Thanks for getting back to me. I don't need an update to v4, I'm really quite happy with the way it works on my old Macs. (I haven't upgraded them to newer OSX because I'm afraid they'll get stuck on the upgrade and I'll be in an even bigger mess.) If there's just some way to get even the current password database on to the new machine and be able to access it from v4 that would be all I need, it doesn't have to update through syncing etc.

  • BenBen AWS Team

    Team Member

    @PR1

    It might help to better understand the setup here. Could you please answer each of these 4 questions for me?

    • What Macs are in play?
    • Which version of macOS is on each?
    • Which version of 1Password is currently on each?
    • Where is your 1Password data currently stored / how are you currently syncing?

    Ben

  • OK, so I have:

    1. Old iMac with 10.9.5, which currently has 1P v4 that was syncing from a local file through Dropbox (at least until Dropbox stopped supporting 10.9.5). This is the one I'm afraid to update the OSX on.
    2. Newer Macbook Air with 10.14.5 that I've transferred v4 to from the iMac but can't get to work. What I'd be happy with as a compromise would be to get v4 working on this one and then transfer the data file from the iMac. Most of the passwords don't change much and I can take care of the important ones manually if I do change those.

    Sorry to be a pain, I just need to keep the old iMac running for as long as I can (after which I'll get the newer 1P of course)!

    Thanks

  • brentybrenty

    Team Member

    @PR1: First and foremost, I'd encourage you to update your OS and browsers, not just for the convenience of compatibility with newer stuff (Dropbox not working there is one of many good examples), but primarily for security, as you're missing out on literally years of fixes otherwise. If you make a bootable full disk backup first, even if something goes wrong, you'd still be able to recover -- and literally boot into your old setup again in minutes, if necessary. I haven't had any issues with a macOS update for years (probably closer to a decade), but it's a precaution I always take because, well...I need to make sure I can get work done in the mean time if something does happen to go wrong. And I'm sure that Apple would be able to help either way. All Macs that can run Mavericks can upgrade to El Capitan (system requirements) — and many can upgrade to High Sierra. :)

    Getting back to 1Password, version 4 is not compatible with any recent versions of macOS. But versions 3 through 6 all support the AgileKeychain vault format, so if you've been using that (likely, if you were syncing with Dropbox), you should be able to open that vault on all your Macs, if they can run one of those versions. A license for 1Password for Mac version 4 will also work with version 6, and that should work a bit better on Mojave (though you will run into compatibility issues there too, especially with browsers) That should be viewed as a temporary option, but could help for a bit. :)

  • You're right, of course, I do need to update the OS for security (I think my browsers are OK though, they're all current; I'm not so concerned about 1P browser extensions). And I do have bootable copies on an external, it's just that sometimes when I try to reboot from the external it doesn't show up as one of the options! So it's a risk I've not been willing to take until I absolutely positively have to.

    As for 1P, are you saying I should transfer the current vault to the new Mac and just open it in the v4 that I have there? I tried that and nothing happened. And I tried doing a restore from a backup file that I copied over from the old Mac but again nothing happened. So maybe I'm out of luck there.

    You said that v6 might work - could you possibly send me a link to download that? Also, I can't locate my license number now - when I try on the old Mac it gives me a window saying "Trial Expired" and asking me to buy it! I bought it back in 2013, I can locate the email invoice if necessary.

    Thanks

  • brentybrenty

    Team Member

    @PR1: Please do check on the browsers. :+1: As far as I can recall, there aren't any that are still releasing updates on Mavericks.

    Regarding moving your data to the other Mac, can you be more specific? I'm not sure what wouldn't be working, but then again I don't know what's involved there without more details.

    1Password for Mac version 6 can be found at the bottom of our main download page, under "Using an older computer?":

    https://1password.com/downloads/

    But you would need to have a license for it from us for that to work. If you purchased it from the Mac App Store, you'd need to download it from your Apple ID purchase history there.

  • So v6 is working on the new Mac under Mojave - thanks! Now I just need the license number - I actually bought it directly from Agilebits and have the PayPal email with the payment info. I can forward that to you if you would like, or perhaps you can go by the Invoice number 4592144.

  • brentybrenty

    Team Member

    @PR1: Glad that helped! No recent versions of 1Password use a license number/key. You'd have been given a license file to download, which you could have saved in your 1Password vault or elsewhere for safe keeping. All you'd need to do is double-click that to register the app. If you need help with that though, please shoot us an email at [email protected] with the details so we can look into it, as we're not going to be able to do so here in a public forum. :)

  • Thanks, I'll try your sales people by email.

  • ag_anaag_ana

    Team Member

    Sounds good @PR1! :+1:

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and get back to you as soon as possible.

    Looking forward to your message!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file