iPhone show "never synced"

I've used my iPhone set up as WLAN sync, running the WLAN server on my desktop. I have run this way for years. Typically, when I have the phone at my desk (or anywhere in the house on the network), when I open 1PW and check the sync status, it says synced x seconds ago, where x<10. Now, just recently, I notice my phone is reporting "never synced". Yet, it does actually sync. I tested this by creating a new Login in the desktop app, and it showed up immediately on the phone. Then deleted the new Login, and it disappeared immediately. But if I click on "sync now", it does not change the status from "never synced".

I've tried toggling Wi-fi on the phone, disabling sync altogether on both the phone and desktop and reinstating them, but no joy. I guess I shouldn't worry since it is syncing, but it does not give me a lot of confidence when all it ever says is "never synced".


1Password Version: 7.3.2
Extension Version: 7.3.2
OS Version: macOS 10.14.6
Sync Type: WLAN

Comments

  • ag_anaag_ana

    Team Member

    Hi @HenryAZ!

    Is the "never synced" message showing in the Mac app or in the iOS app? I ask because you posted in the iOS section of the forum but you provided the 1Password version and OS version for the Mac app instead.

    Can you also please tell us what 1Password version and iOS version you are running on your phone, if you are indeed seeing the message there?

  • HenryAZHenryAZ
    edited August 2019

    I am seeing the message on my phone, version 7.3.6. On my desktop, I use a local vault. It is set up with WLAN server, and the syncing to the iPhone has never (before very recently) showed this "never synced" message before. I've been syncing the iPhone this way for years.

    Another question, how do I set up a notification for this thread so I get an email whenever a new message is posted, in this thread only?

  • HenryAZHenryAZ
    edited August 2019

    Here's a clue. I just fired up my iPod, for the first time in a while. It is an iPod Touch 6th generation, running iOS 12.4. It has 1Password on it also, but had an older version. It is also set for WLAN sync with the same desktop server. I tried syncing using the older version, and sure enough it updated the "Last Sync" to 1 second. Then I went to the App Store and updated my 1PW on the iPod to 7.3.6. Now the "Last Sync" status is not updating. It shows 5 minutes, which is when I synced with the older version. Seems to me there is an issue introduced with the "Last Sync" status with iOS version 7.3.6

  • JK1JK1 Junior Member

    Hi, I'm seeing the same thing, running 1Password 7.3.6 on iOS 12.4. 1Password shows Last Sync as 6 days ago, although the number of items has updated to reflect what is running on the Mac (1Password 7.3.1). It seems like something may have broke in the most recent update to the iOS version?

  • BenBen AWS Team

    Team Member
    edited August 2019

    Hi folks,

    To help us get an idea of what is happening here we'd like to see some diagnostic reports. On iOS enable Settings > Advanced > Diagnostics > Log Settings > Sync. Then please recreate the issue and generate the reports:

    Attach the diagnostics to an email message and change the email address it is being sent to:
    [email protected].

    Please also include:

    • A link to this thread: https://discussions.agilebits.com/discussion/106477/iphone-show-never-synced#latest
    • Your forum username
    • The time at which you tried to sync

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Ben

    P.S. @HenryAZ You can view and adjust your notification preferences here: https://discussions.agilebits.com/profile/preferences/

  • HenryAZHenryAZ
    edited August 2019

    Support ID number: [#EPI-48193-729]

    Regarding notifications, I have "Notify me when people comment on my discussions" checked to send an email. I am not receiving any emails.

  • BenBen AWS Team

    Team Member
    edited August 2019

    @HenryAZ

    Did you just recently enable that? Have you received an email for this comment? We are aware some folks are experiencing trouble receiving any emails from our forum provider. We've reached out to them about that and they are investigating.

    Ben

    ref: EPI-48193-729

  • ag_anaag_ana

    Team Member

    @HenryAZ:

    Did you receive this notification? We received an update from our forum provider that notifications should be working again now :)

  • HenryAZHenryAZ
    edited August 2019

    Yes, I did recently enable that, after I posted the first message in this thread. I still have not received any email notifications, including for the two most recent messages from ag_ana and Ben. They are showing up when I view My Account/Notifications, but no email notice.

  • Just now I received an email for ag_ana's post.

  • ag_anaag_ana

    Team Member

    That's great to hear! :) Thank you for letting us know :+1:

  • We're seeing the same issue as well with some of our clients.

  • BenBen AWS Team

    Team Member

    Hi folks,

    We've identified a bug in the updating of the display when using the WLAN Server to sync 1Password data. The sync does indeed complete successfully, but the UI doesn't update to show that. Our development team has been made aware and will be investigating further.

    Ben

    ref: apple-4158

  • Ben, thanks for the update. I'm glad your team reached the same conclusion, exactly as I outlined it in my first post. :)

  • BenBen AWS Team

    Team Member

    Thank you for all of your assistance in helping track it down. :+1:

    Ben

  • Has this issue been resolved? I'm seeing "Last Sync: Never synced." on my iphone 7 running ios 13.1.2 with 1Password version 7.4.3. I'm running 1Password 7.3.2 on my Mac Mini with Catalina 10.15.1.

  • BenBen AWS Team

    Team Member

    Not yet, sorry. It is on the radar but is of relatively low priority compared to some other irons in the fire. This is based on the fact that it doesn't affect the actual sync process (i.e. it is just a visual glitch).

    Ben

  • It is indeed a "visual glitch", but it is one that was not present before recent versions. Certainly some sort of programming bug was introduced, so it should be a simple process to undo that mistake. It is nice to have visual confirmation that your device has synced, rather than having to go look for something you had added to see if it is there.

  • brentybrenty

    Team Member

    "Simple" is very relative and subjective. As Ben mentioned, there are higher priority things we're working on at present. We'd rather take the time to make sure we don't introduce further issues for you when we fix this. ;)

  • Ben stated "We've identified a bug in the updating of the display when using the WLAN Server to sync 1Password data. The sync does indeed complete successfully, but the UI doesn't update to show that. Our development team has been made aware and will be investigating further."

    However, I have a different password on my computer than on my phone app for one of my logins, but they aren't syncing. I have an iPhone 10S IOS 13.3 running 1Password 6, my MacBook Pro OS is Mojave 10.14.6.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file