Accessibility for Autofill not staying activated

I've got a Family Account, running the latest app version (7.2) on my Huawei P20 Pro (running EMUI 9.1.0), and the autofill "accessibility" option keeps deactivating. I go back into permissions to activate it again, and the next time I open the app again it's deactivated again.
I've only recently noticed this, so I'm not sure if it coincides with the last app update or not.

Comments

  • periperi

    Team Member

    Hi @mikeslich. 1Password's accessibility service is constantly scanning your screen for login fields, and as such, can be pretty resource hungry. And as certain devices are aggressive at shutting down running processes to conserve resources, Accessibility can often be shut down in the background by your device.

    Huawei is one of the most aggressive OEMs when it comes to shutting down background processes, so that's most likely what's happening here. Try going to your device settings and tapping Battery > App launch. Set 1Password to “Manage manually” and make sure everything here is turned on. Hopefully that helps!

  • I've just tried that, and after several inexplicable failed attempts, it seems to be working now. However, when clearing all my open apps to optimize the phone, it resets again. It seems the only option is to stop clearing 1Password from my list of open apps.

  • periperi

    Team Member

    @mikeslich Thanks for the update. From what I understand, Huawei devices come with a built-in app killer called PowerGenie. Unfortunately, as far as I can tell, there's no way to whitelist any apps using PowerGenie, so the only option to stop it killing your background processes is to uninstall it.

    That said, if leaving 1Password running is working for you, that's great. Let us know if you need anything else.

  • Will do - thanks!

  • periperi

    Team Member

    :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file