No autofill prompt showing up for certain apps on Android phone

Greetings,

I'm a new user doing the trial and trying to follow the instructions. Not easy to so far. Of immediate concern, no autofill prompt is showing up when I open certain apps, namely Netflix and Spotify, on my Android (Samsung Galaxy A5) phone. Looks like I did allow for 1password for autofill and accessibility permissions, and I find the instructions on the web site minimal. Can you please advise re: the Android apps and more complete set-up information in general for my PC, phone, and iPad? Need to decide if I'm going to purchase this, not great so far. Thank you kindly.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:New user, no autofill prompt showing up for Netflix and Spotify apps on Android phone

Comments

  • periperi

    Team Member

    Hi @Glis. :) With the Spotify app, try pressing your finger in the login field and then tapping Autofill from the context menu that pops up. You should be able to fill that way.

    As to Netflix, I'm being prompted to fill here as expected. Can you try disabling Autofill in 1Password's settings and then filling? Are you able to fill with Accessibility?

  • Hey @peri :)
    In our case, we happened to upgrade to v7.3 for Android (from a previous v7.x) and the autofill stopped showing up for good.
    Everywhere.
    We tried uninstalling and reinstalling the app (on said phone running Android version 7) to no avail -while the autofill switch stays greyed-out with a notice reading "requires Android 8 or later". The accessibility switch is active tho.

    What would you suggest for getting out of this situation?

  • periperi

    Team Member

    @CrowdedTent Autofill requires Android 8 or later. While you can indeed use Accessibility with Android 7 and earlier, you won't be able to use Autofill on this device without updating to Android 8.

  • Sure @peri thank you for your response.
    Given that said phone will stay on Android version 7, what would cause the lesser functionality?
    We do not care about autofill at this stage as it not supported. We do care about functionality that we had and somehow is lost though.
    Any thoughts?

  • periperi

    Team Member
    edited September 12

    Hi @CrowdedTent. The Autofill framework was first supported in Android 8, which is why that's required. To be clear, this is across the board on Android, and not our own limitation. Android 7 does not have support for Android's Autofill framework, so it won't work there.

    I'm not sure what you mean about the functionality being lost, though, as this has always been the case. However, Accessibility filling works very similarly to Autofill, so by enabling and using that, most people would not notice the difference. If you had been able to fill on this Android 7 device in the past, then you would have been using Accessibility.

    As you mentioned that you have Accessibility enabled, you should be able to fill into most apps and browsers with that.

  • Exactly my point ...accessibility remains enabled after the "upgrade" to 1password for android v7.3 while the pop-up (not sure on how to call it) stopped showing up :/
    Any thoughts?

  • periperi

    Team Member

    Can you let me know what browser and/or apps you've tried filling in, @CrowdedTent? Also, what's the make and model of your device?

  • Xiaomi redmi note 4, running Android v7.0 & tried running it on Chrome, Firefox Focus, and Brave browsers @peri

  • emet09emet09 Junior Member
    edited September 14

    so I've been having the same issue, before updating to 1password 7.3 on chrome with accessibility turned on, there was no pop up of the option to fill with 1password like the second image
    I tried updating to the beta but no luck
    I also tried the 1password keyboard option but that has the issue of not being able to detect the page from the browser

  • periperi

    Team Member

    @CrowdedTent Try setting your power management settings on the device following these steps:
    1. Go to your device settings > Advanced Settings > Battery manager and set 'Power Plan' to 'Performance'
    2. Go to Advanced Settings > Battery Manager > Protected apps and make sure 1Password is protected
    3. Go to Apps > 1Password > Battery > Power and enable 'Intensive prompt' and 'Keep running after screen off'
    4. Go to Additional Settings > Battery & Performance > Manage apps’ battery usage and switch Power Saving Modes to Off, then set the next options: Saving Power in The Background > Choose apps > 1Password > Background Settings > No restrictions

    @emet09 It looks like Chrome is being detected as an app for you, rather than a browser. Can you try rebooting your device? If you continue having trouble, please let us know the make and model of your device, as well as what version of Android you're using.

  • emet09emet09 Junior Member

    ok thanks, for the advice, so I did the reboot and I'm getting the pop-up for other sites but still no luck with the Scotiabank one

    https://www2.online.scotiabank.com/onlineV1/leap/mobile/signon/mobileSignOn.xhtml?country=TTO&lang=en&channel=MOB

  • @peri OK thanks, but FYI the 1password v7.3 continues to behave erratically.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file