Choosing password via password type input field doesn't work anymore

There has been a bug since version 1.16.0 (Mac / Chrome): when you right-click a password type input field and choose "Show 1Password", the blue/gray icon appears but clicking it doesn't do anything. Previously in this point, you could choose the appropriate password.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @foo: Something does seem to be broken there. But to clarify, what do you mean by "the blue/gray icon appears but clicking it doesn't do anything"? Also, are you not seeing the 1Password icon in the field in the first place? It might help to know the OS and browser versions you're using, and the URL. Thanks in advance!

  • The URL is https://online.s-pankki.fi/ebank/auth/initLogin.do?language=1.

    The icon is not there in the first place (I guess because the form contains only one field, which is of type password?).

    macOS 10.14.6
    Chrome 76.0.3809.132 (Official Build) (64-bit)

  • brentybrenty

    Team Member

    @foo: Thanks for clarifying! Indeed, while that is a "password" field, it is not part of a login form, but rather a "list" for some reason, so 1Password has no idea that it's used for a login process of some kind. I'm seeing a number of other issues, from saving to filling, on the "TUNNUSLUKUTAULUKOLLA" portion as well. It isn't possible for 1Password to fill correctly there at present, but we'll see if there's something we can do to get it working with this page without causing issues with others. Thank you for bringing it up! :)

    ref: xplatform/xplatform#53, xplatform/filling-issues#679

  • Yes, and also it's a client id what is entered to the field and not a password in the first place. But anyway the filling worked fine prior to version 1.6.0. Or who knows, maybe they changed / broke the form on page at the same time.

    When it stopped working, I realised that I can insert the password just as easily via the same icon in the browser toolbar. So this isn't really a big issue.

  • kaitlynkaitlyn

    Team Member

    @foo – That is very coincidental, but I don't believe we made any changes to our filling algorithm recently. Either way, I see that Brenty filed an issue for this, so we'll look into it. In the meantime, it sounds like you figured out that you have the ability to fill from the 1Password X pop-up. I was able to get the password field filling once I tried it that way. I hope that helps for now!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file