Is there a way to disable 1password extension for a certain page

edited September 2019 in Mac

Our product has a page allow users to enter secrets

The problem we have right now is when user hits Add Property, the 1password extension then pops up trying to save logins since the name of the properties key contains password and Key at the same time. Which stopped our click handler from being triggered then blocking users who has 1password extension to add a new property. If I changed DOCKER_PASSWORD to DOCKER_PASSWOR or API_KEY to API_KE then 1password extension won't popup.

I wonder if there's a way like a global variable or something that we could use in our product to disable 1 password extension's auto save login feature only this page.

Any help is appreciated.


1Password Version: 7.3.2
Extension Version: 4.7.5.90
OS Version: 10.14.6
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member

    Hi @jiangsid87

    We don't have a per-page feature that would do this, but it can be done on a per-domain basis (e.g. yourcompany.com):

    1Password > Preferences > Browsers

    This can also be done from the auto-save popup:

    I hope that helps. Should you have any other questions or concerns, please feel free to ask.

    Ben

  • Not sure if you aware, but annoying thing is, sometimes, the 1password extension dialog just won't pup up(usually I have to restart computer to fix it), but the your code still runs and blocks.

    I wonder if your code runs by listening on window.onClick event? is there any hack(not asking for a feature) we could use? Suggesting customers what to do in above described case could also be very hard.

  • BenBen AWS Team

    Team Member

    @jiangsid87

    In speaking with our extension folks they suggested that setting the autocomplete property on these fields to off may help? We have further documentation that may be of assistance here:

    Design your website to work best with 1Password

    Please let me know if that helps. If not I can prod them further.

    Ben

  • BenBen AWS Team

    Team Member

    Please disregard the above post. It seems 1Password does not look at autocomplete being off when determining if the autosave prompt should show. I've asked our extension team to take a closer look at this and see if there is anything that can be done.

    Ben

  • Thank you very much, I think our entire company uses 1password enterprise, so this thing might potentially block many of our internal users, looking forward for your help.

  • Hi Ben, Is there any response from the extension squad?

  • BenBen AWS Team

    Team Member

    @jiangsid87

    Nothing yet. They'll likely reply here directly with further when more info is available. Sorry for the delay.

    Ben

  • Hi Ben, it seems like no one replies here? May be I should contact you guys through a formal channel (since we are using the enterprise version) to draw more attention?

  • Corey_CCorey_C

    Team Member

    @jiangsid87 We most certainly try to respond here, but if you wish to contact our email support, you are fully welcome to. Although it seems like this is just a matter of waiting for an update from the extensions team.

  • brentybrenty

    Team Member

    @jiangsid87: I'd encourage you to reach out to [email protected] though, as it may help to exchange more details than would be appropriate here in a public forum. :)

This discussion has been closed.