1Password 6 in Safari

BenBen AWS Team

Team Member
edited September 4 in Mac

Summary

Apple's Safari Extensions Gallery has now been retired and the extensions that were hosted there are no longer available. This means that 1Password 6 customers will no longer be able to install the 1Password extension in Safari. This change does not affect 1Password 7 customers.

Background

In June of 2018 Apple announced that the Safari Extension Gallery would be discontinued, as Safari 12 and later use the newer Safari App Extensions built into apps themselves. As of September 3, 2019 the galley has closed. In preparation for this change, and the upcoming Safari 13, we published a blog post:

Safari 13 is awesome, but 1Password 6 users need to upgrade to enjoy it

Moving forward, the use of 1Password with Safari will require 1Password 7, which fully supports the latest Safari and macOS releases. Alternatively, it is possible to continue to use 1Password 6, with a different browser. Our recommendation would be keeping all of your software up to date, but of particular importance is macOS, your web browser of choice, and 1Password.

We've been asked if it would be possible for us to provide the extension such that it could be installed regardless of the Safari Extension Gallery's status. Since Safari 12 does not allow .safariextz extensions to be installed from anywhere except the gallery, and Safari 13 does not allow such extensions to be installed from any source, if we were to provide the extension files, they could not be installed. As such this will not be a feasible solution.

For more info on the status of 1Password 6 please see this thread: 1Password 6 legacy support information. If you have any questions not addressed here please feel free to start a thread in our 1Password 3 – 6 for Mac legacy category.

This discussion has been closed.