"menu.accountType.user_string" shown under the bank account entity type

Hi all,
as described in the discussion title, I see that string under the bank account entity type. I'm using the last beta published on TestFlight (7.3.7.BETA-4), the one listed here: https://app-updates.agilebits.com/product_history/OPI4#v70307004.

For same entity of my vault, on other (macOS/Android/Windows) app, all is ok.


1Password Version: 7.3.7 (70307004)
Extension Version: Not Provided
OS Version: iOS 12.4.1 (16G102) - no jailbreak
Sync Type: Not Provided

Comments

  • Maybe @rudy can help me this time too, as last time for a similar issue in a past build (https://discussions.agilebits.com/discussion/comment/513523/#Comment_513523)

  • brentybrenty

    Team Member

    @wizard86pz: That's an odd one. Are you using a standalone/local vault or a 1Password account?

  • 1password account @brenty

  • brentybrenty

    Team Member

    @wizard86pz: Is your 1Password account profile set to Italian? We're actually having trouble even finding that string, so I want to make sure we're not looking for the wrong thing.

  • Yes @brenty, it is set to Italian language. The string name has been set by me: Conto deposito. The string refers to bank account type, for an entity of my cloud vault, that is a bank account type.

  • In my scenario, I see menu.accountType.Conto deposito as shown in my first post here (https://us.v-cdn.net/5020219/uploads/editor/vz/1k72tbt6gb2d.jpg).

  • brentybrenty

    Team Member

    @wizard86pz: Thanks! That helps a bit. Can you give me some context for the screenshot though? A full screenshot would help. Just be sure to remove any sensitive information before posting, as this is a public forum.

  • @brenty here two screenshots for a quick comparison.

    Screenshot from macOS beta app, with NO issue:

    Screenshot from iOS beta app, with issue:

    Here a little hint that can help you to understand and found the cause: this is happening only when I type a custom string for the "type" of bank account entity. I can type what I prefer, but this only from windows app (7.3.705.BETA). Windows, macOS and Android app of 1Password seem to manage and show properly only the string I've customized (Conto deposito)...but iOS app show the right string but in a not perfect way, probably not in the designed one: menu.accountType.Conto deposito

  • brentybrenty

    Team Member

    @wizard86pz: That's really helpful! Thank you! One last question, and then I think we should be able to reproduce this and narrow down the cause to find a solution: Did you originally edit the item to add the "Conto deposito" field on Windows, or somewhere else?

  • I'm not 100% sure, but I'm confident that I've done it from Windows, yes.

  • brentybrenty

    Team Member

    @wizard86pz: Thanks! That was it. I was able to reproduce this. I think it's two problems: you've set a custom "type" for a field that is designed to support only presets (so selecting one from the dropdown list instead should resolve the issue for you), and 1Password for Windows has a bug that allowed you to do that in the first place. Thanks for bringing this to our attention! :)

    ref: apple-4196, opw/opw#4160

  • Happy to have helped.

  • brentybrenty

    Team Member

    Seriously, it would have taken me way too long to find my way there without your helpful hints. You rock! :lol:

  • BTW, no any plan to allow those custom string, editable by user? I'd like to transform the Windows bug in a feature, you know devs like that sometimes :) And to start to hope for a support of custom strings in iOS.

    I see that every other app of 1Password has that support for custom string, except the last iOS beta app, actually.

  • brentybrenty

    Team Member

    Not at present, no. Those templates are set and built into all 7 client apps, and previous versions as well. If and when we redo items/categories, that's something we can consider. But it's not going to be in the short term, and would need to be updated everywhere to work reliably.

  • I understand.

  • brentybrenty

    Team Member

    To be clear, I think a lot of this would be great to rework; there are just so many other things we need/want to do. It's definitely worth reevaluating things like what is/isn't customizable when the time comes though. Cheers! :)

  • It's OK. I understand that there is a list of priorities to respect 😉

  • brentybrenty

    Team Member

    Thanks. I wish there were more hours in a day though. :lol:

  • I'm not sure if it has been forgotten, but this has NOT been fixed in beta 7.3.7 (70307005).

  • brentybrenty

    Team Member

    @wizard86pz: I'm sorry for not being clearer. The bug is that it was possible for you to change what's supposed to be a static value in 1Password for Windows at all. We need to fix that there; and you'll need to select one of the values from the menu instead: it's not meant to support custom values, and you could lose any data you enter into that field at any time if and when we update that field.

  • Sorry @brenty. You were super clear...it's me that has forgotten that the issue was on Windows app. Thanks.

  • brentybrenty

    Team Member
    edited September 18

    Ah...well, I found this situation confusing too, so I figured it was me. I do hope we'll be able to offer more flexibility in the future, but only if it's working as designed so we don't have to worry about anything going wrong. Thanks for understanding. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file