1password ignoring auto-lock setting

1Password X v1.17.1 is set to "Integrate with 1Password for Mac". Auto-lock settings for 1Password for Mac v7.3.3.BETA-2 are all unticked. However, it is frequently locking despite browser running and sleep disabled. I have tried reinstalling extension and ticking various auto-lock settings, then unticking them again.


1Password Version: 7.3.3.BETA-2
Extension Version: 1.17.1
OS Version: 10.14.6
Sync Type: Cloud
Referrer: forum-search:auto-lock

Comments

  • kaitlynkaitlyn

    Team Member

    Hi there @posix! Thanks for bringing this up. We've currently got an open issue in regards to 1Password X's auto-lock settings not being ignored when Desktop App Integration is enabled. My guess is that 1Password X's auto-lock settings are set to the default, which is Lock after computer is idle for 10 minutes and Lock when device goes to sleep. You should be able to tell that by gathering your 1Password X log after it locks on you, which you can learn how to do here.

    If you want to take a bet on it, you can go to the 1Password X Settings page (1Password icon in browser toolbar > gear icon > Settings), temporarily disable "Integrate with 1Password desktop app," and tweak your 1Password X auto-lock settings to something that fits your preference. After that, re-enable "Integrate with 1Password desktop app" and those settings should be respected.

    I'm sorry for the extra trouble now, but it's on our radar, so we'll be improving the experience soon. :)

    ref: x/b5x#1221

  • That has sorted it. Thank you! :-)

  • kaitlynkaitlyn

    Team Member

    I'm glad to hear that, @posix! I hope you have a great rest of your week. ❤️

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file