Fingerprint not working on OnePlus 7 Pro (Android 10)

I am using 1Password 7.3 (stable). I also tested it with the Beta, but the same problem is occuring.
On my OnePlus 7 Pro I'm using the OxygenOS Android 10 Beta 2 and I've never ran into any problems with 1Password until now.
I deactivated Fingerprint in 1Password and when I tried to enable it again, I get the following error:

java.security.ProviderException: Keystore operation failed

I've already read every post on the forum accounting this problem and tried everything mentioned:
Removing fingerprints, restart device, re-enroll fingerprints, restart device: didn't work
Reinstalling the app, repeating the fingerprint steps above: didn't work
I also tried installing the beta, repeating the fingerprint steps above, but it also couldn't solve the problem, I am still getting the same error message. PIN Unlock works just fine, but I miss the convenient way of unlocking 1Password with my fingerprint.

I couldn't figure out if it is a problem of Android 10 or the 1Password version I am using.
It could be a problem of the optical fingerprint sensor of my OnePlus 7 Pro, but I hope this can be solved soon.
Thanks in advance for any help!


1Password Version: 7.3
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:oneplus 7 pro fingerprint

Comments

  • I'm having the same exact issue. I tried removing all fingerprints, rebooting and readding them but I get the same error still

  • andiAGandiAG

    Team Member

    Hi @madotha and @ohjk I'm sorry to hear about the trouble that you're having with Fingerprint Unlock here.

    It sounds like it would be a good idea for us to take a look at a diagnostics report for your devices to see if they provide more answers. To do this follow the instructions linked below:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/107570/fingerprint-not-working-on-oneplus-7-pro-android-10
    • Your forum username: @madotha / @ohjk

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly.

    Once I see the diagnostics I'll be able to better assist you.

    Cheers :)

  • Hi @andiAG
    Thanks a lot for your help, regarding this issue!
    I've sent the diagnostics report to said email and I'm glad you're looking into this.
    So far, I haven't received a Support ID number (after 2 hours), but I'll post it on here as soon as I get it.

  • andiAGandiAG

    Team Member

    No worries @madotha I've found your message, I'll respond to you there :)

  • Im having this issue as well my fingerprint just wont register how to fix this please help

  • periperi

    Team Member

    Hi @sardar98. Are you also using a OnePlus device? What version of Android are you using, and are you seeing any error messages when trying to enable Fingerprint Unlock?

  • Hi, I have the same problem since i restarted my OnePlus 7 Pro running on 10.0.1.GN21BA.
    I get the same error message when trying to activate biometric unlock.
    java.security.ProviderException: Keystore operation failed

    Also tried reinstalling, reimprinting and all the other things....

    Help is really appreciated.

  • periperi

    Team Member

    Unfortunately, there seem to be a few people having trouble with biometric unlock on the OnePlus 7 Pro, @bokoffzki. I'd like to ask you to create a diagnostics report from your Android device:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/107570/fingerprint-not-working-on-oneplus-7-pro
    • Your forum username: bokoffzki

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!

  • edited November 2019

    Wat worked for me, is to not only remove your fingerprints, but also remove the device security (pin, password, pattern etc.). This resets some of Androids security settings. When enabling after this again, fingerprint worked again

    Edit: to clarify: this seems to be an oneplus/oxygenOS bug, nog an 1password one

  • brentybrenty

    Team Member

    Ah, thank you for the additional details! I'm glad that helped. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file