1Password Chrome Plugin can not properly fill forms on my Mac

It begin months ago and I finally have some time to write about it.
1Password Chrome Plugin sometimes failed to fill in the form on the page ( 4-5 times a day ), instead, when I double click on the item to fill, it jumps to the 1Password Mini for some reason.


1Password Version: 7.3.2 (70302004)
Extension Version: 4.7.5.90
OS Version: macOS mojave 10.14.6 (18G95)
Sync Type: Not Provided

«13

Comments

  • ag_anaag_ana

    Team Member

    Hi @richardevs!

    What version of Chrome is this happening with?

  • @ag_ana Hi! Current Chrome version is 77.0.3865.90. For the record it has been happening for a while and I kept my Chrome up to date.

  • brentybrenty

    Team Member

    @richardevs: What happens if you use the keyboard shortcut -- ⌘ \ -- to fill?

  • @brenty ⌘ \ works like a charm, no autofill failure yet.

  • brentybrenty

    Team Member

    @richardevs: Thanks for letting me know! I'm glad that works for you, but we'll see if we can figure out what's going on with Chrome. We've had a few similar reports, so it may be something with an update there. :+1:

  • ZortriumZortrium Junior Member

    I posted about this in another topic a week or so ago, but this continues to plague me daily. Chrome autofill fails many times a day, both when activated by keyboard shortcut and by clicking. Sometimes I have to try 5+ times to get it to work.

    Since I see this behavior across all my machines, maybe it's possibly related to my specific chrome extensions installed? Eg tampermonkey?

  • YaronYaron

    Team Member
    edited October 2019

    Hey @Zortrium ,
    This might be a sort of bug we're currently tracking internally and it affects other browsers, not just Chrome. It does not seem to be related to a certain extension or settings. Hopefully a fix will be issued soon.

    If you are unable to autofill on the 2nd/3rd try, I suggest you bypass that bug and fill the login credentials by dragging and dropping them with your mouse from the 1Password window into the website's login fields. That seems to work well for now.
    Another suggestion, if you have an active membership account, is to give 1Password X a try, which is not affected by this issue: https://support.1password.com/getting-started-1password-x/

  • edited October 2019

    @brenty
    A bit extra information, when there are multiple items to fill, then I have to choose one from them and press enter, ⌘ \ will fail in this case.
    ⌘ \ only works perfectly when there is only one item for the site, and no other action is required.

    @Yaron

    by dragging and dropping them with your mouse from the 1Password window into the website's login fields

    I don't know if I'm doing things wrong, but this only drags a "onepassword7://open_and_fill/" link to the login fields.

    Nvm, I figure it out by looking at the 1Password X features page.

  • YaronYaron

    Team Member

    @richardevs Thanks for the additional info! We've also seen similar behavior and it is more likely to happen if you have more than one login for a certain website.

    Glad you were able to use the drag and drop method, it works both in the companion extension and 1Password X, so it should provide a viable alternative for now to avoid trying to autofill several times until it works. Thanks again for the info.

  • Just to say I'm also having this issue, and yes I seem to particularly notice it when there's more than one login for the website. Good to know about drag & drop :)

  • First of all I want to say that I'm using 1Password since 6 years now. It's an awesome tool but sometimes after an update of 1Password I'm facing very annoying issues. None of these issues were annoying enough to register here but the current one destroys the user experience of 1Password completely.

    I think it describes it best with the following gif:

    As you can see, a double click doesn't open the desired site and fills the credentials.

    I tried re-installing the chrome extension multiple times. I also tried to restart my computer or just 1Password. Nothing works and the bug seems to be random because sometimes it works as expected. I'm facing this issue since a while but it became a way worse after updating to Catalina. This way it's almost impossible to use the browser extension.

    Please fix this issue. I'm using 1Password across different companies and private.


    1Password Version: 7.3.2
    Extension Version: 4.7.5.90
    OS Version: OS X 10.15
    Sync Type: Any

  • Hey @larister I'm sorry you're running into this issue as well. I hope we can fix this quite soon. 💜

    @steefaan, I likewise am sorry you're running into this. Just a heads-up that I've merged your thread into this one, as you're exhibiting the same issue described here.

  • @ag_michaelc actually it isn't the same bug because I faced the bug described by @richardevs as well. Usually 1Password redirects you to the page of the credentials you double-click on but it doesn't work anymore. In my case ⌘ \ is't working at all.

  • YaronYaron

    Team Member

    Thanks for the additional information Steefaan. Does pressing ⌘ + \ bring up the 1Password window, or does it not do anything at all? Perhaps there is a problem with the keyboard shortcut, or maybe you have a different shortcut set up in 1Password all together?

  • @Yaron Nothing happens if I use ⌘ + \. For me it's ⌘ + # because I'm using a German keyboard but I checked it before in the 1Password settings. Actually I tried everything because I'm using 1Password heavily. Using 1Password X is also not an option because I'm using a combination of a self-hosted vault and for my company the Teams version. If I use 1Password X I cannot access the self-hosted vault longer.

    Please try to fix this issue as soon as possible because the handling of passwords became so bad that the whole idea of easily accessing passwords broken. 1Password was by far the best password manager but with the current bug it's just another tool between many and doesn't worth the price for 40 users anymore.

  • YaronYaron

    Team Member
    edited November 2019

    Thanks for the additional info @steefaan .
    Can you please send us a diagnostics report from your computer to [email protected]?
    Here's how to create such a report: https://support.1password.com/diagnostics/

    Once we have that we will be able to investigate why doesn't the shortcut key activate the extension.

  • steefaansteefaan
    edited October 2019

    @Yaron Just sent the diagnostics report.

  • YaronYaron

    Team Member

    Thanks @steefaan ,
    Someone will check it out and will get back to you soon :)

  • Still very annoying bug after 1 month... :'(

  • YaronYaron

    Team Member

    @richardevs Indeed, no fix yet unfortunately.
    Doesn't 1Password X work well for you?

  • @Yaron Have not made my switch to 1Password X since it would be some changes... Looks like i have no choice but to move to 1Pass X for now.

  • brentybrenty

    Team Member

    @richardevs: Probably not as much change as you expect. If you'd like help with that, please shoot me an email at [email protected] so I can assist. :)

  • @brenty @Yaron actually... I found out that it does not support TouchID... which is kinda awkward... Since I have to enter my very long master password every time I come back to my mac...

  • brentybrenty

    Team Member

    @richardevs: Desktop app integration is available in the beta, which leverages 1Password for Mac to use OS-level features like Touch ID. ;)

  • @brenty: It keeps shouting =>

    🌈 Sending message to native app
    💥 Failed to send because our port was disconnected. Browser code signature became invalid?

    And cannot do the desktop integration trick... sad

  • ag_anaag_ana

    Team Member

    @richardevs:

    This sometimes happens when Chrome is in the middle of an update, or when the Chrome installation has been damaged, so 1Password cannot verify the identity of the browser. It might be what is happening here too.

  • YaronYaron

    Team Member

    @richardevs You can try fixing it by:
    1. Quitting Chrome, then quit 1Password by right clicking on the little 1Password icon in the top menu bar and select "Quit 1Password Completely".
    2. Right click the Finder icon in your Dock and select "Go To Folder".
    3. Paste this line and click on "Go": ~/Library/Application Support/Google/Chrome/NativeMessagingHosts/
    4. Delete the .json file in there.
    5. Open and unlock 1Password, then open Chrome and see if 1Password X now integrates with the app properly.

  • I believe that this issue of 1password failing to autofill and returning to the favourites list is a known issue and has been for a while. https://discussions.agilebits.com/discussion/comment/528924#Comment_528924

    Is there any update? It is making the use of 1password endlessly frustrating.

  • @Yaron I follow the steps and sadly it did not fix my 1Password X integration.
    Also, there is a weird bug in 1Password X being the password input screen will froze when entering password (but actually I can still do delete and input new characters, it is just that ui has frozen), things would return normal after i unlock it.

  • YaronYaron

    Team Member

    @pdjwa We're hoping to release a fix soon!

    @richardevs Can you email us the console logs from your browser so we can see why the integration is not working for you? https://support.1password.com/cs/extension-console-log/

    Regarding the UI freezing - this is a known Chromium bug that affects many extensions - it only happens if you are using an external monitor. If you move Chrome to the main display then you will not experience it. However, this is more of a graphical glitch and you can still enter your Master Password even though it looks like it is frozen, then hit Enter and it will unlock 1Password properly. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file