Getting 1Password on macOS to respect Auto-lock Security preferences

I'm running 1Password 7, Version 7.3.3.BETA-2 (70303002) on my Mac alongside version 1.17.1 of 1Password X in both Chrome and Brave, and both have the "Integrate with 1Password for Mac" option switched on. My Mac is running 10.14.6 with all the latest security patches.

I work at home and have my overall system quite locked down, so I'd like 1Password's behavior to be that anytime my Mac is unlocked, so too is 1Password.

Thus, I've got all 5 checkboxes unchecked in the Auto-lock section of 1Password's Security preferences.

However, the 1Password app (and by association, 1Password Mini and 1Password X) locks frequently throughout the day despite my settings, and I find myself typing in my master password many more times per day than I'd like.

I do realize I'm running a beta; if this is potentially a bug, I'm happy to submit logs if that would be helpful.

Thanks!


1Password Version: 7.3.3.BETA-2 (70303002)
Extension Version: 7.3.3.BETA-2
OS Version: 10.14.6
Sync Type: 1Password Family account

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @monticola! It does appear that you've run into a bug. What's going on here is that 1Password X isn't respecting your auto-lock settings in 1Password for Mac. We're working on improving that behavior, but I've found a workaround in the meantime. Go ahead and open the 1Password X settings page by right clicking on the 1Password icon in your browser toolbar, then choose settings. Temporarily disable Desktop App Integration at the top, then adjust your auto-lock settings. For your situation, you can disable the "Automatically Lock 1Password" option so that 1Password for Mac will be in control of the lock settings. Keep an eye on it throughout the day and let me know how it works for you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file