autofill not working for captiveportal w/DuckDuckGo browser, and secondary vault

Android 10: I have my work related credentials in a separate vault.

When I try to autofill the wifi captive portal at my workplace,
1password7 does not show me the credentials, or even find it using search.

If I connect directly to 1password, and either turn on "All vaults" or to "vault: work",
I can find it there.

Is this is known issue of sorts?

Kannan


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:autofill not working for captiveportal w/DuckDuckGo browser, and secondary vault

Comments

  • andiAGandiAG

    Team Member

    Hi @kv3, Autofill should show you any items which are available in All Vaults. Could you confirm that your Work vault is ticked in Settings > Vaults?

  • @andiAG

    ok, There seem to be two settings:
    a) A multi-colour flower icon on the top left, that shows different vault selections in blue. What i choose there is specifically when I open 1Password as an application and search/manipulate. Even if I specifically choose the "Work" vault (it shows up in highlighted in blue for me), that is not relevant for autofill.
    b) There is a separate Settings (bottom right icon) -> Vaults with check boxes. I need "Work" to be enabled for inclusion in "All vaults" here. autofill is driven by this Settings icon.

    Did I get that right?

    If so, some follow on questions then.

    It looks like each instance of 1Password 7 (1p7 on work mac, 1p7 on home mac, 1p7 on my home windows machine, each instance) has a separate notion of "All vaults", which brings flexibility.

    For 1passwordX, I thought this would be controlled in the cloud, but it looks like each browser instance has its own "Settings" to control autofill behaviour, in a local/browser specific setting.

    Real cool, thanks

  • periperi

    Team Member

    Hi @kv3. Regarding your first message, 1Password can only fill Login items, so if the password you're trying to use is not a Login, you won't see it available for filling. Is the item in the Wireless Routers category or some other category?

    Regarding your second post, it sounds like you have it right. Let me explain. 1Password will open to All Vaults by default. However, you have the ability to exclude certain vaults, so that you don't have to see their contents all the time. If you got o Settings > Vaults, and turn any vaults off there, then they won't show up under the All Vaults umbrella. You can always click on the vault list and view each vault separately, though, whether or not it's included in All Vaults.

    This is customizable on each device. So, say you have a work computer and you only want your work passwords to show up on that computer, and you don't want them always showing up at home. You can set up 1Password on your home computer to exclude your work vault, and vice versa. You can find more info here: https://support.1password.com/all-vaults/

    Let us know if you have more questions.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file