Android 10 autofill doesn't use work instance

I have 1password installed on Android 10 in both my personal and work instances (using Android for Work on a Pixel 2XL). I have enabled the autofill and accessibility services in both of these installs however when attempting to autofill in Chrome in my work profile, 1password appears to be using the vaults from my personal account.

The autofill/accessibility services definitely seem to be correct for the work profile (if I enable them only in my personal profile the browser doesn't offer 1password autofill options) but if I use fingerprint auth, it doesn't find a matching site that I know is there and if I use my master password, my work vault password doesn't work but my personal vault one does.


1Password Version: 7.3.1
Extension Version: Not Provided
OS Version: Android 10
Sync Type: Not Provided
Referrer: forum-search:android for work

Comments

  • brentybrenty

    Team Member

    @amf: Thanks for reaching out. I’m sorry for the difficulty! Work profiles are something that's handled by the OS, so it isn't something 1Password has any control over. However, there are some things you can try that might help.

    1Password for Android uses the Autofill and Accessibility services to fill your credentials in browsers and apps. These services don’t always work reliably with Android for Work, so to sign in to an account, you may need to copy or drag your details from 1Password by opening it alongside the app you're trying to fill into:

    See two apps at the same time on Android

    It sounds like that's the issue you're running into: the work profile pulling from the personal profile when using Accessibility to fill. Hopefully that's something that will be improved with future Android updates. Android 10 helped a bit compared to 9, but that's one issue that remains elusive.

    In case it helps you or anyone else:

    To use Fingerprint Unlock with 1Password on a work profile

    1. Open your Settings app, then go to Security > "Work profile security".
    2. Tap Advanced > Fingerprint, then follow the prompts to add your fingerprint.
    3. Open and unlock 1Password.
    4. Tap Settings > Security, then tap to turn on Fingerprint Unlock.
    5. Place your finger on the fingerprint sensor.

    To use Fingerprint Unlock with 1Password on a work profile

    1. Open and unlock 1Password in your primary profile.
    2. Tap Settings > Filling.
    3. Tap Autofill to turn it on. In the list of Autofill services, tap 1Password, then tap OK.
    4. Repeat steps 1-3 in 1Password on your work profile.

    Let me know how it goes! :) :+1:

  • As an update on this after a little more experimenting. It appears that in Chrome, the password fill is being performed by the accessibility service not the autofill option. The key problem that I hadn't noticed the first pass through was that, when enabling the service from my work profile install of 1password, the "You're using this app outside of your work profile" notification is shown - the accessibility service is only enabled in the main phone profile so only that instance of 1password will ever be launched by the service.

    For me currently the autofill service doesn't offer any option to do so in Chrome at the moment - though I don't currently think that's any fault of 1password.

  • periperi

    Team Member

    Thanks for the update, @amf. Autofill should work in Chrome as of our latest update (7.3.2). If you haven't yet updated, please make sure to update as soon as it's available. Let us know if that helps!

  • The 7.3.2 update arrived for me today and it does appear to be working better - thanks!

  • periperi

    Team Member

    Thanks for the update, @amf! I'm very glad to hear that!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file