Getting “1PasswordAgent.app” would like to access files in your Desktop folder - constantly

Upgraded to Catalina, everything was fine with 1Password except I cannot get rid of this authorization popup. No matter if I click Don't Allow or OK it just reappears. I have verified numerous times that 1Password has the right permissions in security settings, and I have toggled those setting back and forth a few times as well. Rebooting does nothing. Any clues?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • I guess I'm the only one?

  • I am getting this same message when I reboot my mac under Catalina. Under Security & Privacy > Privacy > Files and Folders the Documents Folder is checked under the 1PasswordAgent

  • BenBen AWS Team

    Team Member

    Hi folks,

    How are you syncing your 1Password data? What do you see under 1Password > Preferences > Sync (if that tab is available)?

    Ben

  • No Sync options shown. This is really annoying, all updates to Catalina are done, and the "1PasswordAgent.app" is constantly in in a unresponsive state. You cannot dismiss the error message which acts like a modal window, which BTW continues to function. IOWs, I can open the Preferences>Security>Files and Folders pane and I can click the modal "OK" or "Don't Allow" and watch it change the state of the permissions in the preference pane; yet the modal never goes away. (and yes, I know I am using "modal" incorrectly, but it acts just like it a modal window should, except that I can get control of parent windows with it present, I just need to drag the window to a place on the screen where it doesn't interfere with work)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file