The 1Password 7 app has me locked out of everything now

tl;dr because of an account recovery I have a new key but the 1Password 7 app on macOS won't let me change it. I can change it on the iPad so I would think you could do the same on macOS. So the question is. How do I get the 1Password 7 app on my iMac to use the new Secret Key?

Details below

I recently went thru the upgrade from 1Password 6 to 1Password 7 as an invited family member.
1. I chose to move my then current 1Password iCloud synced vault to 1Password.com.
2. I chose a different 1Password master password than the one I used to open my 1Password 6 vault.
3. I stored that master password in 1Password and, like I do with all my passwords, forgot it.
4. I logged into 1Password (don't remember which device) using the old 1password 6 password. It showed duplicate entries for everything. Apparently it was showing me both the old iCloud password and the 1Password.com passwords. I went into settings and set the vault to the 1Passwod.com vault (I think) and saw that there's only one entry for everything so that seemed to work.
5. I tried to login using the 1Password 7 app on macOS but it wouldn't allow me to use the old 1Password 6 vault password. I thought it was because it needed the new Master Password so I went thru the recovery process to get a new Master Password and key, Copy/pasting into an Apple Notes app note.
6. I can now log into the 1Password.com account using this new Master Password and I can see my vault with all the entries.
7. I still cannot login using the 1Password 7 app. I have tried using the old 1Password 6 password and the new Master password that works for gettin me into 1Password.com
8. I cannot modify any preferences in the 1Password 7 app, such as deleting my 1Password 7 account, or changing the key. I have deleted and re-installed the app but that hasn't helped.
9. I used the latest 1Password app on my iPad and it wanted me to enter my Master Password. I must have used the iPad in #4 and migrated the iPad over to using the new 1Password.com account. Here's a major clue I think: the iPad would not take my Master Password which made me realize it was still using the old Secret Key. I reset the key to use the key I received when I went thru the Account Recovery and I could now login. This is the problem with 1Password 7 app on macOS. It's still stuck on the old key. This is where #8 comes in. I can't change it, it's greyed out.

Note The iMac is on Catalina. The iPad and iPhone are on 13.1.2. The iPad has migrated to the new 1Password account data


1Password Version: 7.3.2
Extension Version: 7.3.2
OS Version: macOS 10.15
Sync Type: iCloud and 1Password.com

Comments

  • ag_anaag_ana

    Team Member

    Hi @ngkrueger! Welcome to the forum!

    We will be happy to help you with this. I noticed that you have also sent us an email about the same issue, and that my colleague Carlos has replied to you there already. So we don't duplicate the answers, let's keep the conversation going via email.

    ref: HTU-24784-738

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file