After upgrading to 7 does not fill and popup window shows up instead

I have a perpetual license for 1Password 6, but it recently stopped working with Safari, and apparently isn't being updated by Agile Bits.

So I felt forced to buy the much more expensive monthly/yearly subscription, since I figured I'd get left out in the cold again if I bought another "perpetual" license.

Anyway, upgrading to 1Password 7 seems to have introduced a new problem instead: Pressing Command+' (which fills out a user + password in Safari) now suddenly opens a popup window and does nothing on many websites.

I've tried removing and re-installing the Safari extension and 1Password, but the same problem keeps happening.

I can then manually re-apply the "Autofill" function via a blue button in the rather annoying popup window (which wasn't there in v 6), but this either doesn't work at all or only fills one field correctly.

All of these websites worked fine with 1Password 6 and Safari. And still work fine on my other computer, which is why it's certainly not the websites that have changed, but the 1Password 7/extension that's not working properly.

This fill function is a major selling point of 1Password for me, so I hope this is a bug to be fixed soon, and not something we have to live with?

Also a second very annoying bug: Manually copy+pasting from 1Password 7 does not work. I can copy (and it looks like it's copying) and I can press paste, but nothing is pasted.


1Password Version: 7.3.2
Extension Version: 7.3.2
OS Version: OSX 10.4.6
Sync Type: iCloud

Comments

  • YaronYaron

    Team Member

    Hey @Lagerfeldt ,
    After Apple released Safari 13 and shut down the Safari Extensions Gallery for good, 1Password 6's ability to autofill in Safari was gone for good. You can read more about it here: https://support.1password.com/kb/201909/

    It sounds like you might have some issues on your computer there with either 1Password and/or Safari. Let's try with some basic things first:
    1. Quit Safari completely by right clicking its icon in the dock and select "Quit".
    2. Go to the Applications folder on your Mac.
    3. Locate a folder there called "Utilities" and enter it.
    4. Open the "Disk Utility" app that resides there and click the "First Aid" button at the top are of the app. It might take a while so give it time to complete.
    5. Once it is done, close Disk Utility, then open Safari and see if the 1Password extension is there and functioning properly/autofilling.

    Let me know how it goes.

  • Hi,

    Thanks for the explanation on 1Password 6.

    Everything is working fine with my computer. It's a brand new iMac 27" with a standard install, this one just for office use.

    I've quit Safari, run First Aid in Disk Utility. Everything is OK. The 1Passsord extension is there in Safari.

    However, it isn't auto-filling (f that's what you call manually pressing Command+') the webpages as 1Password 6 is.

    If I do this on my other computer with 1Password 6 it's filling in all the pages. 1Password 7 will only work with a few pages and instead pops up this window instead. Forcing an "Autofill" there only fills in one or none of the fields and copy+pasting manually does not work at all.

  • YaronYaron

    Team Member

    Thanks for the additional info @Lagerfeldt .
    1Password 7's autofilling logic is a bit different than 1Password 6, so I'd like you to try and create a new login in 1Password 7 for one of the websites you're having troubles with and see how that goes:
    1. Open 1Password 7 on your Mac and locate a login of a website where it does not autofill properly.
    2. Copy the credentials in that login to a temporary location, then delete this login from 1Password.
    3. Go to the website and manually fill in your login credentials and log in. 1Password should pop up and ask you if you'd like to save it - confirm and save it.
    4. Log back out, this time try to autofill with 1Password and see if it works properly.

    Let me know how it goes.

  • Thanks for the suggestion, although it didn't work.

    Here's what I did:

    1. Went to one of the websites that doesn't work with 1Password 7, but does work with 1Password 6.
    2. Copied the login/password to a temp note, deleted the same entry in 1Password 7.
    3. Manually filled in the login/pass on the website. 1Password 7 correctly popped up and saved this info as I pressed return. Looks 100% correct inside 1Password. So far so good.
    4. Logged out of the website and tried to autofill with 1Password. DIdn't work, instead 1Password 7 opens up the popup window and does nothing. Autofilling by pressing the button only fills in the password on this particular website.

    I repeated this with a similar website (same login procedure, but different part of the website) and in this instance 1Password 7 wouldn't even save the credentials in 1Password 7 (1Password never tried to or opened at all).

    Doing this with 1Password 6 works fine, but 1Password 7 doesn't work.

  • YaronYaron

    Team Member

    Thanks for the additional and detailed information @Lagerfeldt .
    Can you please share the URL of the website you tried this on? I'd like to test it here and see if I can find a way to make it work. If I can't, I will forward it to our devs so that they may improve 1Password's autofilling logic to work better on that website and any similar login page.

  • edited October 17

    Thanks, let's try that.

    However, I prefer not to share the URLs in public since they relate to health information, taxes, and several online banks.

    I can share a handful of them in by email/PM if you have a way of doing that?

    Please notice that this relates only to iPassword 7's autofilling logic, since it's working fine in iPassword 6, i.e. it should be fairly straightforward (nothing ever is when it comes to coding, right?) to check out what's iPassword 6 is doing right.

  • YaronYaron

    Team Member
    edited November 14

    Sure @Lagerfeldt , let's try that.
    Please email us at [email protected] with all the details and a link to this forum discussion.

  • Hello folks..I'm having the same experience with my recently installed 1Password v7. The autofill function does't work at all, so I'd be very interested if you've had any luck dealing with this.

    Yaron..would it be possible for you to direct us to any 1Password 7 customer(s) where the autofill process works correctly ?

    Cheers,

  • 1Password has gone backwards with regard to filling in login details since upgrading to 1Password7 (standalone version).

    In 1Password6, when you right clicked in a field in the web page login form and selected 1Password from the pop-up menu, when the 1Password window appeared, the correct item was selected from the list of login items, the list had been scrolled down to that item and its details also shown so you just had to click to fill in the login details.

    Now in 1Password7 the window appears but the list simply starts at the first item and those details are shown. 1Password knows which item it is because if you scroll down then the correct item is selected in pink. You then have to click on that item to highlight it in blue and show its details and then click autofill. Way too many clicks.

    This behaviour is happening in Firefox and Safari and is a real pain. If I had known this I would have moved to an alternative solution.

  • YaronYaron

    Team Member
    edited November 14

    Hey @NormCole ,
    The autofill feature of 1Password is one of the main reasons people love and use 1Password. Autofilling works for everyone unless they have a technical issue on their setup or they're trying to autofill in a problematic website that prevents it.

    If you are experiencing issues on a specific website I'll be happy to test it for you if you share the URL. If 1Password's autofill does not work at all, I suggest you send us a diagnostics report so we can investigate the possible causes in your setup and provide you with a solution or troubleshooting steps :)
    Here's how to generate such a report: https://support.1password.com/diagnostics/
    Send it to [email protected]

    @simoncook , it sounds like your 1Password is set to open to "All Items" instead to "Suggestions". Please try this:
    1. Open the 1Password app and unlock it.
    2. Click the "1Password" menu on the top left of the screen next to the Apple logo and select "Preferences".
    3. In the new preferences window that opens, select the "Mini" tab and set "Open 1Password To: Suggestions".
    4. Close that window, now try and autofill and see if 1Password shows you relevant results :)

  • edited October 24

    So here's the workaround that Yaron (thanks!) found for me - and I've got to say I hope this will be fixed as it's a bit cumbersome:

    1. Delete the existing problematic login in 1Password (making a temporary note of any information somewhere else)
    2. Go to the problematic website (in my case any website using the NemID applet) and fill in your information manually, but don't press return/login yet.
    3. Ctrl+click or right-click on one of the input fields and open 1Password from the contextual menu.
    4. Press the settings cogwheel in the upper right corner of the 1Password pop-up window and choose "New login" to save this login.

    Login and out if you want to.

    In the future when visiting this website do the following to login:

    1. Move your cursor to the user field and click on the field, but don't input anything!
    2. Try to autofill by pressing Command+' (or whatever similar key command your system uses even though it won't work.
    3. Autofill won't work, but after the 1Password window opens, now press return to autofill.
  • YaronYaron

    Team Member

    I'm glad we were able to find this workaround for these NemID login windows on your websites :)
    In case someone else is having troubles with saving the login manually, here are instructions with pictures: https://support.1password.com/save-login-manually/

    When login pages (or applets windows, in this case) have their own autofocus logic that prevents 1Password from being able to focus the field it needs to, clicking on the field that isn't being autofilled will force focus and allow 1Password to autofill it properly. So clicking on the username field in your instance and only then autofilling did the trick :)

    Thanks again for working on this with me.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file