Auto-Disable 1Password X Locally when 1Password companion app is installed

Hello!
I currently use 1Password on Windows and Linux.
My setup is the following:
My Laptop computer uses Linux, so I use 1Password X for Firefox there.
My Desktop computer uses the 1Password binary, so I have the 1Password Companion extension for Firefox installed.

My use case:
I keep my Firefox extensions synced using Firefox Sync, so I need 1Password X to be enabled at all times, otherwise I have to re-enable it every time I use it.
I however prefer the 1Password binary app.

My suggestion:
Would it be possible to add a check in the 1Password X extension to automatically un-register keyboard shortcuts, field commit hooks, suggestion dropdowns, contextual menu entries and all other 1Password X-provided features, if the 1Password companion extension is found?
Even better, being able to determine if the 1Password Companion has a working connection to the 1Password binary, and if not functional (removed binary, etc), re-enable 1Password X.

I have had this issue since 1Password X was released and hoped this Quality of Life update would land soon, in vain. So I decided to report it myself.

Dual login interface, two different keyboard shortcuts, two menu entries, two commit hooks, this is a little hairy to manage, I'd appreciate a fix.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Windows 10, Linux
Sync Type: Not Provided

Comments

  • kaitlynkaitlyn

    Team Member

    Hey there @Xenhat! That's an interesting use case indeed. I don't see us implementing a feature like this, and it's extremely rare where I see users want 1Password X enabled but its features to be disabled. However, I'd like to help you get as close as possible to the experience you're wanting.

    Just to confirm, it sounds like you're wanting 1Password X to remain enabled (that way it doesn't become disabled on your Linux machine), but hang there passively. I'd suggest disabling the 1Password X inline menu, which is the menu that appears underneath fields so you can have easy access to filling. To do that, you can disable the option to "Offer to fill and save passwords." I don't believe those settings will sync to your other device, but I'm hoping you can double check it for me just to be sure.

    All in all, the desktop-dependent 1Password extension that you use on your Windows computer should work even though 1Password X is enabled. Without seeing the inline menu in your above screenshot, it'd be hard to tell 1Password X is even there aside from the icon in your browser toolbar. I'm curious if that helps you achieve what you'd like to see with features we already have. Let me know!

  • Hello!
    I did not even know that 1Password X had settings now! hahaha. It's been a while I've looked deeper into that extension. I've been content to simply use it.

    I unfortunately found a bug with the "Offer to fill and save passwords" option:
    When disabled, it is impossible to invoke 1Password X with the right click contextual menu. The toolbar icon works fine, however.

    Thankfully, disabling "Show autofill menu on field focus" is sufficent in most of the cases, for the time being.

  • kaitlynkaitlyn

    Team Member
    edited October 22

    @Xenhat – I'm glad you got a chance to explore the settings page. :)

    Are you needing to use 1Password X on your Windows computer, or are you using the desktop-dependent extension there? Disabling the "Offer to fill and save passwords" setting will get rid of the 1Password X inline menu, which is what the right-click contextual menu is for. I was under the impression that you didn't want to use 1Password X on your Windows computer, though. I didn't think that those settings synced between different machines – can you double check it disabling that setting in Firefox on Windows also disables it on your Linux machine?

    Disabling "Show autofill menu on field focus" is a great alternative, and I went back and forth on which one to recommend. We may end up going with that one in the end (especially if the settings do actually sync), but at least you're familiar with both now.

  • My linux laptop is currently not in a state that can run firefox (reinstalling it), I will reply when I have new information. Things kind of happened all at once

  • kaitlynkaitlyn

    Team Member

    Things kind of happened all at once

    That's how it always seems to work, @Xenhat. I hope things are looking up, and feel free to let me know whenever you've got Firefox reinstalled. ❤️

  • Hello! Sorry for taking so long to reply.
    I have just confirmed that changing the Autofill setting in either instances of 1PasswordX does not modify the other, even after triggering a forced Firefox Sync. This seems to fill the bill. Thanks again!

  • kaitlynkaitlyn

    Team Member

    @Xenhat – That's great to hear! You're very welcome. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file