TouchID Support in new beta?

Now that the 7.3.3.BETA-2 has expired I want to ask wich version does support TouchID on macos?

Currently I'm using 7.3.3.BETA-2 Mac App together with 1.17.2.beta Password X.


1Password Version: 7.3.3.BETA-2
Extension Version: 1.17.2.beta
OS Version: macos 10.15
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @mxhjaymems: All recent versions (going back to 6.something) of 1Password for Mac support Touch ID. If you're referring specifically to desktop app integration with 1Password X, 1Password for Mac version 7.4 has been in beta for a few weeks now:

    https://app-updates.agilebits.com/product_history/OPM7#beta

    Cheers! :)

  • Hey @brenty, yes I'm referring to the desktop app integration with 1Password X.
    With 7.4.BETA-0 the connection to the 1Password Mac App does not work. Therefore it's not possible to unlock 1Password X with TouchID - like it was possible with 7.3.3.BETA-2 1Password Mac App with 1.17.2.beta of 1Password X.

  • brentybrenty

    Team Member
    edited October 28

    @mxhjaymems: Well, I know it's working for others in 7.4, so there's a good chance we can get it working for you too. :) There is an issue we're aware of with Chrome though that we have a fix for in an upcoming beta. If that's what's happening to you, deleting the 2bua8c4s2c.com.agilebits.1password.json file in Chrome’s support folder will resolve it in the mean time. Here's how:
    1. Quit 1Password by right clicking the little 1Password icon in your Mac's menu bar at the top and select "Quit 1Password Completely".
    2. Remove 1Password X beta from Chrome.
    3. Quit Chrome by right clicking its icon in your Dock and select "Quit".
    4. Right click the Finder icon in your Dock and select "Go To Folder..."
    5. Paste this line there and click on "Go": ~/Library/Application Support/Google/Chrome/NativeMessagingHosts/
    6. Delete the 2bua8c4s2c.com.agilebits.1password.json file in there.
    7. Open and unlock 1Password.
    8. Open Chrome and reinstall 1Password X beta from here.

    Let me know if that helps, and, if not, specifically what is happening in your case. Making sure you've updated and restarted Chrome can help too. Let me know how it goes. :)

  • Thanks, that has worked as expected! 🎉

  • kaitlynkaitlyn

    Team Member

    I'm glad to hear that, @mxhjaymems! We'll be here if anything else comes up.

  • edited November 1

    After it worked for the last 3 days, it stopped working today.
    I got error messages like "1Password could not trust Chrome, app is not from a verified Developer"

    After deleting the 2bua8c4s2c.com.agilebits.1password.json file once again, it works again

  • brentybrenty

    Team Member

    Great! Thanks for letting us know. I'm glad that @Yaron 's instructions (which I stole) helped. Have a great weekend! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file