Cross-Platform Compatibility Issues

Hi, recently new user of 1P for Mac/Windows/iOS Pro via Dropbox. Encountered a login error today on Windows using Chrome (21.0.1180.89 m) to access American Airlines AAdvantage site.
  1. Upgraded all passwords via 1P Mac 10.8 and Safari. Light use of Mac Chrome for a few sites.
  2. Occasionally use 1P on Windows, and rely primarily on Chrome.
  3. I confirmed via iOS that the password for AAdvantage is correct w/in 1P. Ultimately changed the password, then logged-out and back in to test. Successfully saved.
  4. Sampled other logins for same error. Confirmed same problem for Schwab login, but found that copy/pasting password from the extension works.
  5. Passwords appear to be syncing properly.

Is this a known issue for cross-platform compatibility in how 1P saves the login steps?

Comments

  • khadkhad Social Choreographer

    Team Member
    The data format and extension filling code is identical between Chrome for Mac and Chrome for Windows. I'm not sure I understand the discrepancy. Are you saying that filling a Login works in Chrome for Mac but not Chrome for Windows? You mentioned two different sites and one or both may be resolved. It was hard for me to tell from what you wrote. Perhaps if we just focus on one URL where you are having trouble it will be easier to see the issue and resolve it.

    Please let me know. Thanks!
  • Yes, that's exactly what I've encountered. It appears Chrome on Windows does not submit login details in the same way Safari or Chrome on Mac does for the Schwab or American Airlines login pages.

    I first encountered the problem on the American Airlines site and reset the password while on Windows. Subsequently, Chrome and 1P were able to login to that site without issue on Windows. Both Safari and Chrome on Mac work fine now that the new password has synched.

    I then attempted to login to a sample of other sites using Chrome on Windows. The Schwab login encountered the same thing, only I did not reset the password. Instead, I used my iPhone to verify the password was synched correct between the 1P apps on iOS and Windows. I then manually copied/pasted the password directly from 1P on Windows into the field for a successful login. Logged-out, attempted to use 1P again, and it failed again. 1P on the Mac still works without issue.

    Hope this clarifies.
  • khadkhad Social Choreographer

    Team Member
    Hm. I'm sure it is just me, but I feel like I am even more confused. image' /> Let's try this:

    1. Does your Schwab login work properly across Mac and Windows?
    2. If not, is the problem with filling the credentials or submitting the form? You can easily test filling by disabling autosubmit and then submit the form manually.
    3. If your Schwab Login is working well, as I mentioned in my previous post, let's focus on one specific URL where you are having trouble. Is the problem with filling the credentials or submitting the form?

    There shouldn't ever be any need to reset any password(s) if you are having trouble with filling or submitting Logins. I'm not sure if that was something you just happened to do while in the middle of troubleshooting the issue and just thought it would be a good idea to mention or if you actually reset the password in order to resolve the issue. If the latter, there should be no need.

    Please let me know the answers to the above questions. I apologize if you feel you have already answered them. I'd really like to help, but I am having a hard time following you since you are referring to using multiple Logins in multiple browsers on multiple platforms. Let's take it one step at a time: one Login in one browser on one platform. :)

    Thanks for humoring my pedantry. It just gets hard to troubleshooting more than one issue at a time especially when they may be closely linked.
  • Responses to your queries above:

    1. Yes, the login/pass work properly on Mac and iOS (both iPhone & iPad) when using 1P apps or extension in Safari or Chrome. No on Windows when using Chrome extension, but yes when copying/pasting the password from 1P application into password field on the login page.
    2. Based on your question, I went looked back to my steps. Login/Pass are populated on the page whether autosubmit is enabled or disabled. Schwab login fails under autosubmit and when manually clicking the "Log In" button. Decided to reveal and inspect the password the Chrome extension and 1P Windows app are populating. Discovered the Chrome extension's password has not synched, and is still 16 long that was replaced last week with 20 long while on Mac 10.8. The 1P Windows app has the correct 20 long password, which is why manually copying/pasting the password from the application to the password field yields successful login, while relying on the Chrome extension to populate the password fails whether autosubmit enabled or disabled; I had not copied/pasted the password from the extension.
      • To be absolutely clear, I have discovered the Windows Chrome extension is not synched with the 1P Windows application, though the 1P Windows application is properly synched, as is Mac and iOS, all via Dropbox.
    3. Based on discovery in #2 above, it appears this is a sync issue, not a cross-platform compatibility issue. As I changed the Schwab and American Airlines passwords on the same day last week, I will presume this same error occurred on both sites. (Note: I was locked-out of the American Airlines account and had to change the password to regain access before there was time to troubleshoot)

    As such, to recast this in the appropriate light, why would the Windows Chrome extension not be pulling the latest password detail from Dropbox as 1P Windows is doing? Also, as it has not done so on its own after a week, how do I force Windows Chrome extension to update?
  • khadkhad Social Choreographer

    Team Member
    The extension will be out of sync if the Helper is unable to connect. Please follow the steps listed in the User Guide for troubleshooting the browser extension:

    http://help.agilebits.com/1Password_Windows/helper-not-connected.html

    Following those steps should resolve the issue in 99% of cases. Please pay special attention if you are behind a proxy server or running one of the programs listed in steps 7:

    http://help.agilebits.com/1Password_Windows/antivirus-configuration.html

    Simple removing and reinstalling the extension (step 3 in the troubleshooting guide) may get things working again.

    Please make sure you try all the steps in order, though, and let me know how it goes.
  • Thank you! Updating to version released on Sept 10 fixed the issue and am now able to utilize autosubmit. Will refer back to linked steps should the issue repeat.
  • khadkhad Social Choreographer

    Team Member
    Great news! Thanks for letting me know that everything is working well. :)

    If we can be of further assistance, please let us know. We are always here to help!
This discussion has been closed.