How do I get Chrome to never show login pop-up?

pbryanwpbryanw Junior Member
edited September 2012 in 1Password 4 for Windows
Hi,

Every time I login to my Bank, HSBC UK, I get a Chrome pop-up asking me whether I want to save the password (see attached pic).

However, I can't seem to find a way to get the pop-up to never show again for this login. I seem to recall an option in previous extensions to never remember the login (and it's still in the Firefox extension) but it doesn't appear any more in Chrome.

Anyway, would appreciate any help in stopping this pop-up from showing.

Comments

  • khadkhad Social Choreographer

    Team Member
    Unfortunately, there is a bug right now and the "Never save for this site" option is only available in the Safari and Firefox extensions. I apologize for the inconvenience, but you'll need to either click the "X" to dismiss the autosave prompt or press Esc on your keyboard until we get this fixed.
  • pbryanwpbryanw Junior Member
    edited September 2012
    Hi, thanks for the quick reply, help and explanation. Look forward to a fix for this in a future update. (y)
  • khadkhad Social Choreographer

    Team Member
    Thanks for your patience. I don't have a time frame at the moment, but hopefully we can resolve this sooner than later. :)
  • Any update on this?
  • khadkhad Social Choreographer

    Team Member
    The team has been pretty busy with some other projects, but this is definitely still on our radar. For now, you can manually add domains to the "Don't autosave on these domains" list in the extension's Settings > Logins. The issue is only in Chrome, by the way, so if you switch between browsers I want to be sure you know that you will be able to choose "never" in the autosave prompt in other browsers.

    Don_t_autosave_on_these_domains-1-3-1-1-1-20130106-153931.png
  • khad wrote:

    The team has been pretty busy with some other projects, but this is definitely still on our radar. For now, you can manually add domains to the "Don't autosave on these domains" list in the extension's Settings > Logins. The issue is only in Chrome, by the way, so if you switch between browsers I want to be sure you know that you will be able to choose "never" in the autosave prompt in other browsers.

    Don_t_autosave_on_these_domains-1-3-1-1-1-20130106-153931.png


    Cool - that'll hold me over.
  • pbryanwpbryanw Junior Member
    edited January 2013
    khad wrote:

    For now, you can manually add domains to the "Don't autosave on these domains" list in the extension's Settings > Logins.


    Thanks from me too - I also didn't know about this feature. At the moment, I've disabled "Ask to save new logins" and am manually adding logins. Might try the above, quoted approach instead as I only get this problem on one or two web-sites.
  • khadkhad Social Choreographer

    Team Member
    Glad I could help for now. I should have mentioned it sooner. :)
  • Hi,

    I have the same problem, but I found that if I save the way 1Password wants it stays fine, but when I change later to my way it comes back again. let me clarify.
    I saved password as domain.com.login (email here) , then later on I changed manually to Adam - domain (login) for easier search. When I input my name first then many logs comes up and it`s easier for me to find it. Then, when I go to that website login page it ask me again to save log. I didn`t know at the beginning of using 1Password, so I had 3 the same logins. I use Roboform too. It helps me to transfer all logs to 1Password.
    By the way, it`s not on topic, but please add Cash card in Wallets. I found only credit cards. I use SBP Wallet which has everything possible, but they don`t update anything recently. I love 1Password because I have all-in-one, SPB Wallet and Roboform

    Adam
  • khadkhad Social Choreographer

    Team Member
    Adam, 1Password can only check to see if you already have a Login saved if you use 1Password to fill the login form. If you are filling the login form with another application, your browser's password manager, or anything else 1Password will prompt you to save a new Login item since it cannot check to see if there is already one saved. To avoid this, just make sure you are using 1Password to fill the forms.
  • I'm trying to disable autosave across an entire subdomain to no avail. We have developer sites internal to our company, and every time I log in with a test account, the autosave bar pops up in Chrome.

    I've tried adding ".dev.mycompany.com", "dev.mycompany.com" and "*.dev.mycompany.com" without any luck.

    Am I doing something wrong, or is this just not currently supported?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @atraver,

    Try adding mycompany.com to the list, it should then work for all subdomains. Note that we don't recognize beyond the subdomain, so only sub.domain.com or domain.com will work, the rest won't work. We're working on some improvements to make it work better.

    Hopefully, the domain filter will work for you.

  • Thanks for the response, @MikeT. Unfortunately, I can't add an entire domain, since we have public-facing sites that I'd like to store my credentials for. It sounds like I'm SOL for now, but I'm looking forward to the updates!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @atraver,

    How often do you create new items for that site? The reason that I'm asking is that if it is not too often, you can disable it for the whole domain and have 1Password save it manually by pressing the 1Password button to press the Add button on top right to create a new item. It might be less annoying this way.

  • khadkhad Social Choreographer

    Team Member

    I should also mention that the latest beta build of the Chrome extension adds the "Never for this site" button to the autosave bar. You can switch to the beta channel by selecting the "Allow beta extensions" option on the extension download page or just wait until the next stable release, and you'll get it.

This discussion has been closed.