1Password GPU usage in Windows 10

Hello

Why 1Password is using my GPU?


1Password Version: 7.3.712
Extension Version: Not Provided
OS Version: Windows 10 1903
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Naxterra,

    Thanks for writing in.

    We use Windows Presentation Foundation (WPF) to render our UI, it also uses DirectX to accelerate the rendering of the app. It's not just animation but every UI element you see is rendered by WPF.

  • But why is it using %8 of my GPU? I have RTX2080Ti and this doesn't seem like normal.

  • MikeTMikeT Agile Samurai

    Team Member
    edited November 8

    Hi @Naxterra,

    What is it doing right now? If you close the app window, is it down to 0%?

    I'm not able to reproduce any GPU usage for more than 1-2% on my GTX 1070.

    Has it always been like this or is this a new change?

  • If I close 1Password window usage drops

    It has been like this for last few days

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Naxterra,

    Any recent changes like new GPU drivers or anything that? We haven't had a new update in the last two months and even that didn't have any relevant changes.

    If it is a recent change, it may be your drivers and/or Windows update that has changed something that is causing a bit more GPU than usual.

    If you can narrow down where it is using more GPU, like did it happen when you're editing or syncing? We can look into it and possibly file a report with Microsoft but I'm trying and not able to reproduce anything that would eat 8% of a powerful RTX 2080Ti.

  • Only change was Geforce driver update on 04.11.2019 to version 441.12, maybe that is the issue?

  • MikeTMikeT Agile Samurai

    Team Member

    I have that same GPU driver on my machine, so it may not be it but given different setups between us, we can't rule it out.

    Does it eat up 8% all the time as soon as you open 1Password or do you have to do something first? I need specific steps to try to reproduce, it is possible there's something that could cause it to spike the GPU usage and stay high forever.

    Also, do you use any tools that modifies any app windows like adding extra toolbar icon to move between monitors?

  • It begins to consume my GPU as soon as I open main app window. It is turning to normal if I use mini app version or when I close it.

    Also for my DxDiag you can check https://pastebin.com/4RvArBY2

    I have only one monitor, default Windows 10 UI. My monitor is ASUS ROG PG278QR 2560x1440 @165Hz

    I also tried also below settings from Geforce Control Panel for 1Password Windows app

  • bundtkatebundtkate

    Team Member

    Mike had asked me to check this too, @Naxterra, and like him I'm seeing things sitting around 4%. Bit higher than what Mike sees, but lower than you're seeing for sure. I'm running a 1060, too, so I'm not as fancy as either of you.

    I see your display does support GSync, so I'm curious if maybe GSync might be playing a role. In doing some quick research, I saw a few folks complaining of GSync interfering with a number of other apps. I don't have GSync-capable display and I don't think Mike does either so that's at least one thing you've got on the both of us. This also means I'll have to beg your forgiveness in advance if I'm totally misunderstanding how these settings work. Feel totally free to set me straight if you've already ruled it out and I'm just overlooking it due to lack of experience with Gsync.

    Assuming you still have GSync enabled, any difference if you toggle it off temporarily? I'd restart 1Password after toggling it off, just to be extra careful. A bit of a wild guess here, I'm afraid, but there's some evidence it's worth a test at the least. My display is Freesync, which I know is technically compatible with Nvidia GPUs now so I could finally set that up and give it a test myself, but it's still different tech so probably better to just have you give it a check. Let me know if it makes any difference at all.

  • @bundtkate

    this setting disables GSync for specific program. I encountered slow response time issue in Snagit and this was the workaround for it, so I applied same thing to 1Password but sadly it didn't help.

    I also lowered my refresh rate to 60hz for testing but it didn't change anything either.

  • bundtkatebundtkate

    Team Member
    edited November 9

    Thanks for explaining, @Naxterra. If you couldn't tell by my general hesitancy, I thought that might be the case, but I figured it was better to just ask since you undoubtedly know that system better than I. With the exception of the exact level of usage, this is honestly what's expected at present. 1Password will use some GPU on the lock screen, none when closed, close to none in mini, and you'll likely see a more sizable spike during the actual unlock animation. I agree that it's using more than it should given the power of your GPU and what I see myself, but I'm at a bit of a loss as to why. Do you maybe have other graphics tools you use like MSI Afterburner or similar? Does the display itself have any configuration software (my LG Ultrawide has some windows management tools it comes with, for example) that you could see having an impact here? I feel like this ultimately going to be a question of guess and check or potentially thanks to changes in architecture between the 10 and 20 series, but I'm fairly certain those haven't been that substantial. I'd love to just tell my boss I need a 2080Ti for testing purposes, obviously, but sadly I doubt that would fly so our best bet is probably just continuing to ponder reasonable possibilities and have you tweak things to test so if you have other ideas as well, I'd certainly welcome them.

  • brentybrenty

    Team Member

    To be clear, 1Password does not in any way control the amount of resources the GPU uses to render it. We are not and can not request a specific percentage of its power. We just tell WPF to draw. The OS does the graphics calls to the driver, but as far as what resources are used to accomplish that it's all the driver and hardware. It does seem like overkill in that context, so perhaps a driver update in the future will result in it allocating less -- more in line with what we'd expect for what's really a fairly small task: rendering 1Password's UI. Crypographic operations require much more power.

  • Here is a quick update. Symantec Endpoint Protection is main root cause for GPU related issues. It is not related to 1Password app. I was thinkering with my rig, and while searching slow UI performance of Spotify, I found out SEP is the reason for it. After fresh install via USB stick (SEP even corrupted my Windows repair drive) it all turned to normal. 1Password app is using around %2 GPU now.

  • MikeTMikeT Agile Samurai

    Team Member

    @Naxterra, wow, that's very odd but thank you so much for informing us on what it was.

    I'm glad you got it back to normal now.

  • Yeah, it was literally the most unexpected thing to check but still.. My Spotify was lagging on each song change for like 3-4 seconds. I literally tried everything, reinstalling app, reinstalling graphic drivers, updating network drivers, changing network, using Windows safe mode, using VPN, disabling antivirus (SEP) but nothing worked. In the end I just thought I should give it a go and uninstalled SEP. Then magic happened

  • brentybrenty

    Team Member

    Yeah their track record recently has not been great:

    https://www.zdnet.com/article/symantec-antivirus-crashes-something-again-this-time-chrome-78-browsers/

    Glad disabling it helped you as well!

  • GregGreg

    Team Member

    @Naxterra: We are glad to hear that you've figured it out and it works correctly now. :)

    Please let us know if you have other questions, we are here for you. Thanks!

    ++
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file